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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

 DANGER 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 
 WARNING 

indicates that death or severe personal injury may result if proper precautions are not taken. 
 

 CAUTION 
indicates that minor personal injury can result if proper precautions are not taken. 

 
 NOTICE 

indicates that property damage can result if proper precautions are not taken. 
If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

 WARNING 
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 
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 Introduction 1 
1.1 General introduction 

LOGO! Web Editor is used together with LOGO! Base Module (BM) and LOGO! Soft Comfort. 
This tool helps you create user-defined web pages in the Editor pane, and visually view the 
whole project through Web Server of LOGO! Base Module. 

With LOGO! Web Editor, you can: 

• integrate different components including some variables conveniently; 

• customize individual web pages. 

Document History 
The following edition of LOGO! Web Editor has been published: 
 
Edition Version Comment 
11/2017 V1.0 First edition 
03/2019 V1.0.1 Second edition 
10/2020 V1.1 Third edition 

1.1.1 What's new in LOGO! Web Editor 1.1? 
The features described below are only used for LOGO! Web Editor V1.1. 

New functions 
LOGO! Web Editor V1.1 provides the following new features: 

• Cloud Web Application: You can deploy a LWE V1.1 project to AWS  (Page 50)(Amazon 
Web Services) Elastic Beanstalk and view the deployed project through browsers 
(Page 73). 

Changed functions 
Pages: add new function to create a Login Page (Page 15). 

Global configuration:  

• new IoT thing table to add IoT things. 

Component: the name of component "Digital Value" is changed to "Switch button". 

• Rainbow (Page 36) 

• Trend View (Page 41) 
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• Push Button (Page 29) 

• Webcam (Page 43) 

• Login (Page 45) 

• PDF (Page 26) 

New menu commands 
• File -> Export as BM Https Project (Page 54) 

• File -> Export as AWS Web App (Page 54) 

• File -> Deploy to AWS (Page 50) 

• Window -> Reset Windows (Page 61) 

1.1.2 Basic concept 
Having a general idea of LOGO! Web Editor is the prerequisite for using it. The basic concept 
about the whole project is as follows: 

Project 
In LOGO! Web Editor, project contains Pages and a Navigator. Each page contains pre-defined 
components, such as Text, Image, Digital Value and so on. Global Tag is defined for 
facilitating end user to bind components and variables. 

Pages 
Pages contains a Login page, a Home page and some user-defined pages. Home page is a 
default page, while you can determine whether to create Login page or user-defined pages 
according to your requirements. You can create your own Login page for logging on LWE 
project deployed on LOGO! BM or Cloud. Either Login page, Home Page or other page is a 
web page, and you can visit it in web browser after deploying a project to LOGO! BM or 
Cloud. 

Navigator 
Navigator is a floating page of the web site and it intended to aid users to switch between 
different web pages or log off during the runtime operation.  

Navigator is a floating page for accessing different pages or log off in the deployed LWE 
project. 

Component 
LOGO! Web editor contains a couple of pre-defined components for web page. Each 
component has different render effect in web page. Each component contains some 
properties. 
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Variable 
Variable is read/write data element of LOGO! BM, such as I, Q, AI, AQ and etc. Variable can be 
bound with component. You can read/write variable via components. 

Private Tag 
A private tag that is used for the component it bound with only.  

Global Tag 
A global tag that is declared outside any component and is accessible to all component 
throughout the project.  

Tag Table 
Tag Table is a place to define Global Tags, and you can add, modify, and delete Global Tags 
here. 

IoT Thing Table 
IoT Thing Table is used to create, update and delete IoT things registered in Amazon Web 
Services (AWS). After an IoT thing is created in IoT thing table, this IoT thing can be 
referenced in tag table or component property. 

IoT Thing name 
IoT thing name is the name you fill in IoT Thing table for IoT thing. It must be the same as the 
name you registered in AWS. 



 Introduction 
 1.1 General introduction 

LOGO! Web Editor Online Help 

Operating Instructions, 10/2020, A5E42880034 - AC 9 

1.1.3 Compatibility 

Project compatibility 
If the project is created with a version earlier than LWE V1.1 LOGO!, the project cannot be 
opened with LWE V1.1. If you open the project with the LWE V1.1, LWE V1.1 saves the 
original project and upgrades the original project to V1.1. 

 

LOGO! Base module 
LOGO! Web Editor is available for: 

• LOGO! 8 6ED1052-xxx08-0BA0 

• LOGO! 8 6ED1052-xxx08-0BA1 

Java runtime environment  
LOGO! Web Editor V1.1 is compatible with the following Java Runtime Environment: 

• 1.8.0_191 
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Browser 
LOGO! Web Editor V1.1 is compatible with the web browsers which support HTML5: 

• Microsoft Internet Explorer with minimum version 11.0 

• Mozilla Firefox with minimum version 30.0 

• Google Chrome with minimum version 45.0 

• Apple Safari with minimum version 10.0 

 

 Note 

Siemens recommends you use the latest version of Google Chrome when visiting the 
deployed LWE projects. 

 

Operating systems 
LOGO! Web Editor V1.1 supports the following systems: 

• Windows: Windows 7, Windows 8 or Window 10; 

• Mac OSx: Mac OS X 10.9 Mavericks; Mac OS X 10.10 Yosemite; Mac OS X 10.11 X El 
Capitan; Mac OS X 10.12 Sierra; Mac OS X 10.13 High Sierra; Mac OS X 10.14 Mojave 

• Linux: SUSE Linux 12 sp1, kernel 3.12.74. Compatible with all Linux distributions which 
are aligned with Java 2. You can find the necessary hardware requirements from the 
corresponding Linux distribution. 

1.2 Security information 
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines and networks. 

In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
security concept. Siemens’ products and solutions constitute one element of such a concept. 

Customers are responsible for preventing unauthorized access to their plants, systems, 
machines and networks. Such systems, machines and components should only be connected 
to an enterprise network or the internet if and to the extent such a connection is necessary 
and only when appropriate security measures (e.g. firewalls and/or network segmentation) 
are in place.  

For additional information on industrial security measures that may be implemented, please 
visit (https://www.siemens.com/industrialsecurity). 

Siemens' products and solutions undergo continuous development to make them more 
secure. Siemens strongly recommends that product updates are applied as soon as they are 
available and that the latest product versions are used. Use of product versions that are no 
longer supported, and failure to apply the latest updates may increase customers' exposure to 
cyber threats.  

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS 
Feed visit (https://www.siemens.com/industrialsecurity). 

https://www.siemens.com/industrialsecurity
https://www.siemens.com/industrialsecurity
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 User interface 2 
2.1 User interface - Overview 

User interface  
LOGO! Web Editor starts with an empty pane for the project.  

When you create a new project, the user interface appears as follow: 

• A new project appears in Project tree. 

• Component pane contains all the component information. 

• An empty window for Home Page in the Editor pane. 

• Property pane contains the properties information for the Home Page. 

To help you maintain an overview of a complete project, the right side and the bottom of the 
Editor pane contain scroll bars, which you can use for vertical and horizontal scrolling of the 
project editing. 

 
 
① Menu bar ④ Component pane 
② Standard toolbar ⑤ Editor pane 
③ Project tree pane ⑥ Property pane 
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Menu bar 
The top of the LOGO! Web Editor window contains the menu bar (Page 46). Here, you can 
find various commands for editing and managing your projects, as well as functions for 
defining your default settings and for transferring of the project to and from LOGO!. 

Standard toolbar 
The standard toolbar (Page 13) appears above the Project tree and Editor pane's interface. 
Initially, LOGO! Web Editor shows you a reduced standard toolbar that provides only the 
essential functions.  

The standard toolbar provides direct access to the essential functions of LOGO! Web Editor. 

After you open a project for editing, you can see the complete standard toolbar. 

  

You can use these icons to create a new project or download, save an existing project, 
undo/redo the last action, or initiate data transferred to and from LOGO! devices. 

2.2 Function keys and shortcuts 
LOGO! Web Editor provides the following function key and shortcuts for frequently called 
functions:  

Function key in LOGO! Web Editor: 
 
[F1] Help -> Help Contents (Page 61)  

Shortcuts in LOGO! Web Editor: 
 
 In the File menu (Page 47): 
[Ctrl+Shift+N] File -> Open Project (Page 48)  
[Ctrl+F4] File -> Close Project (Page 49) 
[Ctrl+S] File -> Save (Page 49)  
[Ctrl+Shift+S] File -> Save All (Page 49) 
[Alt+F4] File -> Exit (Page 54)  
 In the Edit menu (Page 54): 
[Ctrl+Y] Edit -> Redo (Page 55)  
[Ctrl+Z] Edit -> Undo (Page 55) 
[Ctrl+A] Edit -> Select All (Page 55)  
[Ctrl+C] Edit -> Copy (Page 56)  
[Ctrl+V] Edit -> Paste (Page 56)  
[Delete] Edit -> Delete (Page 56) 
 In the Tools menu (Page 56): 
[Ctrl+D] Tools -> Download (Page 56)  
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[Ctrl+U] Tools -> Upload (Page 58)  
 In the Window menu (Page 59): 
[Ctrl+1] Window -> Project (Page 60) 
[Ctrl+2] Window -> Properties (Page 60) 
[Ctrl+3] Window -> Component (Page 60) 
[Ctrl+4] Windows -> Reset Windows (Page 61) 

2.3 Standard toolbar overview 
The icons of the standard toolbar provide quick access to commands that are also available 
on the menu.  

In LOGO! Web Editor, you can use the mouse-over-button function to display the icon name, 
which represents the tooltip. This helps you quickly recall the function of the icon, without 
calling the menu or the help. 

The following commands are found in the standard toolbar: 

 
 

  File: New Project (Page 47)  
   Open Project (Page 48)  
   Close Project (Page 49) 
   Save (Page 49)  
   Save all (Page 49)  
   Deploy To SD Card (Page 50) 

 
 Deploy To AWS (Page 50) 

  Edit: Left Rotate (Page 55)  
   Right Rotate (Page 55)  
   Redo (Page 55) 
   Undo (Page 55) 
  Tools: Download (Page 56) 
   Upload (Page 58) 

 

2.4 Projects tree pane 
In the Project tree pane, you can configure and manage your projects. When you create a 
new project from the menu bar of File -> New Project (Page 47), LOGO! Web Editor creates a 
new project with a Pages, a Global Tags and a Navigator automatically.  

• Pages (Page 14) 

• Global Tags (Page 16) 

• Navigator (Page 18) 
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2.4.1 Pages 
  

Pages is the container of your pages. Page is the main editing area of LOGO! Web Editor. You 
can edit pages with the provided components (Page 20), and save the pages as html file in 
project. After deploying the project in LOGO! Base module or Cloud, you can view them in 
web browser. You can navigate among different pages with Navigator (Page 18). 

The Pages can contain one default Home Page, a Login page and other pages. You can open 
a page by double-clicking the page icon, or right-clicking the page icon and select Open 
button. 

Home page (Page 14) 

Login page (Page 15) 

Other pages (Page 15) 

Page Properties  
• Basic 

– Name: Page 

– Resolution: you can modify the width and height of the page in the Size window. 

• Styles 

– Background Image: you can select a appropriate picture for the current page from 
Graph Library. 

 
  Note 

Graph Library is the LOGO! Web Editor build-in graphics library. It contains three parts: 
Build-In Graph, Color and My Graph. You can choose any of the graphic for the image by 
selecting the picture, and confirm the selection by clicking OK button. For detailed 
information, refer to the chapter Graph Library (Page 62). 

 

2.4.1.1 Home page 
 

This is the home page for your project, and the Home page cannot be deleted.  

When you create a new project (Page 47), the Home Page is created under the Pages in the 
Project tree.  
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2.4.1.2 Login page 

 
You can add a Login page for your project. When the Login page is enabled, you need to 
input a password to login. 

• When the project is deployed on LOGO! BM, you need to enter the password of Web User 
or Web Guest. 

• When the project is deployed on the Cloud, you need to enter the password you set when 
you deploy (Page 50) the project. 

Create a Login page 
• Right-click the Pages icon  and select Create Login Page. 

Then the Login page is created above the Home Page and the Login Page is opened in Editor 
pane. 

Open or delete the Login page 
• Right-click the Login page icon and select the Open or Delete from the shortcut menu. 

Create the Login panel 
1. Drag and drop the Login component  (Page 45)to the login page and set the properties as 

you need. 

2. Save (Page 49) the change. 

Enable or disable the Login page 
• Right-click the Login page icon and select the Enable or Disable from the shortcut menu. 

2.4.1.3 Other pages 
You can add more pages according to your need. The pages you add can be deleted. 

To create a new page 
• Right-click the Pages icon and select New Page. 

Then a page (page_number) is created below the Home Page and the new page is opened in 
Editor pane. 

To open, delete or rename a page 
• Right-click the page_x icon and select the corresponding options (Open, Delete or 

Rename) from the shortcut menu depending on your need. 
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2.4.2 Global Tags 
  

Global Configuration is the set of LOGO! BM variable. The Global Configuration contains 
Tag Table and IoT Thing table, and the they cannot be deleted. Tag Table is a place to 
define Global Variables. IoT Thing Table is place to create, update and delete Cloud devices. 
The IoT thing can be added in Tag Table after they are created in IoT thing table. 

When you create a new project (Page 47), Global Configuration is created in the project 
tree. 

2.4.2.1 Tag Table 
  

Tag table is used to define the global variables for your project. These variables can be from 
the local device or Cloud. After you saved the Tag table, you can use the variable and its 
binding data in the component property. The component filters the variables in Tag table, 
and only variables which match the component property are showed in the Variable Name 
drop down list. 

Block number varies according to the corresponding block type. For the detailed information, 
refer to the following table. 

 

Block Type Block Number 
I I1-I24 
Q Q1-Q20 
M M1-M64 
AI AI1-AI8 
AQ AQ1-AQ8 
AM AM1-AM64 
V V: 0-850  

Bits: 0-7 
VD VD: 0-847 
VW VW: 0-849 
Cursor Key C1-C4 
Function Key F1-F4 
Shift Register S1.1-S1.8,S2.1-S2.8, S3.1-S3.8,S4.1-

S4.8 

Open the Tag Table 
Open the Tag Table with either of the following ways: 

• Right-click the Tag Table icon  and select Open button; 

• Or double-click the Tag Table icon  . 
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Add a variable in Tag Table 
1. Click Add to add a new row. 

2. Define the alias name for the variable by double-clicking the Name column; 

3. Select Block type from the drop-down menu, and select corresponding value for each Block 
type in Block Number. 

4. Save the table by click Apply or Save (Page 49). 

Delete a variable in Tag Table 
1. Select the row which contains the variable you want to delete. 

2. Click Delete. 

3. Save the table by click Apply or Save (Page 49). 

See also 
Creating a new Project (Page 72) 

Standard toolbar overview (Page 13) 

2.4.2.2 IoT Thing Table 

 

IoT Thing Table is used to create, update and delete IoT things registered in Amazon Web 
Services (AWS). After an IoT thing is created in IoT thing table, this IoT thing can be 
referenced in tag table or component property. 

Open the IoT thing Table 
Open the Tag Table with either of the following ways: 

• Right-click the IoT Thing Table icon and select Open button; 

• Double-click the IoT Thing Table icon. 

Add an IoT Thing 
1. Click Add to add a new row. 

2. Enter the IoT Thing name and description. 

 
  Note 

The IoT Thing name must be the same as you resisted in AWS. 
 

3. Save the table by clicking Apply or Save (Page 49). 
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 Note 

When you set the IoT thing name in the property pane of a component,  
• if you set the IoT thing name the as a real IoT thing name but you deploy the LWE project 

to local BM, the IoT things is identified as local device. 
• if you set the IoT thing name as local device and deploy the LWE project to Cloud, the data 

for IoT thing will not be transferred to Cloud. 
 

Delete an IoT Thing 
1. Select the row which the IoT Thing you want to delete is in. 

2. Click Delete. 

3. Save the table by clicking Apply or Save (Page 49). 

2.4.3 Navigator 
  

Navigator is a floating page of the web site and it is intended to aid users to switch among 
different web pages or log off during the runtime operation.  

When you create a new project (Page 72), a Navigator is created in the Project tree. 

Open a Navigator 
Follow either of the way to open a Navigator in Editor pane: 

• Right-click the Navigator icon  and select Open button. 

• Or double-click the Navigator icon . 

Add a link in the Navigator 
1. Drag Navigator Item component under the Navigation bar. 

2. Set the Link values in Navigator Item Property pane: 

– Set the name by modifying the Text. 

– Set the link by selecting the page from the drop-down menu of Link. 

 
  Note 

The added navigator item can be link to an LWE page or LOGO! System page (Web 
server). 

 

3. Save (Page 49) the navigator. 
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Properties for Navigator Item 
• Basic 

– Name: Navigator Item 

– Location: you can only check the location coordinate from the Location pane. 

– Size: you can only check the width and height information from the Size pane. 

• Styles 

– Font: select Font, Font Style and Size depending on your need. Click the OK button 
for save the correction or click the Reset to Default button to reset to the default 
setting. 

• Values 

– Text: Type the Navigator Item name for each page. 

– Link: select Home Page or another page name which you have created in the drop-
down menu. 

2.5 Editor pane 
The Editor pane is the working space for the project, and it is shown in the middle of the 
window. It displays the opened pages, global configuration and navigator for the editing 
project. You can switch the editor pane for different panes, configuration tables and 
navigator by clicking the tabs above the editor pane. 

With the scroll bars on the right side and the bottom of the editor pane, you can view the 
complete project.  

When you edit components in the Editor pane, you can refer to How to edit component 
through the shortcut menu (Page 98). 
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2.6 Components pane 
The components can be classified to five segments: Tool, Basic, Digital, Analog and 
Miscellaneous in the component pane. 

You can configure the component based on your requirements.  
 
Tool 

  Polyline 
(Page 21) 

  Rectangle 
(Page 22) 

  Circle (Page 20) 

Basic 
  Text 

(Page 27) 
  Image 

(Page 24) 
  Link 

(Page 25)  
PDF 
(Page 26)  

Navigator 
(Page 18) 

Digital 
  Switch Button (Page 30) 

 
Push Button (Page 29) 

Analog 
  Analog 

Value 
(Page 35) 

  Analog 
Bar 
(Page 32) 

  Analog 
Slider 
(Page 33) 

 
Rainbow (Page 36) 

Miscellaneous 
  Scale Time 

(Page 39)  
LOGO! 
Clock 
(Page 38) 

 
Trend 
View 
(Page 41) 

 
Webcam 
(Page 43)  

Login 
(Page 45) 

2.6.1 Tool 
Tool is generally used for editing basic graphics. 

Tool contains the following selections:  

• Polyline (Page 21) 

• Rectangle (Page 22) 

• Circle (Page 20) 

2.6.1.1 Circle 

 

Use the Circle component when you want to draw a circle or an ellipse. 

 In the Circle Properties, you customize the position and size of the component. You can do 
the following operations in particular: 

• Changing size and position of an object (Page 67) 

• Setting the background color (Page 70) 

• Setting the border and transparency (Page 71) 
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Draw circles and ellipses 

1. Select the Circle component  . 

2. Draw a circle by dragging the Circle component directly where you want it to be in the 
Editor pane. 

3. Do one of the following: 

– To draw an ellipse, drag the circle component into the editor pane, and then drag the 
blue square on the borderline until the ellipse is the desired size, or specify the value 
for Location and Size in the Property pane. 

– To select the circle or ellipse, specify the Border Width and Border Style in the 
Property pane. If you want to fill border and background with the color, select color 
swatches separately. 

The Properties for Circle 
• Basic 

– Name: Circle 

– Location: you can modify the location coordinate for the circle. 

– Size: you can modify the width and height information for the circle. 

• Styles 

– Border Width: adjust the value depending on your need. 

– Border Style: select dotted, dashed, solid or double depending on your need. 

– Border Color: click Border Color swatches, select a swatch, and click OK button. 

– Background Color: click Background Color swatches, select a swatch, and click OK 
button. 

– Transparency: value ranges from 1 to 100, adjust the value depending on your need. 

– Fill: click the check box depending on whether to fill the circle with background color. 

2.6.1.2 Polyline 

 
Use the Polyline component when you want to draw one polyline. 

Draw a polyline 

1. Select the Polyline component  . 

2. Position the pointer where you want the line to begin in the Editor pane, and click to define 
the first anchor point. 

3. Click again where you want the segment to end. 

4. Continue clicking to set anchor points for additional straight segments. 

The anchor point you add always appears as a blue solid square. 
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5. Complete the polyline by doing one of the following: 

– Select a different tool. 

– Press the ESC button on your keyboard. 

6. Set the properties for the polyline as you need. 

Modify the polyline  
1. Select the polyline you want to change. 

The anchor points of the path appear. 

2. Select and drag the anchor point you want to change where you want. 

Move the polyline 
• Select a line segment (but not the anchor points) and drag it where you want. 

Properties 
• Basic 

– Name: Polyline 

• Styles 

– Weight: enter the width of the polyline. 

– Color: click color swatches, select a color swatch, and click OK button. 

– Dashed: select different polyline types  Solid, Round Dot, Square Dot, Dash, 
Dash Dot, Long Dash, Long Dash Dot or Long Dash Dot Dot depending 
on your need. 

– Transparency: value ranges from 1 to 100, adjust the value depending on your need. 

2.6.1.3 Rectangle 

 

Use the Rectangle component when you want to draw a rectangle or a square. 

In the Rectangle Properties, you customize the position and size of the component. You can 
do the following operations in particular: 

• Changing size and position of an object (Page 67) 

• Setting the border and transparency (Page 71) 

• Setting the background color (Page 70) 
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Draw rectangles and squares 

1. Select the Rectangle component  . 

2. Draw a rectangle or a square by dragging the Rectangle component directly where you 
want it to be in the Editor pane. 

3. To select the rectangle or square, specify the Border Width and Border Style in the Property 
pane. 

Properties for Rectangle 
• Basic 

– Name: Rectangle 

– Location: you can modify the location coordinate for the rectangle. 

– Size: you can modify the width and height information for the rectangle. 

• Styles 

– Border Width: adjust the value depending on your need. 

– Border Style: select dotted, dashed, solid or double depending on your need. 

– Border Color: click Border Color swatches, select a swatch, and click OK button. 

– Background Color: click Background Color swatches, select a swatch, and click OK 
button. 

– Transparency: value ranges from 1 to 100, adjust the value depending on your need. 

– Fill: click the check box depending on whether to fill the rectangle with background 
color. 

2.6.2 Basic 
Basic is generally used for adding texts, images and links in your project. 

Basic contains the following selections:  

• Text (Page 27) 

• Image (Page 24) 

• Link (Page 25) 

• PDF (Page 26) 
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2.6.2.1 Image 

 

Use the Image component when you want to add an image. 

In the Image Properties, you customize the position and size of the component. You can do 
the following operations in particular: 

• Changing size and position of an object (Page 67) 

• Setting the background image (Page 70) 

Add an Image 

1. Select the Image component  . 

2. Drag the Image component directly where you want the image to be in the Editor pane. 

 
  Note 

Consider the image size when you add it. The image size larger than the size limit cannot 
be uploaded. 
• gif < 256 KB 
• PNG/JPG/JPEG < 2 MB 

 

3. Edit the image in the Property pane by selecting the appropriate pictures for image in Graph 
Library. 

Properties for Image 
• Basic 

– Name: Image 

– Location: you can modify the location coordinate for the image. 

– Size: you can modify the width and height information for the image. 

• Values 

– Image: select the appropriate pictures from Graph Library. 
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2.6.2.2 Link 

 

Use the Link component when you want to add a Uniform Resource Locator (URL) link. 

In the Link Properties, you customize the position and size of the component. You can do the 
following operations in particular: 

• Changing size and position of an object (Page 67) 

• Setting the background color (Page 70) 

• Setting the style of text (Page 70) 

Add a link 

1. Select the Link component  . 

2. Drag the Link component directly where you want the line of link to be in the Editor pane. 

3. To set the text value of link, click "..." at the end of the row "Text Value" and enter the value 
as you need. 

4. To set the link target, enter the Url in the row "Link Target". 

 
  Note 

If you enter more text than can fit within link area, the apostrophe (...) appears in the end 
of the link area. You should adjust the link area by dragging the blue square on the border 
or modifying the value for Size in the Property pane. 

Each link is independent. 
 

5. Click the down arrow at the end of the row "Link Response Mode" and select the mode you 
need. 
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Properties for Link 
• Basic 

– Name: PDF 

– Location: you can modify the location coordinate for the link. 

– Size: you can modify the width and height information for the link. 

• Styles 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

– Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Background Color: click Background Color swatches, select a swatch, and click OK 
button. 

– Fill: click the check box depending on whether to fill the link area with background 
color. 

– Text Align: align the text on left, center or right. 

• Values 

– Text Value: Type the content for the link. 

– Url: URL of the link target. 

• Animation 

– Link Response Mode: select the link response mode. 

 

2.6.2.3 PDF 

 

Use the PDF component to upload a pdf file in the LWE project. The PDF file should be no 
more than 15 MB. 

In the PDF Properties, you can customize the position, size, and style of the object. You can 
do the following operations in particular: 

• Change the size or position (Page 67) 

• Setting the style of text (Page 70) 

• Setting the background image (Page 70) 

Add a PDF component 
1. Select the PDF component in the component pane. 

2. Drag it to the Editor pane and release the mouse button. 
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3. Set the name for PDF component. 

– Click "..." at the right end of the row Value in the PDF properties pane. 

– Change the Text value as you want. 

– Save the change by clicking OK or quit the change by clicking Cancel. 

The text value will change to the default value when you select Reset to Default. 

4. Upload the PDF file to LWE project. 

– Click "..." at the right of the row PDF File in the PDF properties pane. 

– Select a pdf file and click Open. 

The Properties for PDF component 
• Basic 

– Name: PDF 

– Location: you can modify the location coordinate for the PDF component. 

– Size: you can modify the width and height information for the PDF component. 

• Values 

– Text Value: Type the content for the PDF component. 

– PDF file: select the pdf file you want to add. 

• Styles 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

– Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Text Align: align the text on left, center or right. 

– Background Image: select the appropriate pictures from Graph Library. 

2.6.2.4 Text 

 

Use the Text component when you want to add word description. 

In the Text Properties, you customize the position and size of the component. You can do the 
following operations in particular: 

• Changing size and position of an object (Page 67) 

• Setting the style of text (Page 70) 

• Setting the background color (Page 70) 
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Add a text component 

1. Select the Text component  . 

2. Drag the Text component directly where you want the line of text to be in the Editor pane. 

3. Enter the text by double-clicking the text component to edit inline or changing the Text 
Value in the Property pane. 

When the text reaches a boundary, it automatically wraps to fit inside the defined area 

4. Press esc key or click other area to exit edit mode. 

Properties for Text 
• Basic 

– Name: Text 

– Location: you can modify the location coordinate for the text. 

– Size: you can modify the width and height information for the text. 

• Values 

– Text Value: type the content. 

• Styles 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

– Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Background Color: click Background Color swatches, select a swatch, and click OK 
button. 

– Fill: click the check box depending on whether to fill the text area with background 
color. 

– Text Align: align the text on left, center or right. 

2.6.3 Digital 
Digital Value is used for presenting the digital value "0" and "1" visually.  

Digital Value contains:  

• Switch Button (Page 30) 

• Push Button (Page 29) 
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2.6.3.1 Push Button 

 

The Push Button component is a special digital value component. 

In the Push Button Properties, you customize the position, size, and style of the object. You 
can do the following operations in particular: 

• Changing size and position of an object (Page 67) 

• Setting the style of text (Page 70) 

Add a Push Button component 
1. Select the Push Button component in the component pane. 

2. Drag it to the Editor pane and release the mouse button. 

3. To define the Push Button runtime behavior, click "..." at the right end of the row Mouse 
Mode in the push button properties pane. 

– Click: in web page, the status of push button changes by mouse click. Click mode 
supports the following block types: Q, M, V. 

– Hold: in web page, the status of push button changes by holding mouse press. Hold 
mode supports the following block types: Q, M, V, Cursor Key and Function Key. 

 
  Note 

Push Button in Hold mode can only be used in project deployed to local BM 

If you defined the Push Button runtime behavior as Hold, the IoT thing name can only be 
set as "local device". 

If you defined the Push Button runtime behavior as Click, the IoT thing name can be set 
either as "local device" or supported IoT thing name bonded in IoT thing table. 

 

4. Set the On Image or Off image for the push button component. 

– Click "..." at the right end of the row On Image or Off Image in the push button 
properties pane. 

– Select an image from the Graph Library and click OK. 

5. Set the name for Push Button component. 

– Click "..." at the right end of the row Off Text or On Text in the push button properties 
pane. 

– Change the text as you want. 

– Save the change by clicking OK or quit the change by clicking Cancel. 

The text value will change to the default value when you select Reset to Default. 

6. Setting the variable (Page 69) 
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The Properties for Push Button 
• Basic 

– Name: Push Button 

– Location: you can modify the location coordinate for the push button. 

– Size: you can modify the width and height information for the push button. 

• Animation 

– Mouse Mode: select the mouse mode. 

– On Image: select the appropriate pictures for on-state in Graph Library. 

– Off Image: select the appropriate pictures for off-state in Graph Library. 

– On Text: enter the display content for on-state. 

– Off Text: enter the display content for off-state. 

• Variable 

– Variable Name: select the Private Tag or variables from tag table depending on your 
need. 

– IoT Thing Name: select Local Device or IoT thing names you bounded in tag table 

– Block Type: select the type of variable. 

– Block Number: select the block number. 

• Styles 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

– Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Text Align: align the text on left, center, or right. 

2.6.3.2 Switch Button 

 

Use Switch Button when you want to present the digital value "0" and "1" visually. "0" is for 
"off-state", and "1" is for "on-state". 

In the Switch Button Properties, you customize the position and size of the component. You 
can do the following operations in particular: 

• Changing size and position of an object (Page 67) 

• Setting the style of text (Page 70) 

Add a Switch Button 

1. Select the Switch Button component  . 

2. Drag the Switch Button component directly where you want it to be in the Editor pane. 
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3. Setting the variable (Page 69) 

4. Set the On Image or Off image for the switch button component. 

– Click "..." at the right end of the row On Image or Off Image in the push button 
properties pane. 

– Select an image from the Graph Library and click OK. 

5. Set the On Text and Off Text for Switch Button component. 

– Click "..." at the right end of the row Off Text or On Text in the switch button 
properties pane. 

– Change the text as you want. 

– Save the change by clicking OK or quit the change by clicking Cancel. 

The text value will change to the default value when you select Reset to Default. 

Properties for Switch Button 
• Basic 

– Name: Switch Button 

– Location: you can modify the location coordinate for the Switch Button. 

– Size: you can modify the width and height information for the Switch Button. 

• Variable 

– Variable Name: select the Private Tag or Global Tag depending on your need. 

– IoT Thing Name: select Local Device or IoT thing names you bounded in tag table 

– Block Type: select the type of variable. 

– Block Number: follow the below table to select each value. 

– Writable: for the writable block types, you can enable the write function by clicking the 
check box next to Writable. 

• Animation 

– On Image: select the appropriate pictures for on-state in Graph Library. 

– Off Image: select the appropriate pictures for off-state in Graph Library. 

– On Text: enter the display content for on-state. 

– Off Text: enter the display content for off-state. 

• Styles 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

– Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Text Align: align the text on left, center, or right. 
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2.6.4 Analog 
Analog Value is used for editing analog variable visually. 

Analog Value contains the following selections: 

• Analog Value (Page 35) 

• Analog Bar (Page 32) 

• Analog Slider (Page 33) 

2.6.4.1 Analog Bar 

 

Use the Analog Bar component when you want to create an analog bar to show the dynamic 
variable. 

In the Analog Bar Properties, you customize the position, size, and style of the object. You 
can adapt the following properties in particular: 

• Changing size and position of an object (Page 67) 

• Setting the style of text (Page 70) 

Add an analog bar 

1. Select the Analog Bar component  . 

2. Drag the Analog Bar component directly where you want it to be in the Editor pane. 

3. Setting the variable (Page 69) 

4. Set the range for Analog Bar component in the properties pane. 

– Click "..." at the right end of the row Max. value and Min. value. 

– Change the value as you want. 

– Save the change by clicking OK or quit the change by clicking Cancel. 

The value will change to the default value when you select Reset to Default. 
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Properties for Analog Bar 
• Basic 

– Name: Analog Bar 

– Location: you can modify the location coordinate for the analog bar. 

– Size: you can modify the width and height information for the analog bar. 

• Variable 

– Variable Name: select the Private Tag or variables from tag table depending on your 
need. 

– IoT Thing Name: select Local Device or IoT thing names you bounded in tag table 

– Block Type: select the type of variable. 

– Block Number: select the block number. 

– Block Format: select Signed or Unsigned for the Block value. 

– Decimal Places: select the number of decimal places for the variable value. 

• Animation 

– Max. Value: set the maximum value for the analog bar depending on your need. 

– Min. Value: set the minimum value for the analog bar depending on your need. 

– Color: click Color Setting swatches, according to different ranges, select a 
corresponding color swatch, and click OK button. 

• Styles 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

– Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Border Color: click Border Color swatches, select a swatch, and click OK button. 

2.6.4.2 Analog Slider 

 

Use the Analog Slider component when you want to create an analog slider to show the 
slider variable. 

In the Analog Slider Properties, you customize the position, size, and style of the object. You 
can adapt the following properties in particular: 

• Changing size and position of an object (Page 67) 

Add an analog slider 

1. Select the Analog Slider component  . 

2. Drag the Analog Slider component directly where you want it to be in the Editor pane. 
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3. Setting the variable (Page 69) 

4. Set the range for Analog Slider component in the properties pane. 

– Click "..." at the right end of the row Max. value and Min. value. 

– Change the value as you want. 

– Save the change by clicking OK or quit the change by clicking Cancel. 

The value will change to the default value when you select Reset to Default. 

Properties for Analog Slider 
 

• Basic 

– Name: Analog Slider 

– Location: you can modify the location coordinate for the analog slider. 

– Size: you can modify the width and height information for the analog slider. 

• Variable 

– Variable Name: select the Private Tag or variables from tag table depending on your 
need. 

– IoT Thing Name: select Local Device or IoT thing names you bounded in tag table 

– Block Type: select the type of variable. 

– Block Number: select the block number. 

– Block Format: select Signed or Unsigned for the Block value. 

– Decimal Places: select the number of decimal places for the variable value. 

– Writable: for the writable block types, you can enable the write function by clicking the 
check box next to Writable. 

• Animation 

– Max. Value: set the maximum value for the Analog Slider depending on your need. 

– Min. Value: set the minimum value for the Analog Slider depending on your need. 

– Background Image: select the appropriate picture from Graph Library. 

– Thumb Image: select the appropriate picture from Graph Library. 
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2.6.4.3 Analog Value 

 

Use the Analog Value component when you want to show the analog value. 

In the Analog Value Properties, you customize the position, size, and style of the object. You 
can adapt the following properties in particular: 

• Changing size and position of an object (Page 67) 

• Setting the style of text (Page 70) 

Add an analog value component 

1. Select the Analog Value component  . 

2. Drag the Analog Value component directly where you want it to be in the Editor pane. 

3. Setting the variable (Page 69) 

 Properties for Analog Value 
• Basic 

– Name: Analog Value 

– Location: you can modify the location coordinate for the analog value. 

– Size: you can modify the width and height information for the analog value. 

• Variable 

– Variable Name: select the Private Tag or variables from tag table depending on your 
need. 

– IoT Thing Name: select Local Device or IoT thing names you bounded in tag table 

– Block Type: select the type of variable. 

– Block Number: select the block number. 

– Block Format: select Signed or Unsigned for the Block value. 

– Decimal Places: select the number of decimal places for the variable value. 

– Writable: for the writable block types, you can enable the write function by clicking the 
check box next to Writable. 

– Unit: set the unit for the variable. 

• Styles 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

– Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Text Align: align the text on left, center, or right. 
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2.6.4.4 Rainbow 

 

The Rainbow component shows numeric values in the form of an analog gauge. The 
Rainbow is for display only and cannot be controlled by the operator. 

In the Rainbow Properties, you customize the position, size, and style of the object. You can 
adapt the following properties in particular: 

• Changing size and position of an object (Page 67) 

• Setting the background color (Page 70) 

• Set the text font (Page 70) 

Add a Rainbow component 
1. Select the Rainbow component in the component pane. 

2. Drag it to the Editor pane and release the mouse button. 

3. Setting the variable (Page 69) 

4. Set the range for Rainbow component in the properties pane. 

– Click "..." at the right end of the row Max. value and Min. value. 

– Change the value as you want. 

– Save the change by clicking OK or quit the change by clicking Cancel. 

The range value will change to the default value when you select Reset to Default. 

5. Set the color for each range. 

– Click "..." at the right end of the row Color. 

– In the Color Setting window, customize the range and its color. You can add a range by 
clicking "+" button. 

 
  Note 

 You can add five ranges for a Rainbow component at most. 
 

– Save the color setting. 
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The Properties for Rainbow 
• Basic 

– Name: Rainbow 

– Location: you can modify the location coordinate for the Rainbow. 

– Size: you can modify the width and height information for the Rainbow. 

• Variable 

– Variable Name: select the Private Tag or variables from tag table depending on your 
need. 

– IoT Thing Name: select Local Device or IoT thing names you bounded in tag table 

– Block Type: select the type of variable. 

– Block Number: select the block number. 

– Block Format: select Signed or Unsigned for the Block value. 

– Decimal Places: select the number of decimal places for the variable value. 

• Animation 

– Max. Value: set the maximum value for the analog bar depending on your need. 

– Min. Value: set the minimum value for the analog bar depending on your need. 

– Color: click Color Setting swatches, according to different ranges, select a 
corresponding color swatch, and click OK button. 

• Styles 

– Background color: select the background color. 

– Fill: select the check box if you want to fill the Rainbow area with background color. 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

2.6.5 Miscellaneous 
Miscellaneous contains: 

• Scale Time (Page 39) 

• LOGO! Clock (Page 38) 

• Trend View (Page 41) 

• Webcam (Page 43) 

• Login (Page 45) 
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2.6.5.1 LOGO! Clock 

 

Use the LOGO! Clock component to show the date and time information from LOGO! Base 
modular. 

In the LOGO! Clock Properties, you customize the position, size, and style of the object. You 
can adapt the following properties in particular: 

• Changing size and position of an object (Page 67) 

• Setting the background color (Page 70) 

• Setting the style of text (Page 70) 

 

 Note 

LOGO! Clock can only be used in projects deployed to LOGO! BM. 
 

Add a LOGO! Clock component 
You can only read the date and time information from LOGO! Base modular. 

1. Select the LOGO! Clock component  . 

2. Drag the LOGO! Clock component directly where you want it to be in the Editor pane. 

3. Setting the variable (Page 69) 
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Properties for LOGO! Clock 
• Basic 

– Name: LOGO! Clock 

– Location: you can modify the location coordinate for the text. 

– Size: you can modify the width and height information for the text. 

• Styles 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

– Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Background Color: click Background Color swatches, select a color, and click the OK 
button. 

– Fill: select the check box if you want to fill the text area with background color. 

– Text Align: align the text on left, center, or right. 

– Time format: select the time format. 

• Variable 

– IoT Thing Name: select Local Device or IoT thing names you bounded in tag table 

2.6.5.2 Scale Time 

 

Use the Scale Time component when you want to display a time value. 

 In the Scale time Properties, you customize the position and size of the component. You can 
do the following operations in particular: 

• Changing size and position of an object (Page 67) 

• Setting the style of text (Page 70) 

Scale time is the actual value of a referenced function block which displayed as a time value. 
Possible time display formats show as below: 

• hours(h), minutes(m), seconds(s), 10 milliseconds(ms), Yearly (Month day), Weekly 
(Time) 
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Add a scale time component 

1. Select the Scale Time component  . 

2. Drag the Scale Time component directly where you want it to be in the Editor pane. 

3. Set the variable for Scale time under Properties > Variable: 

– Set the time as hours/minutes/seconds/10 Milliseconds (Page 69) 

– When you set the on-time and off-time as yearly/weekly, you must set the block type 
and block number as you use in the LOGO!Soft Comfort circuit diagram. 

a. Check the type ① and address ② of the function block in LOGO!Soft Comfort. 

 

b. Set the variables for in LOGO! Web Editor as below: 

Set Block type as the value of type ①; 

Set Block number as the value of address ②. 
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Properties for Scale Time 
• Basic 

– Name: Scale Time 

– Location: you can modify the location coordinate for the scale time. 

– Size: you can modify the width and height information for the scale time. 

• Variable 

– Variable Name: select the Private Tag or variables from tag table depending on your 
need. 

– IoT Thing Name: select Local Device or IoT thing names you bounded in tag table 

– Block Type: select the type of variable. 

– Block Number: select the block number. 

– Times: Set the unit for the Scale time. 

– Writable: for the writable block types, you can enable the write function by clicking the 
check box next to Writable. 

• Styles 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

– Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Text Align: align the text on left, center, or right. 

2.6.5.3 Trend View 

 

Use the Trend View component to display tag values from the current process in the form of 
trends as a function of the time. The scope of the chart is determined by the maximum tag 
value. One Trend view component can display 10 tags at most. 

In the Trend View Properties, you customize the position, size, title, and title style of the 
component. You can do the following operations in particular: 

• Changing size and position of an object (Page 67) 

• Setting the style of text (Page 70) 

Add a Trend View component 
Set the animation properties of trends under Properties > Animation: 

1. Select the Trend View component in the component pane. 

2. Drag it to the Editor pane and release the mouse button. 
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3. Set the animation properties of trends under Properties > Variable: 

– Click "..." at the right end of the row Trend View Variables. 

– In the Trend View Variable table, click "+" to add a new variable. 

You can delete a variable by clicking "-" while it is selected.  

– Specify the properties of the variable and the color it shows in the trend view. 

– Save the table by clicking Save. 

 

4. Set the interval time in the Interval Time drop-down list. 

5. Set the count of interval time in time axes in the Time Scale Count drop-down list. 

The Properties for Trend View 
• Basic 

– Name: Trend View 

– Location: you can modify the location coordinate for the Trend View. 

– Size: you can modify the width and height information for the Trend View. 

• Values 

– Trend View Title: Set the title for the Trend View. 

• Styles 

– Title Font: select Font, Font Style and Size information separately in the Font pane. 
Click the OK button for save the correction or click the Reset to Default button to reset 
to the default setting. 

– Title Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Title Text Align: align the text on left, center, or right. 
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• Animation 

– Interval Time (seconds): set the interval time of the Trend View. 

– Time Scale Count: set the time scale count of the Trend View. 

• Variable 

– Trend View Variable: Add or delete the Trend View variables. 

2.6.5.4 Webcam 

 

Use Webcam component to add a real-time monitoring screen in web pages. Before adding 
the Webcam component to LWE project, you need to install your IP web camera and 
transcode the RTSP address of your camera into HLS. See Example for adding image for IP 
camera (Page 83) or Example for adding image from USB camera (Page 80)for an example. 

LWE web page supports five stream video types through the Http protocol. The supported 
video types vary from browsers. Refer to HTML5 Video 
(https://en.wikipedia.org/wiki/HTML5_video) for more information on the supported video 
formats by a given browser.  

In the Webcam properties, you customize the position, size, title, and title style of the 
component. You can set the following properties in particular: 

• Changing size and position of an object (Page 67) 

• Set the title and tooltip 

• Set the animation properties 

 

 Note 

Siemens recommends you use the latest version of Google Chrome when visiting the 
deployed LWE projects. 

 

Set the animation properties 
You need to provide a stream source for Webcam component under Properties > Http Live 
Stream Address. 

1. Click "..." at the right end of the row Http live stream address. 

2. In the Webcam-Http Live Stream Address window, enter the address. 

 
  Note 

According to the security policy of browsers, if the LOGO! web server is in HTTPSs mode, 
then address you fill in the Webcam-Http Live Stream Address field must be HTTPS 
address. Otherwise the browser will reject the connection. 

 

https://en.wikipedia.org/wiki/HTML5_video
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3. Save the change by clicking OK or quit the change by clicking Cancel. 

The text value will change to the default value when you select Reset to Default. 

4. Click the down arrow at the right of the row Live Stream Video Type and select the video 
type. 

Set the title and tooltip 
Set the title and tooltip under Properties > Value: 

1. Click "..." at the right end of the row Title/Tooltip. 

2. In the Webcam-Title/Webcam-Tooltip window, set the value as you need. 

3. Save the change by clicking OK or quit the change by clicking Cancel. 

The text value will change to the default value when you select Reset to Default. 

The Properties for Webcam 
• Basic 

– Name: Webcam 

– Location: you can modify the location coordinate for the Webcam. 

– Size: you can modify the width and height information for the Webcam. 

• Styles 

– Font: select Font, Font Style and Size information separately in the Font pane. Click 
the OK button for save the correction or click the Reset to Default button to reset to 
the default setting. 

– Text Color: click Text Color Swatches, select a swatch, and click OK button. 

– Text Align: align the text on left, center, or right. 

• Values 

– Title: Set the title for the Webcam 

– Tooltip: Set the tooltip for the Webcam 

• Animation 

– Http Live Stream Address: enter the address of http live stream. 

– Live Stream Video Type: select the video types of the live stream. 
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2.6.5.5 Login 

 

Login component is only available when you editing the Login page (Page 15). You can add 
only one Login component in one project. 

In the Login Properties, you customize the position, size, title, and title style of the object. 
You can adapt the following properties in particular: 

• Changing size and position of an object (Page 67) 

• Setting the style of text (Page 70) 

• Setting the background color (Page 70) 

• Set the login animation 

Set the Login animation 
There are two options for the login panel:  

• To customized site: when it is selected, you navigate the Home page of your LWE project 
after logon. 

• Keep me logged on: when it is selected, you only need to enter the corresponding 
password for you first logon.  

 

 Note 

For the projects deployed to AWS,  
• To customized site is selected by default and cannot be deselected. 
• Keep me logged on is invisible. 

 

Set the animation properties of Login under Properties > Animation: 

• Hide or show the option in the To customized site and Keep me logged on drop-down 
list by selecting Invisible or Visible. 
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2.7 Properties pane 
The "Properties" pane provides information about the properties of a component or navigator 
as a table. Using the example of a push button, you can see the basic and further properties 
in the "Properties" pane. 

 
LOGO! Web Editor displays properties that you can change in black and those that you cannot 
change in gray. 

There are various input mechanisms for changing properties:  

• Direct input in the table cell 

• Selection list: if a down arrow shows at the right end of the row. 

• Special editors: if '...' shows at the right end of the row. 

2.8 Menu bar 
The menu bar contains some editing functions for the project and provides access to the 
context-sensitive help. 

• File menu (Page 47) 

• Edit menu (Page 54) 

• Tools menu (Page 56) 

• Window menu (Page 59) 

• Help menu (Page 61) 
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2.8.1 File menu 
The File menu command contains commands for file management. Included are also 
commands for creating, saving or exit:  

• New Project (Page 47) 

• Open Project (Page 48) 

• Close Project (Page 49) 

• Save (Page 49) 

• Save All (Page 49) 

• Save As... (Page 49) 

• Exit (Page 54) 

2.8.1.1 File -> New Project 
 

Click this command to open a New Project dialog box which contains name, location and 
resolution information. 
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Name and Location dialog box 

• Project Name: give a valid name to the project. 

 
  Note 

Naming Conventions for the Project Name 
• The maximum length of a name is 8. 
• The maximum length of filename extension is 3. 
• Do not use space in the file name. 
• Do not assume case sensitivity. 
• Do not use the following characters: 

– < (less than) 
– > (greater than) 
– : (colon) 
– " (double quote) 
– / (forward slash) 
– \ (backslash) 
– | (vertical bar or pipe) 
– ? (question mark) 
– * (asterisk) 
– + (plus sign) 
– . (dot) 

 

• Project Location: click Browse button and select a proper location in your computer to 
save the project. 

• Default Resolution: click the drop-down menu and select a resolution for the project. 

After modifying this dialog box, click Finish button to accomplish the new project creation. 
Then a new project appears in Project tree. 

You can also click Cancel button to cancel the creation or click Help button to get more 
information from online help.  

The standard toolbar (Page 13) also contains an icon for this menu command. 

2.8.1.2 File -> Open Project 
 

Click this command to open a dialog box from which you can select and open a previously 
created project for further editing.  

The type of file that you can open is only for Project Folder.  

The icon for the Project Folder is  . 

The standard toolbar (Page 13) also contains an icon for this menu command. 
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2.8.1.3 File -> Close Project 
  

Click this command to close the active project window. If you have not yet saved the current 
project, LOGO! Web Editor prompts you to save it.  

The standard toolbar (Page 13) also contains an icon for this menu command. 

 

2.8.1.4 File -> Save 
  

Click this command to save the current editor pane. 

For other opened windows, you can save them with Save all. You can find additional 
information under File -> Save All (Page 49).  

If you are saving a modified version of an existing project, LOGO! Web Editor performs a quick 
save. The revised version overwrites the old version at the same path and name as the source 
file. 

The standard toolbar (Page 13) also contains an icon for this menu command. 

2.8.1.5 File -> Save All 
  

Click this command to save all the corrections for project in editor pane. 

The revised version overwrites the old version at the same path and name as the source file. 

The standard toolbar (Page 13) also contains an icon for this menu command. A click on this 
menu command closes all open windows.  

2.8.1.6 File -> Save As... 
  

After clicking this command, a dialog box opens for you to specify the path and project name 
under which the current project is to be saved. This allows you to save modified projects 
under a different name or folder, and thus keep previous versions for retrieval.  

The only type of files that you can save is project folder. Each project is saved in its own 
project folder. 
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2.8.1.7 File -> Deploy to AWS 
You can deploy the LWE project to SD card or AWS (Elastic BeanStalk). 

Deploy to SD card 
1. Select File -> Deploy -> Deploy to SD card. 

2. Specify the driver under which you want to save your project in the opened window.  

 

You can also deploy the project to SD card by clicking  on the standard toolbar (Page 13). 

When you download project to BM, LWE builds and compiles a new file folder in project to 
support https mode. 

Deploy to AWS  
Prerequisites 

• The Cloud access must be enabled. 

On how to enable Cloud access, refer to the chapter 2.8.5.19 Tools -> Transfer -> Cloud 
Connection Settings of LOGO!Soft Comfort Online help. 

• An AWS account is created 
(https://docs.aws.amazon.com/organizations/latest/userguide/orgs_manage_accounts_cre
ate.html). 

 
  Note 

 If you cannot visit the LWE project you deployed on  AWS China EC2, contact AWS 
customer service to open these ports for your account: 80, 8080, and 443. 

 

https://docs.aws.amazon.com/organizations/latest/userguide/orgs_manage_accounts_create.html
https://docs.aws.amazon.com/organizations/latest/userguide/orgs_manage_accounts_create.html
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• IoT things are created. 

On how to create a thing, refer to Create a thing 
(https://docs.aws.amazon.com/iot/latest/developerguide/create-aws-thing.html) or 
chapter 2.8.5.19 Tools -> Transfer -> Cloud Connection Settings of LOGO!Soft Comfort 
Online help. 

• IoT thing names are added in IoT thing table  (Page 17)and the LWE project has used the 
IoT things. 

Procedures 

1. Select File -> Deploy -> Deploy to AWS. 

2. Select the WebApp Region, IoT Region, enter the "Access Key ID" and "Secret Access Key". 
Then click the Next button. 

– IoT region: the LOGO! BM registered region on AWS. 

– WebApp region: the region LWE project deployed on AWS. 

 

https://docs.aws.amazon.com/iot/latest/developerguide/create-aws-thing.html
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3. Select the checkbox "Create a new environment" or "Choose an existing environment". 

If you select "Create a new environment", proceed with step 5. If you select "Choose an 
existing environment", proceed with step 6. 
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4. Enter a name for the new application and environment. 

 
5. Set the Web user password for access the Cloud Web App. 

 
  Note 

Siemens highly recommend you set a strong Web user password to protect the Web App. 

This password is used to log in the Cloud web app your deploy on AWS. It is independent 
from the web user password used to log in the BM Web server. 

 

Result: After the deployment, you will get the URL of the Web App. You can also check the 
Web App in web browser or AWS Elastic BeanStalk console. 

 
 

 Note 

You can access the Cloud Web App which is deployed on AWS Service through the 
administrator password. If you forget the password, you must re-deploy the Web App again 
to reset the password. 
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2.8.1.8 File -> Export as BM Https Project 
You can copy the LWE project into SD-card manually. Before that you need to compile the 
project by this command first. Otherwise the project cab only support Http mode. 

Click this command to export the editing project as BM Https project. 

2.8.1.9 File -> Export as AWS WebAPP 
Click this command to export the editing project as AWS Web App. The exported AWS Web 
App can be deployed to tomcat web server directly. 

2.8.1.10 File -> Exit 
Click this command to close LOGO! Web Editor tool.  

If you are editing a project and have not yet saved it, LOGO! Web Editor prompts you about 
your project. 

Below is an example for the pop-up window: 

 
In this pop-up window, you can decide which windows are needed to be saved. You can click 
Save to save the current window or click Save All to save project. 

Alternatively, you can exit LOGO! Web Editor without saving windows by clicking Discard All. 

You can also click Cancel button to cancel the creation or click Help button to get more 
information from online help. 

2.8.2 Edit menu 
The Edit menu provides commands for editing your project. The toolbar contains some of the 
basic commands for creating and editing projects.  

• Right Rotate (Page 55) 

• Left Rotate (Page 55) 

• Redo (Page 55) 

• Undo (Page 55) 
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• Select All (Page 55) 

• Bring to front (Page 56) 

• Send to back (Page 56) 

• Copy (Page 56) 

• Paste (Page 56) 

• Delete (Page 56) 

2.8.2.1 Edit -> Right Rotate 
  

Click this command to rotate the component clockwise. Once you select the component, and 
then click the Right Rotate button, you can rotate the component 90 degrees clockwise.  

The standard toolbar (Page 13) also contains an icon for this menu command. 

2.8.2.2 Edit -> Left Rotate 
  

Click this command to rotate the component anticlockwise. Once you select the component, 
and then click the Left Rotate button, you can rotate the component 90 degrees 
anticlockwise.  

The standard toolbar (Page 13) also contains an icon for this menu command. 

2.8.2.3 Edit -> Redo 
  

Click this command to revert the last undo action.  

The standard toolbar (Page 13) also contains an icon for this menu command. 

2.8.2.4 Edit -> Undo 
  

Click this command to undo the previous actions.  

The standard toolbar (Page 13) also contain an icon for this menu command. 

2.8.2.5 Edit -> Select All 
Click this command to select all components in current Pages or Navigator under the project, 
for example, Polyline, Rectangle, Image or Navigator Item can be selected on the Editor pane. 
You cannot use this command to select the component in Global Tags. 
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2.8.2.6 Edit -> Bring to front 
Click this command to move a component to the top position in its group or layer.  

2.8.2.7 Edit -> Send to back 
Click this command to move a component to the bottom position in its group or layer. 

2.8.2.8 Edit -> Copy 
  

Click this command to copy one or more selected components to the clipboard, for example, 
you can copy the selected Polyline, Rectangle, Image and Navigator Item from the Editor 
pane to the clipboard. 

2.8.2.9 Edit -> Paste 
  

Click this command to copy the clipboard content to the Editor pane.  

2.8.2.10 Edit -> Delete 
  

Click this command to delete the selected components, without copying them to the 
clipboard. You can retrieve deleted components with the Undo function.  

When you delete the selected components, a pop-up window of Confirm Object Deletion 
appears. You can confirm the deletion with Yes button or cancel the deletion with No button 
in the pop-up window. 

2.8.3 Tools menu 
The tools menu provides the following menu commands:  

• Download (Page 56) 

• Upload (Page 58) 

• Deploy To SD Card (Page 50) 

• Options (Page 58) 

2.8.3.1 Tools -> Download 
  

Click this command to download a LOGO! Web Editor project from PC to the Micro SD card of 
LOGO! Base Module. You can also use this button in the standard toolbar (Page 13) for such 
purpose. 
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Example for Download 
To download a new project to LOGO! Base Module, do the following steps: 

1. Click the icon  in the standard toolbar or select Download from Tools bar. 

2. In the pop-up Download window, 

– select correct Interface from the drop-down menu; 

– enter the valid Target IP Address or click scan icon  to find the accessible device to 
connect the BM. 

– click Test button, and then a Connecting pane pops up. 

– after the connection line turns green, click OK button. You can also click Cancel button 
to cancel the configuration or click Help button to get more information from online 
help. 
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3. In the Confirm Download pane, click OK button to confirm to download the project. 

 
Then the project is downloaded to LOGO! BM.  

 
4. In the Confirm pane, click OK button to start the BM. 

 

2.8.3.2 Tools -> Upload 
  

Click this command to upload a LOGO! Web Editor project from the Micro SD card of LOGO! 
Base Module to PC. You can also use this button in the standard toolbar (Page 13) for such 
purpose. 

2.8.3.3 Tools -> Options 
Here you can select Language and Size of the text & icons options for LOGO! Web Editor, 
click the radio button before each options and press OK button to save the selection. 

You can also click Cancel button to cancel the selection or click Help button to get more 
information from online help. 
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Language 

Here you can define the user interface language. 

• Deutsch 

• English 

Size of the text & icons 

Here you can select the size of the text and icons in the user interface. 

• 100% 

• 120% 

• 150% 

 
 

 Note 

The changes for options will not take effect until you restart LOGO! Web Editor. 
 

2.8.4 Window menu 
From the Window menu, you can arrange your project windows on the desktop. You can 
show the Project tree pane, Component pane, Editor pane and Property pane on the desktop. 

The following window options are available:  

• Project (Page 60) 

• Properties (Page 60) 

• Component (Page 60) 



User interface  
2.8 Menu bar 

 LOGO! Web Editor Online Help 

60 Operating Instructions, 10/2020, A5E42880034 - AC 

2.8.4.1 Window -> Project 
You can use this menu command to show the Project tree pane on the desktop. If you want 
to close the Project tree pane, click the cross button   

 

2.8.4.2 Window -> Properties 
You can use this menu command to show the Property pane on the desktop. If you want to 
close the Property pane, click the cross button   

 

2.8.4.3 Window -> Component 
You can use this menu command to show the Component pane on the desktop. If you want 
to close the Component pane, click the cross button   
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2.8.4.4 Windows -> Reset Windows 
You can use this menu command to reset the windows to the default layout. 

 

2.8.5 Help menu 
This menu provides you with help and information on LOGO! Web Editor.  

• Start Page (Page 61) 

• Help Contents (Page 61) 

• About (Page 62) 

2.8.5.1 Help -> Start Page 
Close the whole project or close all the windows in Editor pane, and then exit the LOGO! Web 
Editor, when you restart the LWE again, you can see the Start Page shows in the Editor pane.  

If you exit the LOGO! Web Editor without closing the edited project, when you restart the LWE 
again, the last edited pages can be shown in the Editor pane. 

2.8.5.2 Help -> Help Contents 

The Online Help 
The online help quickly and reliably provides you with information about projects, tools and 
the creation of projects with LOGO! Web Editor.  
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Topics of the Online Help 
The User interface (Page 11) section describes the user interface with its toolbars and the 
LOGO! Web Editor menus in detail. 

Refer to the Tutorial (Page 67) for a quick and easy introduction to the basics of operating 
LOGO! Web Editor.  

The section of Getting started with project creation (Page 72) that takes you a general 
description for creating a new project, and towards the end of this section you will find an 
extensive Practical example (Page 74) that takes you through all the steps of project creation. 

The Tips and Tricks (Page 97) section includes information about operating tips with LOGO! 
Web Editor. 

The online help includes an index as well as a full text search feature for keyword and 
terminology based searches. 

2.8.5.3 Help -> About 
The General tab displays the version number and the release version of your LOGO! Web 
Editor tool.  

The System tab provides you with information on the version of the Java Runtime 
environment used, the program paths, the installed operating system and on the memory 
used. 

The Notice tab provides you with information on the Commercial Features in Java SE Product 
Editions. 

2.9 Graph Library 
Graph Library is the LOGO! Web Editor build-in graphics library. You can select graphics for 
the following three components in Property pane. 

• Page: the selection for Background Image; 

• Image: the selection for Image; 

• Digital Value: the selections for On Image and Off Image; 

• Analog Slider: the selections for Background Image and Thumb Image. 

Graph Library contains three parts: 

• Build-In Graph (Page 63) 

• Colors (Page 64) 

• My Graph (Page 65) 
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2.9.1 Build-In Graph 
In the Build-In Graph folder, each subfolder contains different kinds of graphics. For example, 
Animation, Automation, Basins and so on. Once you click the subfolder, graphics in this 
subfolder show on the right side of the dialog box. 
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In the Build-In Graph folder, you can do the following: 

• To select the appropriate image, click the image and confirm the selection by clicking OK 
button. 

• To search for any kinds of image, enter keywords in the entry field and click Search button 
or press the enter key, and then the result shows on the right side of the dialog box. 

 
  Note 

For using the search function,  
• the search scope is only available for current selected folder. 
• only list the images whose name contains the keywords. 

 

• To copy the selected image to My Graph folder or customized folder, right-click the image 
and select Copy To, then the color image appears in My Graph folder or customized 
folder. 

 

2.9.2 Colors 
There are different kinds of colors in the Color folder.  

In the Color folder, you can do the following: 

• To select the appropriate color image, click the image and confirm the selection by 
clicking OK button. 

• To search for any kinds of the colors, enter keywords in the entry field and click Search 
button or press the enter key, and then the result shows on the right side of the dialog 
box. 

• To copy the selected image to My Graph folder or customized folder, right-click the image 
and select Copy To, and then the color image appears in My Graph folder or customized 
folder. 
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2.9.3 My Graph 
My Graph folder is used for creating customized folder. You can import images from local disk 
to both My Graph folder and customized folder. 

In My Graph folder, you can do the following: 

• To create customized folder, right-click My Graph folder and select New Folder, and then 
a New Folder appears under the My Graph folder. 

 
 

  Note 

The maximum number of supported customized folder is 20. 
 

• To rename the customized folder, 

– right-click the customized folder and select Rename; 

– then the name of the customized folder change to editable state, enter the new name; 

– save the change by pressing the enter key. 

• To delete the customized folder, right-click the customized folder and select Delete, and 
then the customized folder is removed from the My Graph folder. 
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In My Graph folder or customized folder, you can do the following: 

• To Import image from local disk, 

– point to My Graph folder or the customized folder; 

– click Upload Files button to find the directory of the image in your local disk; 

– click Open button to upload the image; 

– then the image appears on the right side of the dialog box. 

 
  Note 

Pay attention to the following issues when you import a image: 
• Supported image formats: PNG, JPG/JPEG, GIF. 
• Acceptable image size: 

- GIF ≤256 KB 
- PNG/JPG/JPEG ≤ 2 MB 

• To improve the LWE and web server performance, LWE might compress some of the 
images you upload. LWE ensures the accuracy of the image when compress it. 

• It takes few minutes to upload high resolution images. 
 

• To copy the selected image, right-click the image and select Copy To in shortcut menu, 
and then the image appears in My Graph folder or customized folder. 

• To move the selected image, right-click the image and select Move To in shortcut menu, 
and then the image move to My Graph folder or customized folder 

• To delete the selected image, right-click the image and select Delete in shortcut menu, 
and then the image is removed from My Graph folder or customized folder. 
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 Tutorial 3 
3.1 Prerequisites for working with the tutorial 

To use this tutorial, you must be familiar with PC operation and you must know how to create 
a project. To download your project, you also need a PC cable, SD card or Ethernet cable for 
connecting the PC interface to your LOGO! device.  

3.2 Basics 

3.2.1 Changing size and position of an object 

Introduction 
When you select a component, it is enclosed by a rectangle with handles. You have the 
following options for changing the size and position of an object: 

• Drag the handles using the mouse. 

• Configure properties in the Inspector window. 
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Change object size 
1. Select the object you want to resize. The selection rectangle appears. The following figure 

shows a selected object: 

 
2. Drag a resizing contact of the rectangle to a new position. The size of the object changes. 

Alternatively, click the size row in the property pane and enter the "Height" and the 
"Width" of the object. 

 
3. Click the Save button. 

Change object position 
1. Select the object whose position you want to change. 

The selection rectangle appears. 

2. Click on the object and drag it to the desired position. 

Alternatively, click the location row in the property pane and enter the coordinates 
"Position X" and "Position Y" for the position. The zero position is located at the top left-
hand corner of the screen. 

 
3. Click the Save button. 
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3.2.2 Setting the variable 
For the digital, analog and some miscellaneous component, you need to set the variable. The 
component filters the variables in Tag table, and only the variables which match the 
component property are displayed in the Variable Name drop down list. 

Set the variables under Properties > Animation: 

1. Click the down arrow at the right of the Variable Name row. 

– If you select Private Tag, the variable you select is local and is only used for the 
component you selected. 

– If you select variables from tag table, the variable you select is global. 

2. Click the down arrow at the right of the IoT Thing Name row. 

You can select Local Device or IoT thing names you bounded in tag table. 

– If you only added local variables in your project, the project can only be downloaded to 
local BM. 

– If you also added variables of IoT things, the project can be deployed to AWS Cloud. 

3. Select block type, block number, block format, decimal places in the corresponding drop-
down list. 

 

Block Type Block Number Writable 
I I1-I24 Read Only 
Q Q1-Q20 Read and Write 
M M1-M64 Read and Write 
AI AI1-AI8 Read Only 
AQ AQ1-AQ8 Read and Write 
AM AM1-AM64 Read and Write 
V VB: 0-850 Read and Write 

Bits: 0-7 Read and Write 
VB 0-850 Read and Write 
VW 0-849 Read and Write 
VD 0-847 Read and Write 
Cursor Key C1-C4 Read Only 
Function Key F1-F4 Read Only 
Shift Register S1.1-S1.8,S2.1-S2.8, 

S3.1-S3.8,S4.1-S4.8, 
Read Only 

4. For the writable block types, you can enable the write function by clicking the check box 
next to Writable. 
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3.2.3 Setting the background color 
LOGO! Web Editor lets you set the background color for some component.  

Requirement 
The object is created and selected. 

Set the background color of an object 
1. Click "..." at the right end of the row background color of the properties pane. 

The color will change to the default value when you select Reset to Default. 

2. Select a color for the background of the object. 

3. Select the check box in the Fill row. 

3.2.4 Setting the background image 
LOGO! Web Editor lets you set the background image for some component.  

Requirement 
The object is created and selected. 

Quintessence 
• Click "..." at the right end of the row background image in the properties pane. 

• Select an image from the Graph Library and click OK. 

3.2.5 Setting the style of text 

Introduction 
LOGO! Web Editor lets you design the text of some component.  

• Font 

• Text color 

• Text Alignment 

Requirement 
The object is created and selected. 
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Set the Text style 
1. Click "..." at the right end of the row "Font" in the properties pane. 

2. Select a font for the selected text. 

The font will change to the default value when you select Reset to Default. 

3. Click "..." at the right end of the "Text Color" of the properties pane. 

4. Select a color for the text. 

The color will change to the default value when you select Reset to Default. 

5. Click the down arrow at the right end of the text align of the properties pane. 

6. Select the text alignment as you need. 

3.2.6 Setting the border and transparency 
LOGO! Web Editor lets you design the border and transparency of some component.  

Requirement 
The object is created and selected. 

Set the border width and style 
1. To set the border width, enter the width value in the row "Border Width" in the properties 

pane. The unit is pixel. 

2. Click the down arrow at the right end of the row "Border style" in the properties pane. 

3. Select the border style as you need. 

4. Click "..." at the right end of the "Border Color" of the properties pane. 

5. Select a color for the border. 

The color will change to the default value when you select Reset to Default. 

Set the transparency 
To set the transparency, enter the value between 0 (non-transparent) to 100 (completely 
transparent) in the row "transparency" in the properties pane. 
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3.3 Getting started with project creation 

3.3.1 Creating a new Project 
After you have installed LOGO! Web Editor tool, you can start to create a new project.  

To create a new project, click the File → New Project or click the New Project button in the 
standard toolbar. 

 → File -> New Project (Page 47)  

Then a new project contains Pages, Global Tags and Navigator appears in the Project tree  
(Page 13) automatically.  

You can work with LOGO! BM to upload (Page 58) or download (Page 56) the project, 
customize the web pages in the Editor pane, combine the different components from the 
Component pane (Page 20), modify the component properties from Properties pane, and visit 
the whole project through Web Server of the LOGO! Base Module. 

 

 Note 

When you create another new project, after you click the Finish button to save the setting for 
Name and Location, the current project will be closed. If you haven't saved the current 
project, LOGO! Web Editor prompts you to save it. 
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3.3.2 Visiting the project through web page 
After deploying the whole project, you can visit it through the web page. 

1. Open the web browser and enter the valid IP address of LOGO! Base Module or URL of Web 
app on AWS. Then the Log on page appears. 

 
  Note 

If you selected "Allow HTTPS access only" for Web server access in LOGO!Soft Comfort, you 
need to install the LOGO! Root Certificate in your operation system or browsers for visiting 
the LWE project on LOGO! BM. On how to install the certificate, refer to the chapter 
"Security-->Installing LOGO! Root Certification" in "LOGO! system manual". 

 

 

2. Enter the corresponding password. 

 
  Note 

The password for logging in BM Web server: Web user or Web guest user password. 

The password for logging in Web app on AWS: the password you set when you deploy the 
project on AWS (Page 50). 

 

3. Select the check box before "to customized site" and click Log on button. Then you can 
navigate to the customized site after logging on. 

 

 Note 

If you download the modified project to LOGO! BM, you'd better log in to the corresponding 
web page again to ensure the correction works. 
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3.4 Practical example 

3.4.1 Introduction for practical example 
This practical sample is applicable to swimming pool level control and light control systems, 
and offer new users a step-by-step introduction. You learn here how to create a whole project 
and the project contains creation procedures for Pages (Page 74), Global Tags  (Page 76)and 
Navigator (Page 77). 

For the detailed configuration information of special components, refer to The example for 
configuring special components (Page 78) chapter. 

3.4.2 The example for Pages 
In this swimming pool project, there are two pages:  

• Home page is the swimming pool level control system and the page name cannot be 
changed; 

• Light control page is the swimming pool light control system and the page name can be 
renamed. 

Home Page for Swimming Pool Level Control  
The swimming pool level control system contains four parts: 

• Tank 

– It is used for water storage. 

– The block contains Image and Analog Bar components. 

• Water valve A 

– It is used for connecting tank and swimming pool to control the swimming pool level. 

– It has two modes: Auto and Manual operation. And both of the two modes have two 
corresponding status: Open or Close. 

– The block contains Text, Rectangle and Digital Value components. 

• Swimming pool 

– It is used for swimming and it use the water-level sensor to monitor the actual water 
level.  

– The block contains Rectangle and Analog Bar components. 

• Water valve B 

– It is used for connecting swimming pool and other pipelines. 

– It has two modes: Auto and Manual operation. And both of the two modes have two 
corresponding status: Open or Close. 

– The block contains Text, Rectangle and Digital Value components. 
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Page for Swimming Pool Light Control  
The swimming pool light control system contains two parts: 

• The lamp and LED control 

– It is used for controlling the lights and recording the running time. 

– The block contains Text, Rectangle, Scale Time and Digital Value components. 

• Schedule for weekday and weekend 

– It is used for controlling the lighting time. 

– The block contains Text, Rectangle, Scale Time and Analog Value components. 
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3.4.3 The example for Tag Table 
In this swimming pool level control and light control system, you can define both digital value 
and analog value in the Tag Table. Here is an example for eight kinds of variables:  

• The Inlet for Water valve A under the manual mode 

• The Outlet for Water valve A under the manual mode 

• Level Control for Swimming pool 

• Level control for Tank 

• Light control for Lamp 

• Light control for LED 

• Schedule control for Weekday 

• Schedule control for Weekend 

The variable in Tag table can customize the alias name and it can be bound with some 
components. Below is just an example screenshot. 
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3.4.4 The example for Navigator 
In this swimming pool level control and light control system, the Navigation bar contains 
three options: link to Home Page (renamed to Level Control), link to Light Control page and 
link for LOG OFF button. 

After editing the Navigator (Page 18), the navigation bar allows you to switch between 
different web pages or log off the project. 

Below is just an example screenshot. 
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3.4.5 The example for configuring special components 
There are more than eleven components in the Component pane. In this swimming pool level 
control and light control system, each block combines with several components.  

For detailed configuration for each component, refer to the section Components pane 
(Page 20).  

Configuration for Analog Bar 
In this example, the tank is used for water storage. When the swimming pool water level 
under the target waterline, the system will give an alarm to the user. The user needs to open 
the Water valve A manually to inject water from the tank. For the tank block, it contains 
Image and Analog Bar components.  

Below is just an example screenshot for configuring Analog Bar. 

 



 Tutorial 
 3.4 Practical example 

LOGO! Web Editor Online Help 

Operating Instructions, 10/2020, A5E42880034 - AC 79 

Configuration for Digital Value 
In this example, Water valve A is used for connecting tank and swimming pool to control the 
swimming pool level. When the swimming pool water level under the target waterline, the 
system will give an alarm to the user. The user needs to open the Water valve A to inject 
water from the tank manually. For the Water valve A block, it contains Text, Rectangle and 
Digital Value components.  

Below is just an example screenshot for configuring Digital Value. 

 

Configuration for Analog Value 
In this example, swimming pool use the water-level sensor to monitor the actual water level. 
When the swimming pool water level under the target waterline, the system will give an 
alarm to the user. This water lever monitor panel also can show the total time and time 
remain for injecting water. For this panel, it contains Text, Rectangle and Analog Value 
components.  

Below is just an example screenshot for configuring Analog Value. 
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Configuration for Analog Slider 
In this example, these two sliders are representing target waterline and time remain for 
injecting water. For these sliders, they contain Text, Rectangle and Analog Slider 
components.  

Below is just an example screenshot for configuring Analog Slider. 

 

3.4.6 Example for adding image from USB camera 
This chapter takes Cam2web as an example to show how Webcam component works.  

Prerequisite 
• Connect and start your IP web camera. 

• Download Cam2web (http://www.cvsandbox.com/projects/cam2web/) and install it on 
your PC. 

 
  Note 

Follow the license terms when using cam2web. 
 

http://www.cvsandbox.com/projects/cam2web/
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Get the image address 
1. Open cam2web.exe. 

2. Set the port under File -> Setting. 

 
 

  Note 

The port you entered must not be occupied by other application. 
 

3. Select the USB camera from the Camera drop-down list  and click the Start streaming 
button. 

In this example, "HP HD Camera" is the camera USB camera connected to the laptop. 
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4. Click Streaming on port ... to view the live page. 

5. Right-click the image and select Copy image address. 

 

Set the Webcam Animation and view the video in LWE project 
1. Create a Webcam component in your LWE project. 

2. Click "..." at the right end of the row Http live stream address. 

3. In the Webcam-Http Live Stream Address window, paste the image address. 

4. Click the down arrow at the right end of the row Live Stream Video Type and select 
MJPEG. 
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3.4.7 Example for adding image for IP camera 
This chapter takes IP webcam and VLC media player as an example to show how Webcam 
component works. 

Prerequisite 
• Install your IP web camera. 

• Log in to the page of the IP camera and make sure it can work. 

• Get the RTSP address of the camera from the camera information page or instruction 
manual. 

Example: rtsp://admin:logo.1234@192.168.0.103/MPEG-
4/ch1/main/av_stream 

• Download VLC media player (https://www.videolan.org/) and install it. 

 
  Note 

Follow the license terms when using VLC media player. 
 

https://www.videolan.org/
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Transcode RTSP into HLS by VLC media player 
1. Go to the Open Media window from Media -> Open Network Stream.... 

 
2. Enter the RTSP address in the marked input field and Click Play. 

 
You should see the monitoring video shows in VLC. 
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3. Restart the VLC. 

4. Go to the Open Media window and enter the RTSP address in the marked input field. 

 
5. Click the down arrow next to Play, select Stream, and click Stream. 

6. Click Next. 
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7. Click the down arrow next to File, select HTTP, and click Add. 

 
8. Enter the port and path. Click Next. 

 
 

  Note 

The port you entered must not be occupied by other application. 
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9. Check the check box next to Activate Transcoding. Select the Output video type as "Video-
Theora + Vorbis (OGG)" and Click Next. 

 
10.Click Stream. 

Your HTTP Live Stream service works after the transcoding. 
 

  Note 

Don't close the VLC until the transcoding is finished.  
 

The address is: http://192.168.0.102:8080/myStream  

192.168.0.102 is the IP address of your computer. 

Set the Webcam Animation and view the video in LWE project 
1. Create a Webcam component in your LWE project. 

2. Click "..." at the right of the row Http live stream address. 

3. In the Webcam-Http Live Stream Address window, enter 
http://192.168.0.102:8080/myStream. 

4. Click the down arrow at the right of the row Live Stream Video Type and select OGG. 
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3.4.8 Visiting the example project through web page 
After you finish the creating a whole project, you can visit this example project through the 
web page. 

Follow the chapter AUTOHOTSPOT to open the project, the below is just an example 
screenshot for visiting the example project through web page. 

 
For more information, refer to ...Tools\LOGO! Web Editor Tool\Sample  folder in the DVD 
ROM. 
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 HTML development interface 4 
 

 

Professional clients can modify the project created by LWE to meet their specific requirements 
on webpage.  

After you bind the HTML element to a BM data, you can monitor the BM data through 
webpage. 

Working principle 
In DBinit(), LOGO! JavaScript scans all HTML elements and transfer data with those having 
server_binding class.  

In the server_binding element, we use range, address, type, length to define and bind a 
data from BM.  

Through show_function and show_param, you can implement a callback method to meet 
their requirements based on the data refresh. 

Follow the below rules when you update the project by the interface. Otherwise, it cannot 
work with BM correctly. 

• Except for htm files, do not delete, move or modify other files. 

• You can add, modify or delete the htm files in LOGO! Web Editor project folder: 

– Do not delete main. htm. 

– You can only modify the part of a htm file between <div id="main"> and </div>. 

– Keep the name of a htm file within 11 characters (a maximum of 8 characters for base 
file name and 3 characters for the extension) 

• Save the modified projects to webroot of SD card. 

4.1 LOGO! data access protocol 
For the use of this interface, your pages should include all the following JavaScript: 

<script type="text/javascript" src="/js/utility.js"> 

</script>  

<script type="text/javascript" src="/js/storage.js">  

</script>  

<script type="text/javascript" src="/js/bigint.js">  

</script>  

<script type="text/javascript" src="/js/encrypt.js">  

</script> <script type="text/javascript" src="/js/ajax.js">  
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</script>  

<script type="text/javascript" src="/js/binding.js">  

</script> 
 

 Note 

You should call the function DBInit() in the page initializing routine, which initializes the data 
binding environments. Otherwise, the refresh framework cannot work. 

 

4.1.1 Operation 

Define a server_binding element 
Define a server_binding class as below. 
<div comp_type="myDigitalComponent" class="server_binding" 
id="mydiv" show_param="mydiv" show_function="myCallback"                                          
range="132" address="0" type="1" length="1"  
text 
</div> 

• id: the unique identifier of an element 

• class=server_binding: scan identifier for JavaScript framework 

• range: the first part of the address 

• address: as the third part of the actual address, address means the data offset from the 
range start. 

• type: data type 

• length: data counts with its type. 

• show_function: define the function that is used to show the data. This function is a 
"callback" function. Framework call the callback function when the binding data is 
refreshed. 

• show_param: parameter for the callback function. 

For more information on the parameters, see Data format (Page 93). 
 

 Note 

Ensure all the parameters are included when you define the sever_binding element. 
Otherwise, the data cannot be bound. 
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4.1.1.1 Command 
This chapter introduces some commands related to LOGO! data access protocol. 

Get 
To get the data in your webpage, you need to do the following two steps. LOGO!’s JavaScript 
framework call the callback function When BM data updates.  

1. Create a server_binding element according to the instruction in Operation (Page 90) . 

2. Implement the declared callback function. 

See an example as below: 
var myCallback = function myCallback() { 
             //get new value 
             var newValue = parseInt(this.m_sValue, 16); 
             //do your actions... 
            $("#xxx").html(newValue); 
 }}; 

When the callback_function is called, the JavaScript framework receives a parameter 
DBRequest. By this parameter, you can get the server_binding emelent related information 
and the updated data as follow. 
 
Property Parameter 
DBRequest.m_nAddress address  
DBRequest.m_nLength  length  
DBRequest.m_nRange range  
DBRequest.m_nType  type  
DBRequest.m_oSrcElement  server_binding element  
DBRequest.m_sShowParam  show_param  
DBRequest.m_sValue value 

Set 
You need to write your own JavaScript code to implement a set query for a server_binding 
element,  

1. Create a DBRequest object for the server_binding element. 

2. Assign a value to DBRequest by SetValue method. 

3. Release a set query by SetQuery method. 

4. Check the m_iSetPendingFlag member to make sure the SetQuery is complete. The ture 
value means SetQuery is pending while the false value means SetQuery is completed. 

You can refer to the example below. 

function DBRequestTest () { 

          var oRequest = new 
DBRequest(document.getElementById("test1")); 

          oRequest.SetValue("00012345"); 
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          if(oRequest.SetQuery()) 

          { 

           while(oRequest.m_iSetPendingFlag) 

           { 

            //wait for a while or give customer some hint. 

           } 

           //done: 

           return true; 

          } 

          //fail: 

          return false; 

        } 

You can also set value for a set of sever_binding elements group. DBGroup object is used for 
collecting the DBRequest objects in this scenario:  

1. Prepare a set of DBRequest objects by the upper description. 

2. Create a DBGroup object. Collect the DBRequest objects by Add method. 

3. Release the set query by the SetQuery method of DBGroup. 

4. Check the m_iSetPendingFlag member to make sure the SetQuery is complete. The ture 
value means SetQuery is pending while the false value means SetQuery is completed. 

You can refer to the example below. 

function DBGroupTest() { 

          var oRequest1 = new 
DBRequest(document.getElementById("test1")); 

          oRequest1.SetValue("00012345"); 

          var oRequest2 = new 
DBRequest(document.getElementById("test2")); 

          oRequest2.SetValue("0x01"); 

          var oGroup = new DBGroup(); 

          oGroup.Add(oRequest1); 

          oGroup.Add(oRequest2); 

          if(oGroup.SetQuery()) 

          { 

           while(oGroup.m_iSetPendingFlag) 

           { 

            //wait for a while or give customer some hint. 

           } 
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           //done: 

           return true; 

          } 

          //fail: 

          return false; 

        } 
 

 Note 

You should call the function DBInit() in the page initializing routine, which initializes the data 
binding environments. Otherwise, the refresh framework cannot work. 

 

4.1.1.2 Data format 
We use range, sub_range, address, type, length to describe a data.  

The range, sub_range, address indicate the address of the data. The length of a date 
indicates its type. For detailed information, refer to the following table. 

 
 
Address 
Space 
Name 

range sub_range address length Recom-
mended 
Access 
Mode 

Reada-
ble/Writable 

Digital Input 129 0 0-63 64 Bits R 
Digital out-
put 

130 0 0-63 64 Bits R/W 

Digital 
Marker 

131 0 0-111 112 Bits R/W 

Variable 132 0 0-6799 6800 Bits, Bytes, 
Words, 
Dwords 

R/W 

Cursor Key 12 0 0-31 32 Bits R/W 
TDE Func-
tion Key 

13 0 0-31 32 Bits R/W 

Shift Regis-
ter 

14 0 0-127 128 Bits R 

NetI 16 0 0-127 128 Bits R 
NetQ 17 0 0-127 128 Bits R/W 
Analog Input 18 0 0-239 240 Words R 
Analog Out-
put 

19 0 0-239 240 Words R/W 

Analog 
Marker 

20 0 0-1023 1024 Words R/W 

NetAI 21 0 0-1023 1024 Words R 
NetAQ 22 0 0-511 512 Words R/W 
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range 
It is the first part of the address. 

sub-range 
It is the second part of the address and reserved for future function extension. The default 
value is 0. 

address 
As the third part of the address, it means the data offset from the range start. 

 

 Note 

Ensure that you provide the offset-address by bits no matter what data type you are 
accessing. 

 

All the address will be validated before access. LOGO! reports an error for an invalid address 
and truncate the address which is out of range 

type 
It means data type. LOGO! has four kinds of data. 
 
Id type length 
1 BOOL 1 bit 
2 BYTE 8 bits 
4 WORD 16 bits 
6 DWORD 32 bits 

length 
It means the data count with its type. 

value 
All data value is presented by a HEX string.  You can convert it into other type for your 
customer, but you must convert it back to HEX array mode before you set it to server. 
 For example, as for data with type DWORD, its value is 0x12345, you will get the string 
“00012345” from server, and if you want to change it to 0x12346, you also should use string 
“00012346”. 
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4.2 Example 
Below is an example of digital component.  

<BODY onload="loadPage()">   

        <DIV  id="wrap"> 

          <div id="main" onclick="hideMenu()" style="width: 1420px; 
height: 880px;"> 

          <div comp_type="myDigitalComponent" class="server_binding" 
id="mydiv" show_param="mydiv" show_function="myCallback"  

             range="132" address="0" type="1" length="1" 

             onclick="sendDigitalRequest(this)" value="0" 

             style="position:absolute; left:389px; top:242px; 
width:84px; height:84px; border:1px solid red;line-height: 84px;"> 

               OFF 

             </div> 

            <script type="text/javascript"> 

                var myCallback = function myCallback() {     

                var id = this.m_sShowParam; //get id 

                var newValue = parseInt(this.m_sValue, 16); // get 
newValue  

                document.getElementById(id).value = newValue;// 
recode the newValue  

                   //response 

                if (newValue == 0) {           

                   $("#"+id).html("ON"); //do your 
actions                             

                     } else {         

                   $("#"+id).html("OFF"); //do your 
actions               

                       }}; 

                 function sendDigitalRequest(obj) { 

                 var id = obj.id; 

                 var oRequest = new DBRequest(obj); 

                   //set value 

                if (obj.value) { 

                     oRequest.SetValue("00"); 

                                 } else { 

                     oRequest.SetValue("01"); 
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                                   } 

                                  //send request 

                if (oRequest.SetQuery()) { 

                         setInterval(checkResult, 1000, oRequest);  

                                       } 

                                          } 

                                        </script> 

                                    </div>  

        </DIV> 

    </BODY> 

Specification 
1. All you custom codes have to be added  between <div id=”main”>  and </div>. 

2. The following four parameters define the LOGO! data access and callback JavaScript 
function:  

– class="server_binding": LOGO! JavaScript will scan all the DIVs and transfer data 
with those DIV having server_binding class. 

– id="mydiv" : You should assign id and show_param with the same DIV. 

– show_param="mydiv": You should assign id and show_param with the same DIV. 

– show_function="myCallback":You need to implement a callback JavaScript 
function and assign its name to “show_function”. 

3. The following four parameters describes the data: 

– range="132": V 

– address="0":0.0 

– type="1":BOOL 

– length="1": 1 

For detailed information, see Data format (Page 93) 

4. The following two parameters are used to submit requests to server. 

– "setDigitalData(obj)" : it’s a customized method, used to submit requests to 
server. 

– "value": used to recode the current data value and could be submitted by 
"setDigitalData(obj)". 
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 Tips and tricks 5 
5.1 How to display a corresponding tooltip for a function key 

In LOGO! Web Editor, you can display a corresponding tooltips both in Standard toolbar and 
Graphic Library. 

Tooltips for Standard toolbar 

In the Standard toolbar, you can use the mouse-over-button function to display the icon 
name, which represents the tooltip. This helps you quickly recall the function of the icon, 
without having to call the menu or the help. 

Below is an example screenshot. 

 

Tooltips for images in Graphic Library 

In Graphic Library, you can also use the mouse-over-button function on each image to display 
the File Name, Item Type, Dimensions and Size information which represents the tooltip.  

Below is an example screenshot. 
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5.2 How to draw a polyline well 
When you active the Polyline component, you can draw the polyline start from left-clicking 
mouse button and end with right-clicking mouse button. 

Every point you click appears a blue square, and a blue arrow goes with your mouse. When 
you finish drawing for the polyline, you'd better move your mouse away from the blue square 
and do the right-click, or else the shortcut menu for right-click function will be popped up. 

 

5.3 How to edit component through the shortcut menu 
Right-click the component to open a shortcut menu that offers you the following functions 
for editing the component: 

• Copy (Page 56) 

• Paste (Page 56) 

• Delete (Page 56) 

• Bring To Front (Page 56) 

• Send To Back (Page 56) 

• Left Rotate (Page 55) 

• Right Rotate (Page 55) 
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5.4 How to import multiple images 

Import multiple images in Graphic Library 

1. Point to My Graph folder or the customized folder where you want to attach the images. 

2. Click Upload Files button to find the directory of the image in your local disk; 

3. Choose the images you want to upload. You can upload multiple images in two ways: 

– To choose a list of sequential images, click the first file you want to upload, hold the 
Shift key on the keyboard and click the last file you want. 

– To choose non-sequential images, click the first file you want to upload, hold the Ctrl 
key on the keyboard and click any further files you want to upload. 

– To choose all the images, hold the [Ctrl+A] key on the keyboard. 

4. Click Open button to upload the images; 

5. Once uploaded you will see the uploaded images appear on the right side of the dialog box. 

5.5 How to add a link connecting to another page 
To add a link connecting to another page in your project, you need to add these parameters 
after your URL: 

 ?!App-Language=" +  

LocalStorage.Instance().Get("logo_current_language") + "&Security-
Hint=" +  

LocalStorage.Instance().Get("logo_current_login_ref"); 

Example:  

window.location.replace(link + "?!App-Language=" +  

LocalStorage.Instance().Get("logo_current_language") + "&Security-
Hint=" +  

LocalStorage.Instance().Get("logo_current_login_ref")); 
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