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1. INTRODUCTION 

1.1 Purpose 

This document describes the MMI Map Editor and Display for the STC Urban 
Traffic Control system (UTC), hereafter referred to as the System. 
The document is written for day-to-day users of the System. 

1.2 Scope 

The document is limited to STC UTC Systems with the standard MMI operator 
interface. 

It is recommended that users of this document should have been on a UTC System 
Operator training course, covering the basic system operation and the Map Editor 
and Display Facilities. 

1.3 Related documents 

Note: In the references below, the characters 'xxx' substitute for the 3 digit 
number which uniquely identifies a particular UTC System i.e. the customer 
variant for these documents. 

1.3.1 Parent Documents 

1.3.1(a) 666/UH/16940/000 System Requirement Specification for an STC UTC  
 System 

1.3.1(b) 666/UH/16940/xxx Customer Requirements Specification 

1.3.2 Kindred Documents 

1.3.2(a) 666/HD/16940/000 Data Preparation Handbook for an STC UTC System 
1.3.2(b) 666/HE/16940/000 System Handbook for an STC UTC System 
1.3.2(c) 666/HF/16940/000 SCOOT User Guide 
1.3.2(d) 666/HG/16940/000 System Management Handbook for an STC UTC System 
1.3.2(e) 666/HH/16940/000 Data Preparation Guide for an STC UTC System 
1.3.2(f) 666/HI/16940/000 Data File Format Guide for an STC UTC System 
1.3.2(g) 666/HD/16067/000 User Handbook for the C-TERM Terminal Emulator 
1.3.2(h) 666/HP/16940/000 Plan Preparation Handbook for an STC UTC System 
1.3.2(i) 666/HT/16940/000 Timetable Preparation Handbook for an STC UTC  

 System 

1.3.3 Reference Documents 

1.3.3(a) 666/KE/16066/000 Glossary of terms 
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1.4 Definitions 

For all definitions and abbreviations used in this and related UTC documentation 
see reference 1.3.3(a). 

1.5 Issue state and amendment 

Issue 01.00  First Issue 

Issues 02.00 to 13.00  Not issued 

Issue 14.00  Updated to reflect V14 software 

Issue 15.00 Updated to reflect V15 software 

Issue 16.00 Not issued 

Issue 17.00 Updated to reflect V17 software 

Issues 18 to 20 Not issued 

Issue 21 Updated to reflect V21 software 

Issue 22 Not issued 

Issue 23 Updated to reflect version 23 of the UTC System 

Issues 24 to 27 Not issued 

Issue 28 Updated to reflect version 28 of the UTC System 
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2. MAP EDITOR AND MAP DISPLAY 

2.1 Introduction 

The Map Editor allows a user to import files in a variety of formats, edit the static 
background, add Live Update Symbols or Group Symbolics to the maps in a 
number of layers and save new composite maps for use by the Map Display 
facility. 

Throughout this handbook the term "map" is used to mean a file consisting of a 
static background and, optionally, live update symbols, which has been saved in 
an internal format and is available for use by the Map Display.  

The facilities are accessed from the MAPS option of the top-level UTC menu, as 
shown in Figure 1. 

 
Figure 1 – Top Level UTC Menu 

2.2 Conventions 

Throughout this handbook the following terms are used: 

• MB1 - "Mouse Button 1". The main button as set up on your mouse. For 
normal configurations this is the left mouse button. 

• MB3 - "Mouse Button 3". The secondary button as set up on your mouse. For 
normal configurations this is the right mouse button for a three-button and a 
two-button mouse. This button is normally used to cancel an operation. 
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3. MAP EDITOR 

3.1 Overview 

The Map Editor is an application for creating maps for use by the Map Display 
application. A map typically illustrates a part of the UTC network and displays 
the current status of the equipment controlling this part of the network. The 
composition of a map, though, is entirely at the user's discretion. 

A map is made up of entities. These are the graphical objects that are displayed on 
the map. The simplest entities are lines, rectangles, ellipses, polygons, text etc. 
and these can be used to draw the static background for a map and live update 
symbolic data. 

There are two types of entities that allow UTC status information to be shown on 
the map - live update symbols and group symbolics. Live update symbols are 
associated with UTC equipment and typically include an information box 
(Infobox), which displays the current status of the equipment. Live update 
symbols also include facilities to allow maps to be linked together such that 
clicking on an area of the screen loads and displays the linked map. Group 
Symbolics allow the user to graphically represent the current stage or state of an 
equipment. Group symbolics are generally used to draw green and red arrows on 
the map to represent each stage of a junction, but other equipment is supported. 

A map may include one or more other maps as background maps. Entities on 
background maps cannot be modified within maps in which they are included. 
Any map created by the Map Editor may be used as a background map. 

The Map Editor can import AutoCAD DXF drawings and Ordnance Survey NTF 
maps. 

The Map Editor is laid out so that the most commonly used tools are available 
through the icon buttons on the left of the drawing area. To see what a button does 
move the pointer to the button and press the left-hand mouse button (MB1). A 
short description of its function is displayed on the line at the bottom of the 
window. Additional help for each of the tools is available through this help 
facility. 

A palette of colours is available below the drawing area. The top row is used to 
select the line drawing colour and the bottom row for the fill colour. The currently 
selected colour for each is shown with a black border around it. These colours can 
be modified or additional colours added. The current colours are also shown in a 
rectangle drawn in the bottom left of the Map Editor window. This rectangle also 
shows other selected attributes - such as line widths, line styles and fill patterns. 

3.2 Screen Layout 

The screen layout is shown in Figure 2. This consists of the following 
components: 

• Drawing area 

• Title bar 

• Menu bar 
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• Tool Box 

• Colour Palette 

• Grid (optional) 

• Horizontal / Vertical Scroll Bars 

• Status Line 

These components are described below. 

 
Title Bar

Menu Bar

Tool Box

Grid

Vertical scroll bar

Horizontal scroll bar

Sample line and
fill styles

Status Line

colour palettes

Drawing Area

 

Figure 2 - Map Editor window 

3.2.1 Drawing area 

The main area of the Editor window is used for editing or drawing. 

3.2.2 Title bar 

The Title Bar shows the name of the currently loaded map and also can be used to 
move the position of the Editor window on the screen. 
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3.2.3 Menu bar 

The Menu Bar contains pull-down menus with additional commands. Detailed 
descriptions of the commands are given in sections 3.5 to 3.12 of this handbook. 

3.2.4 Tool Box 

The Tool Box gives quick access to the most common operations in the Map 
Editor. These are described in sections 3.14 to 3.18. 

3.2.5 Colour Palette 

An on-screen palette is provided for selecting Outline and Fill colours. The palette 
is described in section 3.19. 

3.2.6 Grid (optional) 

The grid is a drawing aid that can be customised as described in sections 3.12.3 
and 3.12.4. 

3.2.7 Horizontal / Vertical Scroll Bars 

The horizontal and vertical scroll bars allow panning of the current viewing 
window. Panning is particularly useful when a Zoom view is used or when the 
Editor window is not maximised. 

3.2.8 Status Line 

At the bottom of the Map Editor Window is a box in which a single line of text is 
displayed. This is context-sensitive help that may either display what the Map 
Editor is currently doing (if it is busy) or what the user may do. When the user 
selects a drawing tool a short description of how to proceed is displayed in this 
line. 

3.3 Pixmap Editor 

The Map Editor includes a separate Pixmap Editor. This can be used to modify 
existing Pixmaps or to create new ones. The new or modified Pixmaps may be 
used as fill patterns within the Map Editor or as live update symbols. It is 
recommended that the Pixmap editor be used before the Map Editor when creating 
pictures in order that a library of Pixmap symbols is available when creating 
maps. This editor is described in more detail in Section 5. 
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Main Menu Bar 

The menu bar as shown in Figure 3 contains a number of pull-down options from 
which the various facilities of the Map Editor can be requested. 

 
Figure 3 - Editor Menu Bar 

The File menu contains options for opening and saving a map, importing, deleting 
maps and for exiting Map Editor. 

The Edit menu contains options for modifying the loaded map in various ways. 
The most commonly used options in this menu are also available from icon 
buttons to the left of the drawing area. Many of these options require the user to 
have pre-selected the entities to work on. 

The Layout menu contains options for inserting special types of entities on a map 
such as background maps and bitmaps. It also includes additional options for 
modifying the map such as changing the map size, grouping and ungrouping 
objects and changing which map layers entities are stored on. 

The UTC menu contains options specific to creating and modifying UTC entities, 
either live update or group symbolics. 

The Fonts menu contains options for changing the attributes of the font used to 
display text, i.e. the font family (Times, Courier, etc.), bold, italic and point size. 

The View menu contains options for modifying how the map is displayed. This 
menu includes options to change which map layers are displayed and to turn the 
snap grid on or off. 

The Zoom menu contains options for changing the zoom factor. The current zoom 
factor is displayed on the pull-down menu label. 

The Options menu allows the user to change various Map Editor options. These 
include toggling snap to grid on and off, changing the grid size and saving the 
Map Editor size and position. 

The Help menu provides various levels of help to the user. 

3.4 Copying Files from a PC to a UTC System Folder 

Windows Explorer may be used to transfer files from a PC to a folder in the UTC 
System, either Alpha based or PC SCOOT. 

After starting Windows Explorer the host name or IP address of the UTC 
computer should be entered in the address box of Windows Explorer and the 
Enter key pressed. After a short delay a window, similar to the shown in Figure 4 
should appear. This window shows all the shared folders of the UTC System.  

If another copy of Windows Explorer is used to locate the file(s) which are to be 
transferred to the UTC System, drag and drop can be used to transfer the files 
from the PC to the UTC System. 
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Figure 4 - Windows Explorer 

Files created in external formats (DXF or NTF) can be transferred to the UTC 
System from a PC for use as background maps and should be transferred to the 
UGE_MAPS folder. 

The same procedure as above can be used for importing bitmap files which should 
be copied to the UTC_PIXMAPS folder. 

3.5 File Menu 

The File Menu contains the options described below. 

3.5.1 New 

Select this option to create a new blank map. The currently loaded map is 
removed; if it has unsaved changes a dialogue box appears asking if you want to 
save the changes. 
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3.5.2 Open 

Select this option to edit a map that has been previously created within Map 
Editor. The dialogue box (see example in 5) includes a list of available maps. 
Each entry in the list contains the map name followed by the title in brackets (if 
the map has a title). Click on one of the maps and click OK to load the map or, 
alternatively, double-click the map. 

 
Figure 5 - File Open 

By default all maps are displayed in the file list. To display a subset of the maps 
you can enter a pattern string in the filter field. Only maps matching the pattern 
string are then displayed in the file list. The following wildcard characters may be 
used in the pattern string. 

• "*" matches one or more characters 

• "%" matches one character 

If another user is editing the map which you have chosen then an error message is 
displayed. 

Select 'Cancel' to quit the file selection dialogue without loading a new map. 

If the currently loaded map has unsaved changes a dialogue box is displayed 
asking if you want to save the changes. 

Save 

Select this option to save the currently loaded map back to disk. The map is saved 
with its original map name. It is recommended that you save the map you are 
working on at regular intervals to ensure that no work is lost in the event of a 
failure in the UTC system, X server, or program. 
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If the map is new and does not have a name then the Save Map dialogue is 
displayed and you should type in the name for the new map. The procedure 
detailed in section 0 should then be followed.Save As 

Select this option to save the currently loaded map back to disk with a new name. 

A Save Map File Selection dialogue box appears which includes a list of existing 
maps. By default all maps are displayed. To display a subset of the maps you can 
enter a pattern string in the filter field. Only maps matching the pattern string are 
then displayed in the file list. The following wildcard characters may be used in 
the pattern string. 

• "*" matches one or more characters 

• "%" matches one character 

To save the currently loaded map using the name of an existing map, click the 
map and then the OK button. You then have to confirm you wish to overwrite the 
existing file with this name. To save the map with a name which does not already 
exist type the name in the selection field. The name that you type in must contain 
only alphabetic or numeric characters or '-', '_', '$' (note, it must not contain 
spaces) and should not be more than 27 characters long. (A free form text 
description for a map can be entered as the title if the map name is not sufficient). 

If another user is editing the map that you have chosen then an error message is 
displayed and you should give the map another name. 

Select 'Cancel' to quit the file selection dialogue without loading a map. 

3.5.3 Import 

Select this option to import an Ordnance Survey NTF file, an AutoCAD DXF file. 

A new map is created from the imported file. If the currently loaded map has 
unsaved changes then a query dialogue is displayed asking if the user wishes to 
save these changes. 

A file selection dialogue is displayed listing the files in the import directory. To 
import a file double-click one of the files displayed. 

Files in NTF format retain their original features e.g. Parish boundaries, street 
markings etc. The edit function allows these features to be modified or deleted in 
whole or in part. See section 3.6.2 for more details. 

Note: External files must be stored in the import directory (UGE_MAPS) 
before they can be used. It is not possible to instigate a transfer from a 
PC to the UTC System from within the Map Editor.  

3.5.4 Delete 

Select this option to delete a map. A file selection dialogue box is displayed 
listing the maps that are available for deletion. Only maps that have been 
imported/created, edited and saved within the Map Editor are available for 
deletion. It is not possible to delete NTF or DXF files. Select a map from the list 
of files and click 'Delete'. 
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3.5.5 Exit 

Select this option to exit Map Editor. If the currently loaded map has unsaved 
changes a query dialogue is displayed asking you if you want to save the changes. 

The Map Editor will not exit if the Pixmap Editor application is still running. A 
warning message is displayed if this is the case. 

3.6 Edit Menu 

The edit menu contains the following options for modifying the currently loaded 
map. 

The use of the first seven of these options provides the same functionality as items 
on the tool bar. See sections 3.17 and 3.18 for more details. 

3.6.1 Change Title 

This option allows the user to change the title of the currently loaded map. A 
dialogue box shows the current title of the map. You can modify or enter a new 
title. Click on OK or APPLY to implement the change. The title is displayed on 
the window title bar. If no title has been defined then the title is the same as the 
map name. This option may be used where it is required to provide a description 
of a map that cannot be contained within the map naming convention. 

 

Figure 6 - Map Title Dialogue Box 

3.6.2 Select Feature 

This option only has meaning when used with imported NTF maps. NTF maps 
give each entity on the map a feature code and include a directory giving a 
description for each feature code. This information is retained when an NTF map 
is imported into the Map Editor and this dialogue allows a user to select entities 
on a map based on their feature code. The dialogue displays a list of features. 
Only features that exist on the map are shown. Select one feature from the list and 
click on OK or APPLY. All entities on the map that have this feature code are 
selected. This allows the user to quickly remove unwanted features or change 
their colours and other attributes. 

Clicking OK or APPLY de-selects any entities which do not have the selected 
feature code, but like other selection operations holding down the SHIFT key 
suppresses this behaviour. 
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3.6.3 Select Map 

This option allows the user to select the current map as a single entity and re-size 
it or change the default colours. 

3.6.4 Select All 

This option is used to select all the selectable entities or entities of one type which 
are on the currently displayed map. This is done by: 

• Select all selectable objects on the map. Ensure that the mouse pointer is the 
arrow, then click on the Select All option. All the selectable objects in the map 
are displayed with their handles highlighted. 

• Select all entities of one type. All the basic drawing entities as described in 
Section 3.14 (Tool Bar - Basic Draw Icons),i.e. - Line, Polyline, Polygon, 
Bezier Curve, Quadrant, Circle Arc, Ellipse, Rectangle, Rounded Rectangle 
and Text Object - can be selectively marked and manipulated. For example, all 
lines can be selected and their style or colour changed in one operation. This is 
done by first clicking on the drawing object icon as if one were to be drawn 
and then clicking on the Select All option from the Edit menu. All the 
selectable entities of this type are then displayed with their handles 
highlighted. 

3.7 Layout Menu 

The Layout menu contains the following options: 

3.7.1 Resize Map 

This option allows the user to change the size of a map. This is typically used to 
select a single junction from a map of a sub-area or large number of junctions and 
then saving the resulting map under a different name. 

To resize the map click on the Layout / Resize option. The mouse pointer changes 
to a cross that should be placed at one corner of the bounding rectangle. Click on 
and hold MB1 and drag the cursor to the other corner of the bounding rectangle. 
To maintain the correct vertical and horizontal content in the resulting map the 
Shift key should be pressed during the operation and only released after MB1 has 
been released. Clicking MB3 at any time during the operation cancels the resizing 
of the map. 

When MB1 is released the selection is resized to fill the available map area and 
may be saved as a new map. 

3.7.2 Insert Background Map 

This option allows a user to insert a previously created map as a background. It is 
normally used when starting from a blank map. The background map is inserted 
as a single entity, i.e. it is not possible to select individual objects on the inserted 
map and change their appearance. The advantage of this method is that it prevents 
objects on the background from being selected "accidentally" whilst editing the 
new map. It also improves the performance of the Map Editor. 
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3.7.3 Insert Bitmap Image 

This option allows the user to insert a bitmap image into the current map. There 
are three types of bitmaps supported by Map Editor. These are X Bitmap Files 
(.XBM), X Pixmap Files (.XPM) and MS Windows bitmap files (.BMP, .DIB). X 
Bitmap files are monochrome images. When an X Bitmap image is inserted on a 
map you can change the colour of the foreground and background pixels of the 
image using the fill and line colours respectively. X Pixmaps and MS Windows 
bitmaps are multi-colour images. You cannot change the colours used by these 
images. 

To insert an image on the map select one of the files and click on Insert. The 
cursor changes to a top left corner pointer. Click on the drawing area where the 
image is to be positioned. 

You can browse through the list of bitmaps available. Select an item in the list and 
its image is displayed in a viewing area on the dialogue. 

To replace an existing bitmap image select the entity. The Insert button label 
changes to 'Replace' and the bitmap that you select replaces the existing image for 
the selected entity. To return to 'Insert' mode deselect any image entities. (Click 
on any empty area of the map or double click the arrow tool). 

To make MS Window bitmaps available for use by the Map Editor you must copy 
the bitmaps onto the TMC computer. See section 3.4 for details. 

You can modify or create new X Bitmap or X Pixmap files using the Pixmap 
Editor. See section 5 for details. 

3.7.4 Group and Ungroup 

This option allows the user to select a number of entities on a map and group 
them together, or to ungroup previously selected entities. Whilst group is enabled 
all the entities in the group can have their attributes changed together. 

The same functionality is also available from the tool bar. See sections 3.18.3 and 
3.18.4. 

3.7.5 Map Layers 

The option allows the user to select which map layers entities are stored on. Select 
one or more layers from the list and click OK or APPLY. 
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Figure 7 - Select Map Layers 

A maximum of 32 map layers is available. These can be named by the user (see 
3.12.5). Map Layers are a useful way of separating the information shown on a 
map into different categories. The user can select which layers are viewed (only 
entities stored on the selected layers are displayed) and therefore remove any 
information from the map that is not of interest. 

When the dialogue is initially shown it displays the currently selected map layers. 
Like most editing functions it operates on the current selection. If any entities are 
selected it shows those map layers on which the selected entities are stored, 
otherwise it shows the default map layers (i.e. those on which subsequently 
created entities are stored). Clicking OK or APPLY updates the selection with the 
selected values. 

Section 6 gives further details. 

3.8 UTC Menu 

The UTC menu options are described below: 

3.8.1 Create Live Update Object 

A live update object consists of the following basic symbols: 

• pixmap - which can be used to select another map, display an infobox, or select 
a number of commands with reference to the associated SCN. 

• hotzone - a rectangular user-defined area with similar properties to a pixmap 

• infobox - a window with status information for the associated SCN 

Some additional special symbols are also available: 

• legend - to display a car park or car park sign status 

• line / polyline / bezier - to display link green and link congestion 

• scale - to display link queue 

The information displayed with these objects is described in more detail in section 
5. 
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To create a live update object, select the dialogue box from the UTC menu or the 
Tool Box, as shown in Figure 8 . 

This option allows a user to create a live update object, define certain 
characteristics of that object and add it to the currently displayed map. The user is 
asked to select a live update symbol from a list of available types. 

 
Figure 8 - Create Live Update Object 

Enter the Object type (from the drop down list), SCN, symbol type and symbol 
representation (from the library of available pixmaps).  

The SCN to be assigned to the live update symbol is entered through a dialogue 
box. The SCN must be valid and of the appropriate equipment type. The 
"General" object does not require an SCN and can be used for defining links to 
other maps. 

The user can select the type of object to create from one of pixmap, hotzone or 
infobox and the special objects legend, line / polyline / bezier and scale. 
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Symbol Types: 

(1) pixmap - choosing this option creates a pixmap with an associated hotzone 
and information box. The default pixmap for the selected object type is displayed 
in the dialogue box. Alternatively, the user can click on the symbol to display a 
library of pixmap symbols which are used with live update objects and select one 
of these instead. Caution - this could lead to confusion if, for example, a car park 
symbol is selected and assigned to a junction SCN. 

For certain object types there is no associated pixmap, but polylines or other 
drawing objects are used. 

 
Figure 9 - Live Update Pixmaps 

The pixmap symbols displayed here can be edited using the Pixmap Editor (see 
section 5). 

(2) hotzone - a hotzone is automatically created with a pixmap. One can also be 
created without an associated symbol. Hotzones define an area of the map used to 
move to another map when the user double-clicks MB1. 

(3) infobox - an infobox is automatically created with a pixmap or a hotzone. The 
information contained in each infobox depends on the equipment type and is 
detailed in section 7. If the infobox is associated with a pixmap it can be selected 
independently of the pixmap and re-positioned on the map for clarity. Example 
infoboxes with associated pixmaps are shown in Figure 10. 

 
Figure 10 - Example Pixmaps with Infoboxes 
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Special Objects: 

(4) legend - an object that can be created for a car park or car park sign. The 
information contained in each legend is a text string with the status of the 
associated equipment. E.g. SPACES or ALMOST FULL 

(5) line / polyline / bezier - objects that change colour to represent a link green or 
link congestion. See sections 7.13 and 7.14 for further details. 

(6) scale - a rectangular object with a green background and filled with a red 
foreground proportional to the length of queue on a link. This is used exclusively 
for the Link Queue symbol. See section 7.15 for further details. 

(7) pie chart - This facility adds two different types of pie chart which may be 
shown on a map display. 

The first type of pie chart shows SCOOT stage splits. The size of each segment of 
the pie chart represents the split as a proportion of the cycle time. The position of 
each segment shows the relative offset (useful when viewing multiple nodes 
running at the same cycle time). 

To insert this type of pie chart, in Map Editor. 

1) Select 'Create Live Update Object'. 

2) Choose 'SCOOT Stage Split' as the UTC Live Update Type. 

3) Select a valid SCOOT node or SCOOT stage SCN. 

4) Choose 'piechart' as the type of object to create. 

5) Click OK or Apply and draw the bounding box for pie chart circle on 
the map. 

If a SCOOT node is selected then the segment for the named stage of the node will 
be drawn in green. The other stages on the SCOOT node will be drawn in other 
(possibly repeating) colours. If SCOOT stage is selected the split for the specified 
SCOOT stage will be displayed in green instead. 

 

Figure 11 - Pie Chart Showing SCOOT Stage Splits (Stage 2 omitted) 

The pie chart includes a “second hand” to show the current position in the cycle. 

The second pie chart shows the UTC stage green replies for a junction for the last 
cycle. The pie chart is incrementally updated every second with the current stage 
replies. In this pie chart, stages representing main road greens are displayed in 
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green and other stages are displayed in other colours. Intergreens are displayed in 
yellow. 

The program decides which stages are main road greens as follows. If the main 
road greens field of the junction data form in data-prep is not empty then it uses 
that data. Otherwise, if the junction is a SCOOT node it uses the stage number 
associated with the named stage. Otherwise, if the junction is not a SCOOT stage 
then stage A is assumed to be the main stage. 

To put a stage green pie chart on a map, repeat the steps as described above with 
the following changes. 

1) Select 'Create Live Update Object'. 

2) Choose 'Stage' as the UTC Live Update Type. 

3) Enter a valid junction SCN. 

4) Choose 'piechart' as the type of object to create. 

5) Click OK or Apply and draw the bounding box for pie chart circle on 
the map. 

 

Figure 12 - Pie Chart showing UTC Stages 

 

3.8.2 Create Group Symbolics 

This enables the user to draw a collection of basic drawing items to represent the 
stages of a junction or pelican controller, including the green-wave and faulty 
conditions. Figure 13 shows examples of the representation of two stages as 
Group Symbolics.  

See section 4 for detailed information on creating Group Symbolics. 
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Figure 13 - Example Group Symbolics 

3.8.3 Change SCN 

This option enables the user to change the SCN of the selected live update object. 
See Figure 14. To modify the existing SCN overwrite the SCN in the box and 
confirm by clicking on either the OK or Apply button. 

 
Figure 14 - Change SCN 

3.8.4 Attach Map 

This option enables the user to attach a map file to a hotzone. A dialogue box with 
a list of available maps is displayed. Choose a file from this list. Using this option 
it is possible to build up a hierarchy of maps for use in the Map Display facility. 
See Figure 15. 
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Figure 15 - Attach Map 

3.8.5 User Text 

This option allows the user to add descriptive text to the details contained in the 
information box created with a live update symbol (see section 3.8.1). See 
example in Figure 16.  

Enter the text to be displayed. If more than one line of text is required, press 
<Enter> to start a new line of text. Confirm the text by clicking on the OK or 
Apply button. 

 
Figure 16 - User Text 

3.8.6 Attach Command 

This option allows a command to be attached to a live update symbol.  
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Select a command from the drop down list or type a command directly into the 
box. If a command is chosen from the list delete its description and type in the 
actual command wanted. 

Confirm the command by clicking on the OK or Apply button. 

3.8.7 Display Information Box 

This option only applies to live update symbols which have a pixmap (or hotzone) 
associated with them. The infobox is displayed when the user either selects this 
menu option or double clicks on the live update pixmap or hotzone. 

3.8.8 Highlight When Faulty 

This option must be selected in conjunction with a live update symbol. The 
symbol is highlighted (in the Map Display facility) in different colours according 
to the level of the current fault, as follows: 

• Red - major fault 

• Magenta - minor fault 

• Yellow - information only. 

3.8.9 Highlight When Active 

This option toggles on/off and must be selected in conjunction with a live update 
symbol. The symbol is edged green in the Map Display facility when active, for 
example when a Remote Request reply bit is sent. 

3.8.10 Blinking On/Off 

This option toggles on/off and must be selected in conjunction with a live update 
symbol. The symbol starts to blink when selected and continues until deselected. 

3.9 Fonts Menu 

This option allows to user to change the font on the currently selected text. The 
style can be chosen from a list of font names. Text size is chosen from a pre-
defined list of point sizes or alternatively from a free-format dialogue box. An 
additional option permits the text to be rotated in increments of 1 degree. Figure 
17 displays the Font options menu. 
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Figure 17 - Font options 

3.10 View Menu 

The View menu is displayed in Figure 18. 

 
Figure 18 - View menu 

3.10.1 Map Layers 

This option allows the user to select which map layers are displayed. One or more 
map layers may be selected from the list of layers displayed. Click the OK or 
APPLY button when you have made your selection. The dialogue only shows 
map layers that are used on the map in the list. By default all entities are stored on 
layer 1 (normally called DEFAULT). The View Map Layer dialogue box is 
shown in Figure 19. 
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You can change the map layers on which entities are stored using the Map Layer 
Dialogue and you can name the map layers using the Name Map Dialogue (see 
list of additional topics). 

See section 6- USING MAP LAYERS for a description of map layers. 

 
Figure 19 - View Map Layer dialogue 

3.10.2 Display Grid 

This option allows the user to toggle the display of the grid. The grid options are 
described in section 3.12.4. 

3.10.3 Refresh Window 

This re-draws the contents of the Map Editor window. 

3.10.4 Hotzone Information Box Window Mode 

This option provides a pseudo-simulation of the Map Display functions. When the 
cursor is moved over a hotzone it changes from an arrow-head to a pointing hand. 
When this mode is selected the mouse buttons operate as follows when used with 
a Live Update Symbol: 

(1) Pixmap, Hotzone 

MB1 has no effect. 

Note: In order to select the symbol in this mode it is necessary to draw a box 
around the symbol by dragging the mouse with MB1 depressed. 

Double clicking on MB1 calls up the attached map, if present, or 
alternatively toggles the display of the infobox. 

MB3 displays a menu of commands that are appropriate to the equipment 
type if there is an SCN attached to the pixmap. 
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(2) Infobox 

The mouse buttons have no effect in this mode. 

3.11 Zoom Menu 

The Zoom menu is displayed in Figure 20. 

 
Figure 20 - Zoom menu 

3.11.1 25% - 1600% 

Zoom commands magnify or shrink the map area for better editing control. To 
return to no-Zoom select the 100% option. The Zoom-out (shrink) factors (25% to 
50%) are useful for seeing the entire map on the screen. The Zoom-in (magnify) 
factors (200% to 1600%) are useful for editing fine detail. 

3.11.2 Select Area 

The Select Area option is used to select the exact area to be displayed in the Map 
Editor window. Click and hold MB1 on one corner of the bounding rectangle and 
then drag the mouse pointer to the opposite corner. On releasing MB1 the selected 
area is magnified. 

3.11.3 Fit to Window 

The map is enlarged or reduced so that it is totally visible in the Editor window. 

3.11.4 Other 

This option sets the resolution at which the map is displayed. Enter a zoom factor 
between 25 and 1600%. 100% is the normal size. Values greater than 100% zoom 
in showing greater amounts of detail. Click on OK or APPLY to display the map 
at the new resolution. 



UTC Map Editor and Display  666/HC/16940/000 

hc16940_V28.DOC  Issue 28   Page: 25 

3.12 Options Menu 

The Options menu is displayed in Figure 21. 

 
Figure 21 - Options menu 

3.12.1 Pixmap Editor 

This option runs the Pixmap Editor application. The Pixmap Editor allows you to 
create your own X Bitmaps or Pixmaps or modify existing ones. You can then 
insert these on a map either as an image or as a tiled fill pattern. See section 5 - 
PIXMAP EDITOR for more details. 

3.12.2 Unlock Background Maps 

A map can have one or more background maps inserted. For example, two or 
more DXF files may cover the area of the map being drawn and the user wishes to 
combine them so that the resulting background displays the correct area. The 
maps are first inserted by the Edit / Insert Background Map option (section 3.7.2). 
After setting the Unlock Background Map option the component background 
maps can be moved and resized. On completion, set this option OFF to avoid 
unintentional modifications to the background. 

HINT: By changing the Zoom factor to 50% it is easier to view the whole map 
area for manipulating the background maps. 

3.12.3 Snap to Grid 

The Snap to Grid option allows the user to draw with precision by horizontally 
and vertically aligning objects to the nearest grid marker. This is useful for 
spacing or sizing objects precisely or aligning them to a given vertical or 
horizontal position. 

3.12.4 Grid Options 

This dialogue box is selected from the Options menu. The dialogue box, 
seeFigure 22, shows the current grid settings and permits the user to modify them. 
The X and Y origin refer to the starting point of the X and Y grid co-ordinates 
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with reference to the top left corner of the drawing area. These can normally be 
left at their default values of 0. The width values refer to the spacing between the 
grid lines. For example when an object is being drawn, moved or resized the 
object handle nearest to the selection point snaps to the closest grid point. It is 
normal for the width and height of the grid to be the same value. 

 
Figure 22 - Grid Options 

3.12.5 Name Map Layers 

This option allows the user to give names to each of the 32 map layers. The 
current names are displayed in the list (see Figure 23). To change a name, enter 
the map number (1-32) followed by its new description in the text entry field. To 
modify an existing description, select it from the list. The map number and 
description are copied to the text entry field allowing you to modify them. Click 
OK or APPLY after typing in each new description. 
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Figure 23 - Name Map Layer 

It should be noted that the names you give to the map layers apply to all maps not 
just to the map that is currently loaded. 

See Section 6 for further information. 

3.12.6 Preferences 

The options that can be set are shown in Figure 24. 

 
Figure 24 - Preferences 
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These options are: 

• Copy background colour from background map - if enabled then on inserting a 
background map the background for the existing map is copied from the 
background map. 

• Set Background colour to black - if enabled then DXF maps are imported onto 
a black background. If disabled then the default colour background is used. 
Note that the background colour of a map may be changed at any time by 
selecting the map and then clicking on one of the colour fill options. 

• Set map size from active viewport - If a DXF file includes information about 
the active viewport (i.e. which portion of the map the user was viewing when 
the DXF file was created) then enabling this option causes the DXF import 
filter to set the map size from this viewport. The default for this option is off, 
which sets the size of the map so that it is just large enough to contain all the 
entities on the map. Enabling the option is useful for some DXF maps that 
contain miscellaneous entities separated by some distance from the main 
image. 

• Import disabled map layers - if enabled this option causes the DXF import 
filter to load entities on disabled map layers. The default value is OFF. 

3.12.7 Web Export Options 

The licensable Web Export Options screen allows the user to specify the 
following: 

• Host name or I/P address to which the maps are to be exported 

• FTP User Name 

• FTP Password 

• FTP Path 

• Width of GIF image 

• Height of GIF image 

• Maps to be exported. 

3.12.8 Save Layout 

This saves the Map Editor window size and position so that when the Editor is 
opened again this layout is restored. 

3.12.9 Save Options 

This saves the options defined in the Preferences dialogue, i.e.: 

• Copy background colour from background map 

In addition, for DXF import options: 

• Set background colour to black 

• Set map size from active viewport 
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• Import disabled map layers 

Plus the following: 

• Display grid 

• Snap to Grid 

3.12.10 Restore Options 

Restore the options saved above. 

3.13 Help Menu 

The help menu provides various levels of help to the user. 

Check out the list of additional topics for more information. 

3.13.1 Help On Context 

This option provides context sensitive help. The cursor changes to a question 
mark. Move the cursor to the part of the window you want help on and click 
MB1. To cancel, click the cursor on any part of the screen background. 

3.13.2 Help On Window 

This option gives an overview of the window from which it was selected and 
additionally provides access to more detailed levels of help on specific items. 
Select this option if you are new to Map Editor. 

3.13.3 Help On Help 

This options displays help on using the Map Editor help facility. Select this option 
to learn how to use the help facility. 

3.13.4 Help On Version 

This option gives summary information about this version of Map Editor. 

3.13.5 Status Line Area 

This displays a short line of descriptive text on the current selection. See section 
3.2.8 for further details. 

3.14 Tool Bar - Basic Draw Icons 

On the left of the drawing area are positioned a number of icon buttons. These are 
the drawing tools. The first group is for creating entities and the second is for 
modifying attribute entities or performing other editing operations. To see what a 
tool does press MB1 on the tool button. A short description of its function is 
displayed in the assistance line at the bottom of the window. 

Clicking once on any drawing tool (except the UTC tools) in the first group 
allows the user to create one instance of that entity before returning to selection 
mode (the default mode). Double-clicking a tool allows the user to create multiple 
entities. 
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3.14.1 SHIFT and CONTROL keys 

These keys have special functions when used with the basic drawing tools. These 
are: 

• SHIFT - used to constrain the drawing object when drawing. 

• CONTROL - The drawing object is centred on the first point drawn. 

• SHIFT and CONTROL - combines both functions. 

Their use is described for each drawing object where appropriate. 

3.14.2 Selection Mode Pointer 

The selection pointer is used to select one or more items in the drawing area of 
the editor. This is the default mode and is shown as a black arrow in the drawing 
area. 

To select a single object, lick with MB1 on the selection pointer if this is not 
already selected, then click on to any part of the object. The object's handles are 
then displayed. 

To select a number of objects there are two alternative methods: 

1. To select a number of separate objects. Click on the first object to select it. 
Then hold down the Shift key and click on the other objects to be selected. All 
the handles on the selected objects are displayed. 

2. To select objects using a selection frame. Drag the pointer across the objects. A 
selection frame, which is a rectangular box, appears as you drag. All the 
objects that lie completely within the selection frame are selected. Note that 
additional items can be selected by using the previous method. 

3.14.3 Create a Line 

Straight lines are created by clicking on the line draw icon, moving on to the 
drawing area of the map, clicking and holding MB1 to define the start point, then 
dragging the pointer to the end point and releasing MB1. The use of the SHIFT and 
CONTROL keys is: 

• SHIFT - the line is constrained to multiples of 45 degrees. 

• CONTROL - The first point drawn becomes the centre of the line. 

3.14.4 Create a Polyline 

A polyline is an open object, consisting of a number of connected lines. Polylines 
are drawn by clicking on the polyline icon, moving the pointer on to the drawing 
area, clicking MB1 once to define the first and subsequent points and double 
clicking to define the end point. 

• SHIFT - the current segment can only be drawn in multiples of 45 degrees. 

• CONTROL - has no effect. 
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3.14.5 Create a Polygon 

A polygon is a closed polyline. It is drawn in the same fashion to a polyline. The 
end point is automatically connected to the first point.  

• SHIFT - the current segment can only be drawn in multiples of 45 degrees. 

• CONTROL - has no effect. 

3.14.6 Create a Bezier Curve 

A bezier curve is defined by its start and end points and a number of intermediate 
control points. Click on the bezier curve icon and move the pointer into the 
drawing area. Click MB1 once to define the first point, click again for the end 
point and click for each intermediate point. The last control point is defined by a 
double click on MB1. 

• SHIFT - the start and end points are constrained to line in multiples 
of 45 degrees. 

• CONTROL - has no effect 

Figure 25 shows two Bezier curves, the one on the right with its start, end and 
control points visible. 

To edit a curve first select it then move the position of either of the end points or 
any of the control points. 

start point

end pointcontrol points  
Figure 25 - Bezier curves 

3.14.7 Create a Quadrant 

An elliptical or circular quadrant is drawn with this tool. With the pointer in the 
drawing area, click on hold MB1 to draw the starting point and drag the pointer to 
the end point, then releasing MB1.  

• SHIFT - the start and end points are constrained to line in multiples 
of 45 degrees. 

• CONTROL - the elliptical quadrant is constrained to a circular 
quadrant. 

• SHIFT and CONTROL - combines both functions. 

Example quadrants are shown in Figure 26. The first is an unconstrained elliptical 
quadrant, the second a constrained circular quadrant. 
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Figure 26 - Quadrants 

3.14.8 Create a Circle Arc 

A circular arc is a segment of a circle. To draw an ellipse or circle, see 3.14.9. A 
segment is drawn with three defining points. Click and release MB1 for the start 
point. Move the pointer to the end point and click MB1 again. Then move the 
pointer to the third point to define the shape of the arc and click MB1. The segment 
is created. 

• SHIFT - constrains the start and end points to lie on a line in multiples of 45 
degrees. 

• CONTROL - has no effect. 

start point

end point

third point

 
Figure 27 - Circle arcs 

3.14.9 Create an Ellipse 

To create an ellipse, click on the ellipse icon in the toolbox, move the pointer to 
the drawing area, click and hold MB1 to define the first point and drag the pointer 
to define the size and shape of the ellipse and then release MB1. 

• SHIFT - constrains the object to be a circle or a vertical or horizontal line. 

• CONTROL - the first point becomes the centre of the ellipse. 

• SHIFT and CONTROL - combines both functions. 

Figure 28 displays two ellipses, the one on the right being constrained to a circle 
by holding down the SHIFT key. 

 



UTC Map Editor and Display  666/HC/16940/000 

hc16940_V28.DOC  Issue 28   Page: 33 

 
Figure 28 - Ellipses 

3.14.10 Create a Rectangle 

To create a rectangle, click on the rectangle icon in the toolbox, move the pointer 
to the drawing area, click and hold MB1 to define the first point and drag the 
pointer to define the size and shape of the rectangle and then release MB1.  

• SHIFT - constrains the object to be either a square  or a vertical or horizontal 
line. 

• CONTROL - the first point becomes the centre of the rectangle. 

• SHIFT and CONTROL - combines both functions. 

Figure 29 displays two rectangles, the one on the right being constrained to a 
square by holding down the SHIFT key. 

 
Figure 29 - Rectangles 

3.14.11 Create a Rounded Rectangle 

Rounded rectangles are identical to rectangles except their corners are rounded, as 
shown in Figure 30. 

 

 
Figure 30 - Rounded rectangles 
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3.14.12 Create a Text Object 

A text object is created by clicking on the Text icon, moving the pointer to the 
position in which the text is to be entered and then typing in the text. On 
completion, press the Enter key to complete the operation. The SHIFT key 
operates in the normal way for text by changing to and from upper case letters. 
The CONTROL key has no effect. 

 

3.15 Tool Box - Live Update Icons 

3.15.1 Create a Live Update Object 

See section 3.8.1 for the creation of live update objects. 

 

 

3.15.2 Create Group Symbolics 

See section 4 for the creation of Group Symbolics. 

 

 

3.16 Tool Box - Style Edit Icons 

The second grouping of icons in the Tool Box is for modifying the characteristics 
of drawing objects, such as colour, line thickness and style. 

3.16.1 Add a New Colour to the Palette 

The colour palette (see Figure 37) displays the palettes for outline and fill colours. 
When this is selected the standard colour mixing dialogue window is displayed. 
The user can create new colours that are then added to the palette (see section 
3.19). 

3.16.2 Set Line Width 

This dialogue allows the user to change the line width for the selected entities. 
The current line width is shown in the text entry field. The units are pixels (when 
displayed at 100%). Type in the new line width (0-100). Fractional values are 
allowed. Click OK or APPLY to change the line width of the selection to the new 
value.  

Lines with the hairline width are non-scaleable and are displayed with a pixel 
width of 1 at all zoom factors. Non-zero widths are scaleable. 
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3.16.3 Set Line Style 

This dialogue allows the user to change the dash length for the selected entities. 
The current dash length is shown in the text entry field (unless the current line 
style is solid or is one of the pre-defined line styles). The units are pixels. Type in 
the new dash length (1-100). Click OK or APPLY to change to the new the dash 
length. 

Lines defined with the hairline thickness that is not scaleable are displayed the 
same at all zoom factors. To change the line to solid select the solid from the line 
style menu (selected from the icon button on the left of the drawing area). 

3.16.4 Set Fill Pattern 

This dialogue is selected from the fill pattern icon button. It allows the user to 
select the bitmap pattern used to fill a shape. There are three types of bitmaps 
supported by Map Editor. These are X Bitmap Files (.XBM), X Pixmap Files 
(.XPM) and MS Windows bitmap files (.BMP, .DIB). X Bitmap files are 
monochrome images. 

When an X Bitmap image is used as a fill pattern you can change the colour of the 
foreground and background pixels of the pattern using the fill and line colours 
respectively. X Pixmaps and MS Windows bitmaps are multi-colour images. If 
these are used to fill a shape then the fill and line colours are not used and the 
image is tiled as-is in the shape. 

To set the fill pattern for the selected entities double-click a file in the list. 

You can browse through the list of bitmaps available. Select an item in the list and 
its image is displayed in the viewing area on the dialogue. 

To make MS Window bitmaps available for use by the Map Editor you must copy 
the bitmaps onto the TMC computer. See below for details. 

You can modify or create new X Bitmap or X Pixmap files using the Pixmap 
Editor. See section 5 for details. 

3.16.5 Set Arrow-Head Style 

Lines, polylines and bezier curves can be terminated with or without arrow-heads. 
The options are none, one end, the opposite end or both ends. Examples are shown 
in Figure 31. 

 
 



UTC Map Editor and Display  666/HC/16940/000 

hc16940_V28.DOC  Issue 28   Page: 36 

 
Figure 31 - Arrow line terminations 

3.16.6 Rotate Text 

Text can be rotated in increments of 1 degree between -180 and 179. To rotate text, 
first select the text object to be modified and then click on the Rotate Text icon. A 
dialogue box opens (Figure 32) and the angle of the rotation can be entered. 
Confirm by clicking on the OK or APPLY button. 

 

 
Figure 32 - Rotate Text dialogue box 

NOTE: The angle entered into the dialogue box refers to rotation from the 
original horizontal orientation and is not added to a previously applied 
rotation. 

An example of text after being rotated is shown in Figure 33. 

 
Figure 33 - Example of rotated text 
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3.17 Tool Box - Editing Facilities 

3.17.1 The Clipboard 

The clipboard is used to cut, copy and paste objects within a map and also transfer 
these objects between maps. The clipboard contains the most recently cut or 
copied object(s) until something else is cut or copied to it. 

3.17.2 Cut 

Cutting an object removes the object from the picture and places it on the 
clipboard. The object can then be replaced in this map or pasted into another map 
with the Paste command. Multiple objects can be cut to the clipboard. To cut an 
object, execute the following: 

• Select the object or objects to be cut 

• Click on the Cut icon or select Cut from the Edit menu. The selected object(s) 
is (are) removed from the map and placed in the clipboard. 

3.17.3 Copy 

Copying makes a copy of the object and places it on the clipboard without 
removing the object from the map. The copy of the object can then be pasted back 
into this or another map with the Paste command. Multiple objects can be copied. 
To copy an object: 

• Select the object or objects to be copied 

• Click on the Copy icon or select Copy from the Edit menu. The selected 
object(s) is (are) copied to the clipboard but not removed from the map. 

3.17.4 Paste 

Pasting places a copy of the object(s) stored on the clipboard into the current map 
without removing the object(s) from the clipboard. In this way multiple pastes can 
be performed into a single or multiple maps. To paste an object execute the 
following actions: 

• Click on the Paste icon or select Paste from the Edit menu. The contents of the 
clipboard are then pasted into the map. The pasted object(s) become selected 
whilst the previously selected objects are deselected. 

• This process can be repeated to copy the object(s) on the clipboard to the same 
or to other maps. 

3.17.5 Delete 

Delete removes an object or objects from the current map. However, unlike Cut, 
the objects are not stored on the clipboard and cannot subsequently be recovered. 
The contents of the clipboard are unaffected. To delete an object execute the 
following actions: 

• Select the object or objects to be deleted 
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• Click on the Delete icon or select Delete from the Edit menu. The selected 
objects are removed from the map but not stored in the clipboard. 

3.18 Tool Box - Alignment and Grouping 

The commands Bring to Front and Send to Back let you control the overlapping of 
objects. Grouping is useful for manipulating a number of objects as one. For 
example, to move them all the same distance or copy all to the clipboard. 

3.18.1 Send to Back 

To send an object to the back of a number of overlapping objects: 

• Select the object you want to send to the back 

• Click on the Send to Back icon or select Send to Back from the Edit menu. 

3.18.2 Bring to Front 

To bring an object to the front of a number of overlapping objects: 

• Select the object you want to bring to the front 

• Click on the Bring to Front icon or select Bring to Front from the Edit menu. 

Figure 34shows the use of Send to Back. On the left are three overlapping objects. 
The right shows the overlapping after the triangle has been selected and sent to 
the back. The operation Bring to Front on the triangle would then bring it to the 
front again. 

 
Figure 34 - Example of Send to Back 

3.18.3 Group 

Two or more objects can be grouped together by: 

• Selecting all the objects to be grouped 

• Clicking on the Group icon or selecting Group from the Edit menu. 

3.18.4 Ungroup 

A group of objects can be ungrouped by: 

• Selecting any one of the objects in the group which selects the whole group 

• Clicking on the Ungroup icon or selecting Ungroup from the Edit menu. 

Figure 35 shows three objects on the left that have been selected. After these 
objects have been grouped they appear as a single grouped object on the right. 
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Figure 35 

Figure 35 - Grouping objects 

Figure 36is an example of manipulating a group of objects. The group shown 
above has been stretched, the operation being performed on all the elements of the 
group. 

 
Figure 36 - Example of manipulating a group 

3.19 Colour Palette 

The colour palette is split into two rows as shown in Figure 37. The top row is 
used for selecting the outline drawing colour. The bottom row is for selecting the 
fill colour. Click on the button to change the colour to that shown on the button. 
The button showing None indicates that the colour is set to transparent - i.e. no 
drawing is done. E.g. set the fill colour to 'None' if the outline only of a shape is 
required. Set the line drawing colour to None if a filled shape with no border is to 
be drawn. 

You can modify any colour by double clicking its button. A colour mixing 
dialogue is created to re-define the selected colour. All entities using that colour 
are changed to use the new colour (except entities on background maps). See also 
section 3.16.1 for information on creating new colours. 

outline colours

current outline
and fill colours fill colours  

Figure 37 - Colour Palette 



UTC Map Editor and Display  666/HC/16940/000 

hc16940_V28.DOC  Issue 28   Page: 40 

4. GROUP SYMBOLICS 
Group Symbolics are used to display symbolic street movements based on the 
controller reply stages. Each stage and intergreen, plus Green Wave and the faulty 
(isolated) state can be displayed in a combination of all the basic drawing objects. 
For example, stage A could show green arrows for the main road movement and 
red lines or arrows for the side roads and an isolating fault could be displayed as a 
large red text message. It should be noted that the Link Green live update object 
could also show green or red arrows or lines to represent link movements. 
However, these only have significance when the intersection is under SCOOT 
control and the intergreen, Green Wave and faulty conditions cannot be displayed. 

Each map can have group symbolics for one or more of the following types of 
equipment: 
• Intersections 
• Pelicans 
• Diversion Signs 
• Car Park Signs 
• Count Detectors 
• Queue Detectors 
• Special Facilities 
• Remote Request 
• Tidal Flow Controller 
• SCOOT links 
• Outstation Reply Bits 

The setting up procedure is described below for an intersection. The other 
equipment types can be set up in a similar fashion. 

4.1 Creating a Symbolic for an Intersection 

The steps in creating a Group Symbolic for an intersection are the following: 

• Open the Map Editor and define the background to be used. For example, if 
symbolics for an intersection is to be defined, an NTF or DXF drawing of the 
intersection layout could be imported and set as the background map. 

• Click on the Group Symbolic icon or select Create Group Symbolics from the 
UTC menu in the Map Editor. The dialogue box in Figure 38is displayed. After 
one or more SCNs have been added to the map, these appear in the list of 
group symbolics that can be edited. 
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Figure 38 - Group Symbolic SCN dialogue 

• Enter the SCN of a valid intersection in the selection box and click on the Edit 
button. The dialogue box in Figure 39appears, which displays all the available 
stages and intergreens plus the Green Wave and faulty condition. 

 
Figure 39 - Edit Symbolics dialogue 
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• Start defining the graphic symbols for one stage - A for example - by selecting 
the stage and clicking on the Edit button. All further editing to the map defines 
this stage and is only terminated when Close is clicked in the Edit Condition 
window or another stage is chosen for editing. 

 

green arrows red stop
line

 

Background Map  Stage A 

Figure 40 - Drawing stage A 

• When stage A is completed, the same graphics can be used to define other 
stages. For example, the intergreen leaving stage A can be identical except that 
the green lines are changed to yellow. This is easily done before leaving the 
editing of stage A by: 

( a) Selecting all the elements that represent stage A, by enclosing them in 
a bounding rectangle, or clicking on Edit / Select All 

( b) Copying the selection to the clipboard by clicking on the Copy icon or 
selecting Copy from the Edit menu. 

( c) In the Edit Condition dialogue box click on "A-"; that is the intergreen 
leaving stage A. 

( d) Now copy the contents of the clipboard on to the map by clicking on 
the Paste icon or selecting Paste from the Edit menu. 

( e) The intergreen A- is now identical to the symbolics for stage A. 
Modify the green lines to be yellow and/or dotted, or change the 
drawing elements in some way to distinguish the intergreen from 
stage A. 

• This sequence can now be repeated to define the remaining stages and 
intergreens. 

• If required, the Green Wave and fault conditions can be drawn. Figure 41 
shows examples of these two conditions. 
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Green Wave  Faulty condition 

Figure 41 - Green Wave and Faulty Symbolics 
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5. PIXMAP EDITOR 
This section describes the Pixmap Editor that is an integral part of the Map Editor. 

 
Figure 42 - Pixmap Editor 

The Pixmap menu bar is made up of commands that are similar to the main Map 
Editor window and which are briefly described below. 

5.1 Mouse Buttons 

When drawing with the mouse all objects drawn with MB1 are displayed in the 
selected colour from the palette and objects drawn with MB3 use the defined 
background colour. 

5.2 File Menu 

The commands in the file menu are: 
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5.2.1 New 

Clear the contents of the Pixmap Editor to start creating a new pixmap. If a 
modified pixmap is displayed in the editor window the user is questioned if he 
wishes to save it or not. 

5.2.2 Open 

Opens an existing pixmap. A dialogue box is displayed with a list of files that can 
be opened. 

5.2.3 Save 

Saves the existing pixmap; if the pixmap is new see "Save As" below. 

5.2.4 Save As 

The user is requested to enter a name for the file and also whether it is to be saved 
as a standard colour pixmap with extension .XPM or as a monochrome bitmap 
with extension .XBM. 

5.2.5 Delete 

Deletes an existing pixmap. A dialogue box with a list of the existing pixmaps is 
displayed. The user then can select a map and confirm it is to be deleted. 

5.2.6 Exit 

Closes the Pixmap Editor. If any changes have occurred the user is requested to 
confirm whether he wishes to save his changes or not. 

5.3 Edit Menu 

The commands in the Edit menu are: 

5.3.1 Cut 

Cuts the selected area to the clipboard and removes it from the current pixmap. 

5.3.2 Copy 

Copies the selected area to the clipboard but does not remove it from the current 
pixmap. 

5.3.3 Paste 

Pastes the contents of the clipboard into the current pixmap. 

5.3.4 Clear 

Deletes the selected area from the pixmap. After the selection is deleted it cannot 
be restored. The contents of the clipboard remain unchanged. 
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5.3.5 Select All 

Selects everything in the pixmap. 

5.4 View Menu 

The View menu consists of: 

5.4.1 Fatbit Size 

This defines the size that each bit of the pixmap should occupy in the editor. This 
is solely for aiding the editing of the pixmap by enlarging each pixel. The possible 
options are: 

• 2 x 2 pixels 

• 4 x 4 pixels 

• 8 x 8 pixels 

• 16 x 16 pixels 

5.5 Colours Menu 

See Sections 3.16.1 and 3.19 for details of the use of colours. 

5.6 Options Menu 

The Options menu consists of: 

5.6.1 Pixmap Size 

This defines the size of the pixmap to be edited. The height and width of the 
pixmap is entered in pixels into the dialogue box. 

5.7 Window Menu 

The Window menu consists of: 

5.7.1 New Window 

Creates another window for editing such that two pixmaps can be edited at the 
same time. Elements can be copied from one to the other by means of the 
clipboard. 

5.7.2 Show Clipboard 

Opens another pixmap window and displays the contents of the clipboard. 

5.7.3 Capture Screen Image 

Allows the user to mark an area of the screen to be copied into the pixmap editor. 
Care should be taken in defining the area to be copied as the resulting file could 
be extremely large. 
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5.8 Tool Bar 

The Pixmap Tool Bar is similar to the Map Editor Tool Bar and is described 
below. 

5.8.1 Selection Pointer 

Selects part of the drawing area. Subsequent operations can then be performed on 
this area. 

 

5.8.2 Pencil 

Draws a free-form line of 1 pixel width and the selected colour. 

 

 

5.8.3 Draw Line 

Draws as near as possible an approximation to a straight line of 1 pixel width and 
the selected colour. 

 

5.8.4 Colour Fill 

This allows an area of the pixmap to be filled with a single colour. First select the 
colour from the palette and then click the Colour Fill icon. When a pixel in the 
drawing area is clicked on, all neighbouring pixels with the same colour are filled 
with the selected colour. 

5.8.5 Draw Wireframe Rectangle 

An outlined wireframe rectangle with a border one pixel wide and the current 
selected colour is drawn in the pixmap window.  

• SHIFT - constrains the object to be either a square or a vertical or horizontal 
line. 

• CONTROL - the first point becomes the centre of the rectangle. 

• SHIFT and CONTROL - combines both functions. 

5.8.6 Draw Filled Rectangle 

A rectangle filled in the current selected colour is drawn in the pixmap window.  

• SHIFT - constrains the object to be either a square or a vertical or horizontal 
line. 

• CONTROL - the first point becomes the centre of the rectangle. 

• SHIFT and CONTROL - combines both functions. 
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5.8.7 Draw Wireframe Ellipse 

An outlined wireframe rectangle with a border one pixel wide and the current 
selected colour is drawn in the pixmap window.  

• SHIFT - constrains the object to be a circle or a vertical or horizontal line. 

• CONTROL - the first point becomes the centre of the ellipse. 

• SHIFT and CONTROL - combines both functions. 

5.8.8 Draw Filled Ellipse 

An ellipse filled in the currently selected colour is drawn in the pixmap window.  

• SHIFT - constrains the object to be a circle or a vertical or horizontal line. 

• CONTROL - the first point becomes the centre of the ellipse. 

• SHIFT and CONTROL - combines both functions. 

5.8.9 Shift Up 

Moves the selected area up one pixel. When any part of the area reaches the top 
limit of the pixmap window no further movement takes place. If no selection is 
made then all coloured pixels in the pixmap window are moved. 

5.8.10 Shift Down 

Moves the selected area down one pixel. When any part of the area reaches the 
bottom limit of the pixmap window no further movement takes place. If no 
selection is made then all coloured pixels in the pixmap window are moved. 

5.8.11 Shift Left 

Moves the selected area left one pixel. When any part of the area reaches the left 
limit of the pixmap window no further movement takes place. If no selection 
ismade then all coloured pixels in the pixmap window are moved. 

5.8.12 Shift Right 

Moves the selected area right one pixel. When any part of the area reaches the right 
limit of the pixmap window no further movement takes place. If no selection is 
made then all coloured pixels in the pixmap window are moved. 

5.8.13 Flip Horizontally 

Flips the selected area horizontally. If no selection is made then all coloured pixels 
in the pixmap window are flipped. 

 

5.8.14 Flip Vertically 

Flips the selected area vertically. If no selection is made then all coloured pixels in 
the pixmap window are flipped. 
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5.8.15 Rotate Clockwise 90 degrees 

Each click of the mouse button rotates the selected area clockwise by 90 degrees. If 
no selection is made the entire pixmap is rotated. 
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6. USING MAP LAYERS 
Map Layers can be visualised as a number of transparencies overlaying one 
another, each with its own image content. This gives greater flexibility in 
constructing and editing maps and permits filtering which layers are to be 
displayed. This means that in one instance all the equipment on a map - 
intersections, pelicans, SCOOT detectors, etc. - can be displayed and on another 
occasion only the intersections are displayed. 

6.1 Layer Identification 

Up to 32 layers can be displayed and each layer can be named for easier 
identification. The same names, however, apply to all maps on the system. It is 
therefore advisable that a standard naming convention be adopted when creating 
new maps. In the examples used in this handbook, the following layer names have 
been used: 

• Layer 1 - Base Map 

• Layer 2 - Intersections 

• Layer 3 - Pelicans 

• Layer 4 - Count Detectors 

• Layer 5 - (unnamed) 

• Layer 6 - SCOOT Detectors 

• Layer 7 - SCOOT Regions 

• Layer 8 - SCOOT Nodes 

• Layers 9 to 32 - (unnamed) 
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Figure 43 - Naming layers in the Map Editor 

The Name Layer dialogue box, which is opened from the Options menu of the 
Map Editor, demonstrates the procedure for naming layers. In this case Layer 5 is 
being edited. To change its name, erase the text "Layer 5" and type in the new 
name after the layer number. 

Note that this is purely an example of how layers can be used and is not a 
recommendation of the procedure to be used. 

6.2 Defining Layers for Objects 

All objects drawn on a map are associated with one or more layers. Unless 
specifically selected, every object is associated with Layer 1, which is the default 
layer. The procedure for associating an object with a layer is the following: 

• Draw or select an object on the map in the Map Editor window. Note that an 
object already drawn can have its layers modified at any time through the Map 
Editor. 

• Open the Select Map Layers dialogue from the Layout menu (see Figure 44). 

• If this is a new object, or no layers have previously been assigned, none of the 
layers in the Select Map Layer window are highlighted. In this case the object 
is automatically associated with default layer 1. 

• Click on the layer(s) to be associated with the selected object and confirm by 
clicking on the OK or Apply buttons. An object can be associated with more 
than one layer if it is to be displayed with various combinations of Live Update 
objects, for example. In Figure 44 the object has been explicitly associated 
with layer 1, or "Base Map" as it has been named. 
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• Save the map. 

 
Figure 44 - Select Map Layer in Editor 

6.3 Displaying Map Layers 

In the Map Display window, click on the View menu and select Map Layers. The 
dialogue shown in Figure 45is displayed. To display all layers of a map click on 
the View All Map Layers button. 

 
Figure 45 - Selecting layers for viewing in the Map Display 
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Figure 46 is a sample map on which the street markings have been drawn as part 
of the map (layer 1) instead of drawing them separately and importing as the 
Background map. The live update objects have been included on their respective 
layers. The layer content is therefore the following: 

• Layer 1 - Base Map - road markings 

• Layer 2 - Intersections - a single intersection 

• Layer 3 - Pelicans - a single pelican 

• Layer 8 - SCOOT Nodes - a single node 

The subsequent figures show a selection of layers being made visible or invisible, 
as follows: 

• Figure 47shows the base map and intersection layers (1 and 2) only being 
visible. 

• Figure 48 shows the base map and pelican layers (1 and 3) visible. 

• Figure 49 shows three layers visible - base map, pelican and node (layers 1, 3 
and 8). 

• Figure 50shows all layers except the base map (layers 2, 3 and 8). 

 

 
Figure 46 - All layers visible 

 

 

 
Figure 47 - Base map and Intersection Layers 
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Figure 48 - Base map and Pelican Layers 

 

 

 
Figure 49 - Base map, Pelican and Node layers 

 

 

 
Figure 50 - All layers visible except Base map 
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7. MAP WINDOW INFORMATION BOXES 
This section describes the contents of the information box associated with each of 
the live update symbols. In addition it is possible to add a textual description to 
each information box (see section 3.8.5 for details). 

These boxes have colour coded stars contained within them. The stars are 
replaced by dots or coded letters in the same colours as the stars giving 
information about equipment states. 

7.1 INTERSECTION 

 
Format: Jnnnnn (Nnnnnn) 

**** (Gnnnnn) 

Description: 

The four stars are colour coded: 

X Cyan Equipment isolated because OTU is faulty 

O Green Equipment on operator imposed plan 

F Red Equipment faulty  

S Yellow Equipment operating on SCOOT control. S only appears if 
equipment forms all or part of a SCOOT node 

Nnnnnn Node SCN if under SCOOT control 

Gnnnnn Green Wave SCN if under Green Wave control 

7.2 PELICAN 

 
Format: Pnnnnn 

**** 

Description: 

The four stars are colour coded: 

X Cyan Equipment isolated because its OTU is faulty 

O Green Equipment on operator imposed plan 

F Red Equipment faulty  

S Yellow Equipment operating on SCOOT control. S only appears if 
equipment is on a SCOOT node. 
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7.3 COUNT DETECTOR 

 
Format: Dnnnnn 

**** 

mmmm /H 

ppp /M 

oo %O 

Description: 

The four stars are colour coded: 

F Red Detector faulty  

M Cyan No reply for 15 minutes 

V Yellow Detector in 'Volume on' state 

C Green Congestion above threshold (for occupancy detectors only) 

mmmm last hour flow (vehicles/hour) 

ppp current stored volume value (vehicles/min) 

oo last minute occupancy (percentage). This %O only appears if the 
detector measures occupancy 

7.4 QUEUE DETECTOR 

 
Format: Qnnnnn 

** 

Description: 

The two stars are coloured coded: 

F Red Detector faulty  

Q Yellow Queue formed 

7.5 CAR PARK 
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Format: Cnnnnn 

* 

Status: Sign State 

Capacity: mmmm 

Vehicles: vvvv (pp%) 

Faulty Dets: qqqq 

Description: 

The star is colour coded: 

X Cyan Equipment isolated (OTU faulty) 

Status: Shows state of car park. The possible states are: 

SPACES 

ALMOST FULL 

FULL 

CLOSED 

FAULTY 

mmmm  Capacity of car park  

vvvv    Current car park count 

pp%   Percentage of spaces available 

qqqq Shows number of car park's count detectors that have 
gone faulty. 

Capacity, Vehicles and Faulty Dets only appear if count detectors sited at the 
entrance/exit to the car park supply car park data. 

 

7.6 CAR PARK SIGN 

 
 

Format: Snnnnn 

*** 

State: <Sign State> 

Description: 

The three stars are colour coded: 

X Cyan Equipment isolated due to OTU fault 

F Red Sign faulty 

O Green Sign state set by operator/timetable command 
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<Sign State> Shows sign state as determined from the reply bits. 

Possible states for entrance signs are: 

• SPACES 

• FULL 

For named signs they are: 

• SPACES 

• ALMOST FULL 

• FULL 

• CLOSED 

For city signs they are:  

• SPACES Group 1 

• SPACES Group 2 

• SPACES Group 3 

• SPACES Group 4 

• SPACES Group 5 

• ALMOST FULL Group 1 

• ALMOST FULL Group 2 

• ALMOST FULL Group 3 

• ALMOST FULL Group 4 

• ALMOST FULL Group 5 

• FULL 

• FAULTY 

7.7 SPECIAL FACILITY 

 
Format: Fnnnnn 

**** 

State On/Off 

[mmm] 

Description: 

The four stars are colour coded: 

X Cyan Equipment isolated because OTU is faulty  

F Red Equipment faulty/isolated 
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O Green Facility under operator control 

R White Green wave active 

mmm Time left before a green wave route becomes inactive. 

7.8 DIVERSION SIGN 

 
Format: Vnnnnn 

*** 

State: On/Off 

Diversion:  mmmmm  

Description: 

The three stars are colour coded: 

X Cyan Equipment isolated because its OTU is faulty  

F Red Equipment faulty/isolated 

O Green Sign under operator control 

mmmmm legend for SIESpace signs 

7.9 POLLUTION MONITORING SENSOR 

 
Format: Wnnnnnm 

**** 

type    value    units 

Description: 

The four stars are colour coded: 

X Cyan OTU fault 

F Red No data received from the sensor for at least 5 minutes 

H Magenta High (increasing) threshold exceeded 

L Blue Low (decreasing) threshold exceeded 

type Type of sensor (for example, CO, TEMP, etc.) 

value Last one-minute calibrated sensor value 

units Measurement units used. 
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7.10 PLAN 

 
Format: abbbbb Plan No xx (yyyy) 

CY rr, s tt, s tt, s tt, s tt 

The second line does not appear for pelicans. 

Description: 

abbbbb Intersection or pelican SCN 

Plan No xx Which plan is running 

yyyy Type of plan running 

rr Cycle time 

s tt Stage letter and start time. 

7.11 STAGE 

 
Format: Current stage ss 

Time to run ttt 

Description: 

Current stage ss Stage letter 

Time to run ttt Time left to run for the stage. For SCOOT control it 
counts down from 127 seconds 

7.12 NODE 

 
Format: Node Nnnnnn 

******* 

Cycle time ccc [ppp&] 

Stage Nnnnnn/s 

TPLN xx 

Description: 

The seven stars are colour coded: 

I Red Implemented 
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O Green Offset optimiser on 

S Yellow Split optimiser on  

D Blue Double cycling 

F Magenta Forced 

E   Green Bus Priority, Extension 

R  Magenta Bus Priority, Recall 

Cycle time ccc Node cycle time  

ppp Minimum practical node cycle time 

& MPCY trend, + or - or = for up, down or stay decisions 

Stage Nnnnnn/s Current SCOOT stage being forced 

TPLN xx Current SCOOT translation plan. 

7.13 LINK CONGESTION 

This is a representation of whether SCOOT sees the link as being congested or 
not. 

It requires the operator to create a background field to represent the link. The 
available field types are the following: 

• LINE (including ARROW) 

• POLYLINE 

• BEZIER CURVE 

To create a link congestion symbol, click on the Create Live Update Object icon 
or select this from the menu. Select the link congestion symbol and enter the SCN 
of the link required. Click on one of the above three drawing objects and draw this 
object in the map. 

The background symbol has one of the following colours: 

• green if there is no congestion 

• yellow if there is light congestion 

• white if there is medium congestion 

• magenta if there is heavy congestion 

In addition, the symbol is red if the link detector is suspect or faulty and the area 
around the symbol is cyan (light blue) if there is exit blocking. 

7.14 LINK GREEN 

This field is a representation of whether SCOOT sees the traffic on the link 
having an effective green taking into account start and end delays. 

It requires the operator to create a background field to represent the link. The 
available field types are the following: 

• LINE (including ARROW) 
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• POLYLINE 

• BEZIER CURVE 

To create a link green symbol, click on the Create Live Update Object icon or 
select this from the menu. Select the link green symbol and enter the SCN of the 
link required. Click on one of the above three drawing objects and draw this 
object in the map. 

The background symbol is coloured green when the link has an effective green 
and red at all other times. 

7.15 LINK QUEUE 

 
This field is a representation of what SCOOT sees as the queue length on the link. 
The length of the queue is proportional to the maximum queue for the link and the 
field length. The red section of the fields represents the queue and green as no 
queue. 

To create a link queue symbol, click on the Create Live Update Object icon or 
select this from the menu. Select the link queue symbol and enter the SCN of the 
link required. The drawing object SCALE can then be drawn. This is represented 
in the Editor as a half red and half green rectangle to assist in the orientation. 
Click and hold MB1 at the first point of the rectangle to be drawn and drag to the 
position of the opposite corner. After the rectangle has been placed on the map, its 
orientation can be altered, i.e. red to the top, bottom, left or right, by clicking on 
one of the handles and dragging past one of the other corners. 

7.16 LINK STATUS 

 
Format: Link Nnnnnnm 

**** 

% Sat XXX 

Description: 

The four stars are colour coded: 

F Red Link detector suspect or faulty  

E Magenta Exit blocked 

B  Cyan Bus detected 

I Blue Incident detected 

XXX The percentage saturation on the link, between 0 and 999. 
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7.17 REGION 

 
Format: Region Rnn aa/bb on SCOOT 

** 

Cycle time ccc [ttt] 

Description: 

The two stars are colour coded: 

C Yellow Cycle time optimiser on  

T Green Trend flag set 

aa Nodes on SCOOT 

bb Node count for region 

ccc Region cycle time 

ttt Preferred cycle time 

7.18 SCOOT DETECTOR 

 

Format: Detector Nnnnnnmd 

*** 

Description: 

The three stars are colour coded: 

F Red Faulty 

S Yellow Suspect 

I Blue Incident detected 
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