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PROPRIETARY INFORMATION 
Siemens Industry, Inc., Rail Automation (Siemens) has a proprietary interest in the information 
contained herein and, in some instances, has patent rights in the systems and components 
described.  It is requested that you distribute this information only to those responsible people 
within your organization who have an official interest. 
 
This document, or the information disclosed herein, shall not be reproduced or transferred to 
other documents or used or disclosed for manufacturing or for any other purpose except as 
specifically authorized in writing by Siemens. 

 
TRANSLATIONS 

The manuals and product information of Siemens are intended to be produced and read in 
English. Any translation of the manuals and product information are unofficial and can be 
imprecise and inaccurate in whole or in part. Siemens does not warrant the accuracy, reliability, 
or timeliness of any information contained in any translation of manual or product information 
from its original official released version in English and shall not be liable for any losses caused 
by such reliance on the accuracy, reliability, or timeliness of such information.  Any person or 
entity who relies on translated information does so at his or her own risk. 

 
WARRANTY INFORMATION 

Siemens Industry, Inc., Rail Automation warranty policy is as stated in the current Terms and 
Conditions of Sale document.  Warranty adjustments will not be allowed for products or 
components which have been subjected to abuse, alteration, improper handling or installation, or 
which have not been operated in accordance with Seller's instructions.  Alteration or removal of 
any serial number or identification mark voids the warranty. 

 
SALES AND SERVICE LOCATIONS 

Technical assistance and sales information on Siemens Industry, Inc., Rail Automation 
products may be obtained at the following locations: 

 
Siemens Industry, Inc., Rail Automation  Siemens Industry, Inc., Rail Automation 
2400 NELSON MILLER PARKWAY  939 S. MAIN STREET 
LOUISVILLE, KENTUCKY  40223  MARION, KENTUCKY  42064 
TELEPHONE: (502) 618-8800  TELEPHONE: (270) 918-7800 
FAX:  (502) 618-8810  CUSTOMER SERVICE: (800) 626-2710 
SALES & SERVICE:  (800) 626-2710  TECHNICAL SUPPORT: (800) 793-7233 
WEB SITE: http://www.rail-automation.com/  FAX: (270) 918-7830 
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NOTES, CAUTIONS, AND WARNINGS 
Throughout this manual, notes, cautions, and warnings are frequently used to direct the reader’s 
attention to specific information. Use of the three terms is defined as follows: 
 

 
 WARNING

 
INDICATES A POTENTIALLY HAZARDOUS SITUATION WHICH, IF NOT 
AVOIDED, COULD RESULT IN DEATH OR SERIOUS INJURY. WARNINGS 
ALWAYS TAKE PRECEDENCE OVER NOTES, CAUTIONS, AND ALL 
OTHER INFORMATION.  

 
 

 CAUTION
 

REFERS TO PROPER PROCEDURES OR PRACTICES WHICH IF NOT 
STRICTLY OBSERVED, COULD RESULT IN A POTENTIALLY HAZARDOUS 
SITUATION AND/OR POSSIBLE DAMAGE TO EQUIPMENT. CAUTIONS TAKE 
PRECEDENCE OVER NOTES AND ALL OTHER INFORMATION, EXCEPT 
WARNINGS. 

 
 

 NOTE
 

Generally used to highlight certain information relating to the topic under 
discussion. 

 
 

If there are any questions, contact Siemens Industry Inc., Rail Automation Application 
Engineering. 
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ELECTROSTATIC DISCHARGE (ESD) PRECAUTIONS  
 

Static electricity can damage electronic circuitry, particularly low voltage components such as the 
integrated circuits commonly used throughout the electronics industry. Therefore, procedures 
have been adopted industry-wide which make it possible to avoid the sometimes invisible 
damage caused by electrostatic discharge (ESD) during the handling, shipping, and storage of 
electronic modules and components. Siemens Industry, Inc., Rail Automation has instituted these 
practices at its manufacturing facility and encourages its customers to adopt them as well to 
lessen the likelihood of equipment damage in the field due to ESD. Some of the basic protective 
practices include the following:  

 
• Ground yourself before touching card cages, assemblies, modules, or components.  

• Remove power from card cages and assemblies before removing or installing modules.  

• Remove circuit boards (modules) from card cages by the ejector lever only. If an ejector lever is 
not provided, grasp the edge of the circuit board but avoid touching circuit traces or components.  

• Handle circuit boards by the edges only.  

• Never physically touch circuit board or connector contact fingers or allow these fingers to come in 
contact with an insulator (e.g., plastic, rubber, etc.).  

• When not in use, place circuit boards in approved static-shielding bags, contact fingers first. 
Remove circuit boards from static-shielding bags by grasping the ejector lever or the edge of the 
board only. Each bag should include a caution label on the outside indicating static-sensitive 
contents.  

• Cover workbench surfaces used for repair of electronic equipment with static dissipative 
workbench matting.  

• Use integrated circuit extractor/inserter tools designed to remove and install electrostatic-
sensitive integrated circuit devices such as PROM’s (OK Industries, Inc., Model EX-2 Extractor 
and Model MOS-40 Inserter (or equivalent) are highly recommended).  

• Utilize only anti-static cushioning material in equipment shipping and storage containers.  

 
For information concerning ESD material applications, please contact the Technical Support Staff 
at 1-800-793-7233. ESD Awareness Classes and additional ESD product information are also 
available through the Technical Support Staff.  
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SECTION I 
INTRODUCTION AND INSTALLATION 

 
 

1.0 INTRODUCTION AND INSTALLATION 

 
The GEOMCF Manager application is an extension to the GEO Configuration Suite (GCS) to 
manage Module Configuration File (MCF) installations, select field-configurable parameters, assign 
Advanced Train Control System (ATCS) addresses, generate Unique Check Numbers (UCNs), 
generate GEO Installation Listings, and record In-Service / Out-of-Service check numbers. 
 
The relationships between GEOMCF Manager, the GEOMCF Manager database, printer, and the 
GWE are shown in the Flow Diagram of figure 1-1. 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-1.  GEOMCF Manager Flow Diagram  
  
Typically, this utility is used at the office to generate the GEO Installation Listing for use by the 
Maintainer at the field site (refer to Appendix A for a sample GEO Installation Listing). The 
Maintainer uses the listing to set GWE parameters, SIN (Site Identification Number), and enter the 
UCN to put the GWE In-Service. 
 
All of the configurable installation settings are saved to a database. The GEO Installation Listing is 
used to configure GWE units in the field. 
 
GEOMCF Manager provides tools for selecting configuration data for a specific site. Each site has 
one or more pieces of GWE, each requiring installation of an MCF for operation. The utility allows 
selection of the MCF(s), setting specific vital or non-vital parameters, assigning the ATCS address 
(SIN), and generating a Unique Check Number (UCN), calculated over the MCF, vital parameters, 
and the SIN. The end result of using the utility is a hard-copy of the GEO Installation Listing, which 
is a set of instructions for use by the Maintainer at the site. 
 

 

GEOMCF Manager 

Office-based PC 

Import MCF 

GEOMCF 
Manager 
Database GEO 

Installation 
Listing 

Printer 

Place GWE In / 
Out of Service 

Record GWE 
In / Out of 
Service # 

COMM Port, 
Network port, 
etc. 

MCFs 
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The GEO Installation Listing enables a Maintainer to perform installation of MCF(s) and/or set 
parameters into non-volatile memory of GWE. It also provides the unique check number (UCN) 
and the SIN that must be entered and transferred to non-volatile memory of the GWE. Without 
the proper UCN, the Maintainer cannot make any changes to the configuration or change In-
Service/Out-Of-Service status of the GWE. The UCN guarantees that only the configuration data 
listed can be set into the GWE, thus preventing improper configuration. 

1.1 INSTALLATION 

The installation refers to the site where the MCFs are installed in GWE. Each installation is given a 
name, which appears on the GEO Installation Listing under “Safetran Systems Corporation GEO 
Installation Listing”. The MCF name, creation date, and MCF CRC appear under the installation 
name on the GEO Installation Listing. Refer to Appendix A for a sample GEO Installation Listing. 

1.2 MODULE CONFIGURATION FILE (MCF) 

A Module Configuration File (MCF) for each GWE at a site must be installed in non-volatile 
memory. The MCF was created using GCS. The MCFs must be available on the PC in order to be 
used by GEOMCF Manager. 
 
GEOMCF Manager keeps track of the installations on one tab and the imported MCFs on a 
separate tab, viewable on the left side of the main screen (see detail below). 
 
 
 
 
 
Clicking on the Installations tab displays the installation trees. Right-clicking on the icons in a tree 
displays pop-up menus of options that can be performed (figure 1-2). 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-2.  Installations Tab Pop-up Menus 
 
 

Tabs 

Right-clicking on an installation icon:  Right-clicking on an MCF icon:  
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For example, from the Installations tab, a selected installation may be deleted or renamed, an 
MCF installed, the ATCS parameters viewed, or a new installation may be added. Also from the 
Installations tab, a selected MCF may be uninstalled, the UCN may be calculated or viewed, the 
In-Service number may be entered to indicate In-Service, or the GEO Installation Listing may be 
viewed. 
 
Clicking on the MCFs tab displays a list of imported MCFs. Right-clicking on an MCF icon in the list 
displays a pop-up menu of options that can be performed (figure 1-3). 
 
 
 
 
 
 
 
 

 
Figure 1-3.  MCFs Tab Pop-up Menu 

 
From the MCFs tab, a selected MCF may be deleted, or another MCF may be imported. 

1.3 ATCS ADDRESS 

Each GWE at a site can be given a 12-digit identification number (SIN) which is stored in non-
volatile memory in the GWE, in the format: 7.RRR.LLL.GGG.SS, where 7 is the designation for 
ATCS wayside type addressing, RRR is the Railroad number, LLL is the Line number, GGG is the 
Group number, and SS is the subnode number. All GWE at a site must have the same Railroad, 
Line, and Group number, only the subnode number is different. This SIN is used as the ATCS 
Address for communications with a device, if communication is required. 

 
 

NOTE
 

Office equipment type addressing differs from wayside type addressing in that 
the format is 10-digits as follows: 2.RRR.NN.DDDD, where 2 is the designation 
for office equipment address type, RRR is the Railroad number, NN is the 
specific unit in the office (e.g., CTC computer), and DDDD is the application in 
the office (e.g., dispatching). 

 
 
Depending on the application, an MCF may assign a SIN, or a default SIN of 700000000000 may be 
imposed (where Railroad, Line, Group, and Subnode are not assigned). If ATCS communications is 
not required for the GWE, the default SIN may be acceptable, however it is preferable to assign 
the SIN that represents the ATCS address, since the SIN is included in the calculation of the UCN. 
If the MCF that was created by GCS imposes the default MCF, and a SIN must be assigned to the 
GWE, GEOMCF Manager assigns the SIN which can then be entered into the GWE by the 

Right-clicking on an MCF icon  
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Maintainer at the site using the GEO Installation Listing. There are specific rules concerning 
assigning ATCS addresses, and GEOMCF Manager will detect an invalid SIN. 
 
Devices at a site communicate using the ATCS addresses. The ATCS communication parameters 
for installed MCFs may be viewed from the Installations tab. Right-click on the Installation icon 
to display the pop-up menu (refer back to figure 1-2), then click on ATCS View (see figure 1-4). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-4.  Example ATCS Tab Views 
 

In the example above, two MCFs (MCF TP15A and MCF TP15B) allow 2 devices at each end to 
communicate. MCF TP15A has a SIN of 710010010003 and MCF TP15B has a SIN of 710010010004. 
At this location, the Railroad is assigned 100, the Line is assigned 100, and the Group is assigned 
100. The subnodes are 03 and 04. 
 
MCF TP15A has devices 05 and 06) and MCF TP15B has devices 04 and 03. The remote 
connections and devices are shown for each device. TP15A device 05 communicates with TP15B 
device 04 and TP15A device 06 communicates with TP15B device 03, as determined by the MCF. 
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1.4 USER CONFIGURABLE PARAMETERS 

The MCF sets the default parameters for a GWE. However, vital or non-vital parameters such as 
Configuration Parameters, Operating Parameters, User Options, User I/O, and User Timers may be 
field-configurable. This feature allows a common MCF to be used at multiple locations, with 
certain site-specific parameters set for each device in the field. GEOMCF Manager can be used to 
indicate the parameter value to be set for the GWE. The Maintainer uses the GEO Installation 
Listing to set these parameters and values (refer to Appendix A for a sample GEO Installation 
Listing). 
 
For example, a GEO unit at a specific site may require setting parameters for one or more of its 
modules. Below is an example for setting Operating Parameters. 
 
1. From the Installations tab, expand the desired Installation icon to display the installed MCFs, 

then right-click on the desired MCF to display the MCF pop-up menu (see detail below). 
 
 
 
 
 
 
 
 
2. From the pop-up menu, select UCN Calculator. The GEO UCN Calculator window is displayed 

(figure 1-5). 

 
Figure 1-5.  GEO UCN Calculator Window 

 
 
3. For the desired module parameters, right-click on the module header (e.g., VPI) to display the 

options (see detail below). 

 
 

Select UCN Calculator to 
display the GEO UCN 
Calculator window 
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4. Click on “Operating Parameters”. The Operating Parameters window is displayed (see 
example for VPI Slot 3 in figure 1-6). 

 
Figure 1-6.  Typical Operating Parameters Window 

 
By bringing up the Operating Parameters window (see the details below for the input debounce 
adjustment), GEOMCF Manager can set the proper value to be entered at the site (e.g., 26 ms). 
 
 
 
 
 
 
 
 
 
 
 
 
 
This is the value (e.g., 26 ms) the Maintainer will set into the GWE at the site. 

1.5 UCN 

GEOMCF Manager calculates the UCN on Installed MCFs. This check number is calculated over the 
MCF, SIN, vital parameters, and in some cases over the MEF. After being calculated, the UCN is 
added to the GEO Installation Listing for the Maintainer to enter into the GWE. The UCN is like a 
key to unlock the GWE and place it in service. 

MCF Default 
value 

Spin Buttons 
displayed 

New 
value 
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1.6 IN-SERVICE / OUT-OF-SERVICE 

When GWE is rebooted, an entry is made in the event log that the module has rebooted. The 
reboot entry is generally followed by a 4-digit hexadecimal In-Service Check Number (if in service) 
or an Out-Of-Service Check Number (if out of service). See example In-Service log entry for GEO 
below. 
 

GEO In Service Check Number Log Entry 

 
The Maintainer at the site must review the event log after the GWE has rebooted so that the In / 
Out of Service check number can be recorded on the GEO Installation Listing and given back to 
the office to be entered into GEOMCF Manager (see figure 1-7). 
 

 
Figure 1-7.  GEOMCF Manager In-Service Dialog Box 

 
When GEOMCF Manager has the correct In-Service check number entered, the utility considers 
the GWE as being properly in service. On the Installations tab, installed MCFs display red, in-
service MCFs display green, and out-in-service MCFs display gray. 
 

 

NOTE
 

When the GWE is taken out of service after having been in service, the Out-of-
Service check number is recorded in the GEO Installation Listing, but not 
required for GEOMCF Manager to indicate Out-of-Service. 
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1.7 SYSTEM REQUIREMENTS   

 
The GEOMCF Manager software requires the following minimum computer configuration: 
 
 VGA monitor 
 Pentium II or equivalent processor, 266 MHz or higher 
 128 MB of RAM 
 Hard disk with sufficient space to install the required options and maintain database files 
 CD-ROM drive 
 3 ¼” floppy diskette drive (for loading MCFs) 
 Printer 
 Microsoft Windows 98, NT 4.0 with Service pack 3 or later, 2000  or XP Operating System 
 Microsoft Internet Explorer Version 5.5 or later installed 
 Microsoft Word 97 or later installed 

 
 

NOTE
 

GEOMCF Manager must not be installed on the same PC where GDT version 
1.1.19 or earlier resides, as there might be a conflict between shared files. 

 
 

NOTE
 

GEOMCF Manager must not be installed on the same PC where GCS version 
1.3.3 or earlier is installed, as there might be a conflict between shared files. 

 

1.8 ORDERING INFORMATION 

 
To order GEOMCF Manager, specify the following number: 
 

Application • Part Number 
GEOMCF Manager (on CD-ROM) Z224-9V603-A010 

  

1.9 PROGRAM INSTALLATION 

GEOMCF Manager software is distributed on Compact Disc (CD). To install, use the following 
procedure: 
 
1. Insert the Installation CD into the CD-ROM drive of the host computer. 

 
The installation program should start automatically. 
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If the installation program does not start automatically, locate the CD-ROM using 
Start>Run>Browse, Windows Explorer, or My Computer, and run the installation file Setup.exe 
located on the disc. 

 
2. The “GEOMCF Manager Setup Wizard” window is displayed on the screen (figure 1-8). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-8.  GEOMCF Manager Main Screen 
 

 

NOTE
 

The current version of the GEOMCF Manager being installed is displayed in the 
upper left corner of the screen (refer back to figure 1-8). 

 
 

3. Click on the Next > button to continue with setup. 
 

 

NOTE
 

At any time during the installation, the user can click on the < Back button (when 
active) of a displayed window to return to the previously displayed window for the 
purpose of making changes or repeating a step. 
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1.9.1 First Time Installation 

1. If this is a first time installation of the GDT utility on this computer, the “License Agreement” 
window is displayed (figure 1-9). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figure 1-9.  License Agreement Window 
 

 

NOTE
 

If a version of this software has been previously installed, the Installation Wizard 
detects it and displays the “Modify, Repair, or Remove the Program” window 
(figure 1-18) instead of the “License Agreement” window. Proceed to paragraph 
1.8.2 for modifying, repairing, or removing a previously installed version of this 
software. 

 
 
2. Click on Yes in the “License Agreement” window to continue with the installation. 
 
3. The GEOMCF Manager Setup Wizard displays the “Destination Folder” window (figure 1-10). 
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Figure 1-10.  Destination Folder Window 
 
4. The destination for installation of the software is displayed in the Destination Folder box of 

the GEOMCF Manager Setup Wizard window. If a different destination is desired, click on 
the Browse… button, then select a different destination. When the correct destination for 
installation is displayed, click on the Next > button. 

 
5. The GEOMCF Manager Setup Wizard window allows the user to select the path to the GEO 

database (figure 1-11). 

 
Figure 1-11.  Selecting the Path to the GEO® Database 
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6. After the proper path to the GEO Database is displayed in the Path box, click on OK. The 
Program Folder Selection window is displayed (figure 1-12).  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-12.  Program Folder Selection Window 
 
7. The folder where the program icons will be added is displayed in the Program Folders: box 

(the default is the Safetran folder). If a different folder is desired, scroll through the Existing 
Folders: box and select the desired folder, then click on the Next > button. 

 
8. The “Installation Summary” window appears (figure 1-13). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 1-13.  Installation Summary Window 
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9. Inspect the Current Settings: box of the “Installation Summary” window to verify that the 
software is about to be added to the correct installation folder and program group. If the 
settings are correct, click on the Next > button. 

 
 

NOTE
 

If the settings in the “Installation Summary” window are not the desired ones, 
click on the < Back button to change the settings. 

 
 

10. The Installation Wizard begins loading some of the applications needed to run with the 
GEOMCF Manager utility (a number of splash screens appear as files are installed). 

 
11. When the Installation Wizard has finished loading a portion of these files, the “Microsoft XML 

Parser Setup” window is displayed (figure 1-14). Click on Next > to continue. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 1-14.  Microsoft® XML Parser Setup Window 

 
12. Follow the instructions for the Microsoft installation windows as they are displayed to install 

Microsoft XML Parser. 
 
13. After Microsoft XML Parser is installed, the GEOMCF Manager Setup Wizard displays the 

“Setup Status” window as the files are loaded (figure 1-15). 
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Figure 1-15.  GEOMCF Manager Setup Wizard Installation Window 

 
14. The GEOMCF Manager Setup Wizard “Release Notes” window (figure 1-16) is displayed after 

the files are loaded. To review the release notes, verify the box is checked (or uncheck box to 
not review release notes), and click on Finish. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 1-16.  Release Notes Window 

 
15. The GEOMCF Manager Setup Wizard “Restart” window (figure 1-17) is displayed. Select the 

radio button desired for rebooting and click on Finish (normally, the computer should be 
restarted now, if installation is finished). 
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Figure 1-17.  GEOMCF Manager Setup Wizard Restart Window 
 

16. When the GEOMCF Manager Installation Wizard has finished installing files, the installation 
utility is closed and the computer is rebooted (if the radio button was selected for restarting 
now). 

1.9.2 GEOMCF Manager Previously Installed 

If a version of GEOMCF Manager has been previously installed on the computer, the InstallShield 
Wizard displays the “Modify, Repair, or Remove the Program” window (figure 1-18). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-18.  “Modify, Repair, or Remove the Program” Window 
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The user has two options when a version of GEOMCF Manager has been previously installed: 
repair the previously installed version of GEOMCF Manager, or remove the previously installed 
version of GEOMCF Manager. Generally, the previously installed version is first “removed”, then 
the utility is “installed” as a first time installation. 
 

 

NOTE
 

The default option for repairing or removing the previously version of GEOMCF 
Manager is “Remove”. 

 

1.9.2.1 Remove the Previously Installed GEOMCF Manager 

 
 

NOTE
 

Before installing GEOMCF Manager, it is preferable to completely remove an old 
version. 

 
1. To remove all installed components of a currently installed version of GEOMCF Manager, 

select the Remove radio button and click on the Next > button. The “Confirm Uninstall” 
window is displayed (figure 1-19). 

2.  
 
 
 
 
 
 

Figure 1-19.  Confirm Uninstall Window 
 

 

NOTE
 

If files used by GEOMCF Manager are shared by other Safetran programs, a 
“Shared File Detected” notice is displayed (see below). Delete all shared files 
because they are going to be reinstalled when GEOMCF Manager is reinstalled. 
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NOTE
 

GEOMCF Manager must not be installed on the same PC where GDT version 
1.1.19 or earlier resides, as there might be a conflict between shared files. 

 
 

 

NOTE
 

GEOMCF Manager must not be installed on the same PC where GCS version 
1.3.3 or earlier is installed, as there might be a conflict between shared files. 

 
 

3. Click on OK on the Confirm Uninstall window to delete GEOMCF Manager software including 
all of its components. The InstallShield Wizard performs the required operations as it displays 
the “Setup Status” window (figure 1-20), then the Maintenance Complete window is 
displayed (figure 1-21). Click on Finish in the “Maintenance Complete” window to close the 
Installation Wizard. 

 

 
Figure 1-20.  Setup Status Window 
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Figure 1-21.  Maintenance Complete Window 
 
 

1.9.2.2 Repair the Previously Installed GEOMCF Manager 

 
To reinstall all components of a currently installed version of GEOMCF Manager, select the Repair 
radio button and click on the Next > button. The Installation Wizard performs the required 
operations, then displays the “Maintenance Complete” window (refer back to figure 1-21). Click 
on Finish in the “Maintenance Complete” window to close the Installation Wizard. 
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 SECTION II 
LAUNCHING AND USING GEOMCF MANAGER 

 

2.0 STARTING THE GEOMCF MANAGER PROGRAM 

 
1. Click the Windows Start button. 
 
2. Select Programs. 
 
3. Select Safetran. 
 
4. Click on the GEOMCF Manager icon. 
 

 

NOTE
 

Steps 1 through 3 can be eliminated if a shortcut icon is placed on the PC 
desktop for GEOMCF Manager. 

 
5. The GEOMCF Manager main screen is displayed (figure 2-1) with any currently installed 

configurations displayed in the Tabs viewing area on the left side of the screen. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 2-1.  GEOMCF Manager Main Screen 
 
 
 

Title Bar 
Menu Bar 

Toolbar 

Tabs viewing 
area 

Text viewing 
area 

Status Bar 

Installations 
tab  

MCFs 
tab  
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2.1.1 GEOMCF Manager Main Screen Components 

The top 3 bars of the GEOMCF Manager main screen (refer back to figure 2-1) are: Title Bar,  
Menu Bar, and Toolbar (which can be enabled/disabled from the View menu). The main area of 
the screen is divided into the Tabs area and the Text area. At the bottom of the screen is the 
Status Bar, which can be enabled/disabled from the View menu. The main screen components 
are discussed in the paragraphs that follow. 
 

2.1.1.1 Title Bar 

 
The Title Bar identifies the GEOMCF Manager application. 
 

2.1.1.2 Menu Bar 

 
 When the Text Area is empty (no text documents displayed), the Menu Bar contains 3 menu 

items: File menu, View menu, and Help menu (see below). 
 
 

 When the Text Area is displaying a text document (e.g., GEO Installation Listing), the Menu Bar 
contains 3 additional items: DOC button, Edit menu, and Window menu (see below).  

 
 
DOC Button 

 
When the Text Area is displaying a text document (e.g., GEO Installation 
Listing), the DOC button is displayed. Clicking on the DOC button displays a 
standard menu of options for working with documents, such restoring or 
minimizing/maximizing a document. Options not applicable for the 
currently displayed document are disabled (grayed out). Click on Close to 
close the text document. 
 

 
File Menu 

When the Text Area is not displaying a text document, the File menu displays 
options to display the standard Windows Print Setup box (select printing 
options and click on OK to accept setup and close the box), or to exit the 
GEOMCF Manager utility. 

 
When the Text Area is displaying a text document (e.g., GEO Installation Listing), 
the File menu displays options to close the document, print the document (using 
the print setup established before displaying a document), or to Exit the GEOMCF 
Manager utility. 
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Edit Menu 
When the Text Area is displaying a text document (e.g., GEO Installation 
Listing), the Edit menu displays options for editing the document. Currently, 
this function is not implemented (options are disabled). 
 
 
 

View Menu 
The View menu is displayed whether a document is displayed or not. It allows 
the user to enable or disable the Toolbar and the Status Bar. When a checkmark 
is placed next to the option, the option is enabled. 
 

Window Menu  
When the Text Area is displaying one or more text documents (e.g., GEO 
Installation Listing), the Window menu displays the standard options for 
cascading or tiling different documents on the screen, or arranging icons. It 
also displays a list of open documents (the currently selected document 
displays a checkmark). 
 

 
Help Menu 

The About… option from the Help menu brings up the About GEOMCF 
Manager window (figure 2-2), which provides application software version and 
the software part number. Click on OK to close the window. 

 
Figure 2-2.  About GEOMCF Manager Window 

 

2.1.1.3 Toolbar 

 
The Toolbar contains 2 items: New Installation button and About GEOMCG Manager button. 
The New Installation button displays the GEO MCF Installation window (figure 2-3). The GEO 
MCF Installation window allows the user to name and introduce a new Installation. A “Comment” 
box is included to add any specific information about the installation. 
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Figure 2-3.  GEO MCF Installation Window 

 
The About GEOMCF Manager button provides the same information provided in the Help menu 
(refer back to figure 2-2). 

2.1.1.4 Tabs Area 

There are two tabs: Installations and MCFs (see detail below). 

 
Installations Tab- The Installations tab provides an area for expanding the installation trees (see 
below), where options are provided by pop-up menus for the installations and installed MCFs. 
 
 
 
 
 
 
 
 
 
MCFs Tab- The MCFs tab lists the MCFs that have been imported. From this view, an MCF icon 
may be right-clicked on to display a pop-up menu to delete or import an MCF (see example 
below). 
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2.1.1.5 Text Area 

The text area is used to display text files such as the GEO Installation Listing or the ATCS view (see 
example below, and in Appendix A). 

 
These files may be cascaded or tiled for viewing from the Window menu, and may be closed from 
the File menu. The GEO Installation Listing may be printed from the File menu. 

2.1.1.6 Status Bar 

The Status Bar provides boxes for status messages (e.g., Ready), describes menu options, etc. It 
also provides boxes to indicate Lock status (Caps Lock, Numbers Lock, and Scroll Lock). 
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2.2 USING GEOMCF MANAGER 

2.2.1 Setting Up Installations 

To set up an installation, the user can use current installations and MCFs, deleting unneeded 
installations, renaming and reusing installations, or installing new installations, as follows: 
 

a. To reuse an existing installation, right-click on 
the Installation icon to display the pop-up menu 
(see detail at right), then click on Rename. A 
window (see detail below) is displayed to allow 
the user to rename the installation. Type in the 
name and click on OK. 

 
b. To begin a new installation, right-click on the Installation icon to display the pop-up menu 

(see detail at right), then click on New 
Installation. The GEO MCF Installation window 
(see detail below) is displayed to allow the user 
to name the new installation and enter any 
desired information about the installation in the 
Comment box. Click on OK. 

 

Select Rename 
to reuse an 
existing 
installation 

Select New 
Installation to 
begin a new 
installation 
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c. To delete an installation, right-click on the 

Installation icon to display the pop-up menu (see 
detail at right), then click on Delete Installation. 
A confirmation prompt is displayed (see detail 
below). Click on Yes. 

 
 

NOTE
 

Before any installations can be deleted, any MCFs installed in them must first be 
uninstalled, or an error message is displayed (see below). 
 
 
 
 
 
 
 
 
 
Click on the expand box (+) for the installation to display the MCFs installed, 
then select the MCFs one at a time and right-click to display the pop-up menu 
(see first detail below), then click on Uninstall MCF. A confirmation prompt is 
displayed (see second detail below). Click on Yes to uninstall the MCF. 
 

 
 
 
 
 
 
 
 

Select Delete 
Installation to 
delete a selected 
installation 

Select Uninstall 
MCF to uninstall 
an MCF from a 
selected 
installation 
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2.2.2 Installing MCFs 

1. From the main screen, click on the MCFs tab to display the imported MCFs viewing area. 
 
2. Right-click in the MCFs viewing area of the screen to display the MCFs pop-up menu (see 

below). 
 
 
 
 
3. One at a time, highlight any MCFs to be deleted, and from the pop-up menu, click on Delete 

MCF to delete them. 
 
4. One at a time to import new MCFs, click on Import MCF. The Select MCF window is 

displayed (figure 2-4). 

 
Figure 2-4.  Select MCF Window 

 
5. Navigate to the directory where the desired MCF resides, highlight the MCF, and click on 

Open. 
 
6. From the main screen, click on the Installations tab to display the Installations viewing area. 
 
7. From the Installations viewing area, right-click on the installation icon that requires MCFs to 

be installed, to display the pop-up menu (see detail below), then click on Install MCF. 
 
 
 
 
 
 
 

Select Install MCF to 
display the Install MCF 
window 

Select Import MCF to import an MCF to 
the MCFs Tab from the GEOMCF Database 

Select Delete MCF to delete the currently 
selected MCF from the MCFs Tab 
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8. The Install MCF window is displayed to allow the user to select from a list of MCFs (figure 2-

5). Also if required, additional MCFs may be imported from this window. 

 
Figure 2-5.  Install MCF Window 

 
 

NOTE
 

The MCF CRC is displayed in parentheses following the MCF name. Use the 
CRC to verify the correct MCF. 

 
9. To install MCFs, perform one of the following steps: 
 
 Select the desired MCF from the list and click on OK. 

 
 Click on the Import MCF button on the Install MCF window to display the Select MCF 

window (refer back to figure 2-4), navigate to the directory where the MCF resides 
(figure 2-6), highlight the correct MCF, then click on Open. 

 
 

NOTE
 

MCFs in the Imported MCF directory reside in folders identified by their CRCs. 
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Figure 2-6.  Selecting an MCF 

 
 

NOTE
 

If the desired MCF is not in the directory, place it there from floppy diskette or 
other source. 

  

2.2.3 Viewing ATCS Parameters 

 
1. After the proper MCFs are displayed in the tree for the installation, the user can right-click on 

the installation icon to display the pop-up menu, and select ATCS View (see detail below).  
 
 
 
 
 
 
 
 
 
2. The right-hand side of the screen displays a tab (display formatted as a text document) for 

each MCF installed (see examples in figures 2-6 and 2-7). Also, the current SIN (default of 
700000000000 or assigned SIN) is displayed below the screen. 

 

Select ATCS View to 
display communication 
device and connection 
information 
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Figure 2-7.  Example ATCS View – TP15A Tab 

 
 

Figure 2-8.  Example ATCS View – TP15B Tab 
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3. Verify the MCFs are set up to communicate as desired. Close the window by clicking on the 

close button (see detail below), or use the File menu, Close option. 
 
 
 
 
 

2.2.4 Assigning ATCS Addresses 

1. The user must assign ATCS addresses to all MCFs that require communications. From the 
Installations tab, right-click on the first MCF to assign an ATCS address, and click on UCN 
Calculator. 

 
 

WARNING
 

TO ENSURE THAT NO POTENTIAL SAFETY CONFLICTS CAN OCCUR 
WITH OTHER EQUIPMENT, VERIFY THAT EACH NEW SIN ASSIGNED IS 
UNIQUE TO THE FIELD UNIT BEING CONFIGURED. 

 
 
2. When the GEO UCN Calculator window appears, select Set Sin from the Configure menu. 

The SIN window appears (figure 2-9). 

 
Figure 2-9.  SIN Window 

 

Close Button 
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NOTE
 

If the SIN does not appear in the “Current SIN” text box on the SIN screen, click 
on Cancel, then on Curr. (SIN) to display the current SIN. 

 
 

 

NOTE
 

The Pend. (SIN) button, the Verify: text box, and the CRC: text box are not used 
even though active. 

 
 
3. In the Current SIN text box, enter the correct SIN, then click on the Apply button. 
 

 

NOTE
 

A SIN of all zeros is invalid (a number must be assigned). GEOMCF Manager 
detects an invalid SIN and will not allow it to be applied. 

 
4. Click on the Curr. button and verify the SIN was properly applied. 
 
5. Click on the Exit button to close the SIN window. 
 
6. Repeat steps 1 through 5 for all other MCFs. 
 

 

WARNING
 

WHEN CHANGING ATCS ADDRESS (SIN) FOR A GWE IN THE FIELD, THE 
INSTALLATION NEEDS TO BE REVALIDATED IN ACCORDANCE WITH 
RAILROAD PROCEDURES FOR QUALIFYING IN-SERVICE 
INSTALLATIONS. 

2.2.5 Using UCN Calculator 

The UCN Calculator window provides a simulated view of the GWE, with slots for modules, if the 
GWE supports individual modules. The headers for populated module slots provide pop-up menus 
when right-clicked on. This function is described in paragraphs 2.2.5.2 and 2.2.5.3. 
 
The UCN Calculator window also provides a menu bar for selecting options. These functions are 
described in paragraph 2.2.5.1. 
 
The UCN Calculator window also provides a View Next Slot Up button to shift the view to the 
right in order to view slots of larger racks that are out of view on the screen. To shift the view 
back to the left, the View Next Slot Down button is enabled when the view is shifted to the 
right.  
 
 
 
 



LAUNCHING AND USING GEOMCF MANAGER 

2-14 
Document No.: SIG-00-03-03                                                                                                           March 2003, Revised July 2014 
Version: A.1 

2.2.5.1 UCN Calculator Menu Bar 

 
File Menu- Currently, the File menu contains only one option: Exit (see detail below). Clicking 
on this option closes the GEO UCN Calculator window. 

 
View  Menu- Currently, the View menu contains only one option: Refresh (see detail below). 
Clicking on this option refreshes the display with any new changes. 

 
Configure Menu-  The Configure menu allows user-configurable parameters to be set (see detail 
below), provided the parameter is programmed in the MCF. The options in the Configure menu 
are: Vital User Options, Nonvital user Options, Vital User I/O, Nonvital User I/O, Vital User 
Timers, Nonvital User Timers, and Set SIN. 
 

 
 
If the selected User 
Parameters option is 
not programmed in the 
MCF, a message 
appears (see right): 
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Tools Menu- Currently, the Tools menu contains only one option: Sniffer (see detail below). 

 
 

NOTE
 

The Sniffer option is provided as a diagnostic tool primarily for use by Siemens 
Rail Automation Engineering personnel. 

 
In GEOMCF Manager, there is a GEO Simulator running to simulate message traffic between the 
GDT utility and the GWE when functions are performed such as “set SIN”, etc. The Sniffer option 
of the GEOMCF Manager Tools menu monitors ATCS message activity between the user interface 
(UCN Calculator) in the GEOMCF Manager utility and the active function. It displays the message 
bytes for evaluation. Select “Sniffer” from the Tools menu to display the Sniffer screen (figure 2-
10). 

 
Figure 2-10.  Typical Sniffer Display 

 
Sniffer is a dynamic display. As new message traffic occurs, it is added to the bottom of the 
display and the message list scrolls up screen.  
 
Select the Stop button to freeze the display so that currently displayed messages may be 
examined. The button label changes to Continue. Select the button again to continue monitoring 
messages as they occur. 
 
Select the Clear button to remove all currently displayed messages from the screen. New 
messages will appear on the display as they are sent or received. 
 
Select the Close button to exit this display and return to the function partition display. 
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2.2.5.2 Setting Vital/Nonvital User Options, I/O and Timers 

 
1. Select the first MCF for the application in the Installations tab, then click on UCN 

Calculator. The GEO UCN Calculator window is displayed (see example in figure 2-11). 

 
Figure 2-11.  Example GEO UCN Calculator Window 

 
2. Click on the Configure menu. If any Vital or Non-vital User Options, User I/O, or User Timers  

are configured, click on them to display the window (see example for Nonvital User Options in 
figure 2-12). 

 
Figure 2-12.  Typical Nonvital User Options Window 

 
3. Click on the Curr. button at the top left of the screen to refresh the current option selections.  
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WARNING
 

WHEN CHANGING VITAL USER PARAMETERS, THE INSTALLATION 
NEEDS TO BE REVALIDATED IN ACCORDANCE WITH RAILROAD 
PROCEDURES FOR QUALIFYING IN-SERVICE INSTALLATIONS. 

 
 

 

WARNING
 

SETTING VITAL USER PARAMETERS INCORRECTLY COULD RESULT IN A 
HAZARDOUS EVENT. THE IMPLEMENTATION OF VITAL USER 
PARAMETER CHANGES AND THEIR EFFECTS ON RAILROAD SAFETY 
ARE THE RESPONSIBILITY OF THE RAILROAD. 

 
 
4. Click on the “Value” field of the desired option to display the Current Options list control box 

(refer back to figure 2-12) and click on the down arrow button (  ) to display the drop-down 
options list. The current selection is highlighted (see detail below). 

 
5. Select the desired value/option from the drop-down list (e.g., 2) by highlighting it. The drop-

down list closes (see detail below). 

 
 

NOTE
 

The available values/options depend on the type of Option selected and 
established in MCF. 

 
6. Verify that the desired selection is now displayed in the “Value” field, then click out of the 

control box to close it. 
 
7. Make any other value/option changes as desired. 
 
8. Click on the Apply button at the top of the screen. To verify that the value was accepted, click 

on the Curr. button. The desired value should appear in the value column. 
 
9. Click on the Exit button to close the options window. 
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2.2.5.3 Setting Configuration / Operating Parameters 

 
1. In the GEO UCN Calculator window, right-click on the header for any module (slot number) 

that has user-configurable Configuration Parameters or Operating parameters (see figure 2-13 
for a typical Operating Parameters window (e.g., VPI Slot 3). 

 

 
Figure 2-13.  Typical Operating Parameters Window 

 
 

 

NOTE
 

Making changes to Module Configuration or Operating Parameters does not 
affect the UCN. 
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WARNING
 

SETTING CONFIGURATION OR OPERATING PARAMETERS INCORRECTLY 
COULD RESULT IN A HAZARDOUS EVENT. THE IMPLEMENTATION OF 
CONFIGURATION AND OPERATING PARAMETER CHANGES AND THEIR 
EFFECTS ON RAILROAD SAFETY ARE THE RESPONSIBILITY OF THE 
RAILROAD. 

 
 
2. Click on the Curr. button at the top left of the screen to refresh the current selections. The 

settings are listed in the “Value” column, and the units of measurement are in the “Units” 
column. 

 
 

NOTE
 

It may be necessary to widen the fields in order to view full properties, values, or 
units. 

 
 

 

NOTE
 

The default values may be confirmed by clicking on the Apply button, or they 
may be changed. 

 
 
3. Click on the “Value” field of the desired property to highlight it and display the spin control 

box with the + (plus) and – (minus) spin controls (see detail below). 

 
4. Click on the + or – spin button to increase or decrease the value by valid amounts (see detail 

below).   
 

 
 

 

NOTE
 

The value range, units and valid increments depend on the type of property 
selected (established by the MCF). 
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5. Verify that the desired value is now displayed in the “Value” field. 
 

 

NOTE
 

If an invalid value is attempted, an error message similar to the one shown below 
is displayed. 

 

 
6. Click anywhere on the “Operating Parameters” screen to close the spin box.  The changed 

value will be displayed (see detail below for an example of a changed value). 

 
7. Make any other desired changes in a similar manner. 
 
8. Click on the Apply button at the top of the “Operating Parameters” screen for the module 

slot or function partition. To verify that the value was accepted, click on the Curr. button. The 
desired value should appear in the value column. 

2.2.5.4 Calculating/Viewing UCN 

The UCN is continuously calculated as changes are made to the configuration. It is calculated over 
the MCF, SIN, vital parameters, and in some cases over the MEF. 
 
To view the calculated UCN at any time, from the Installations tab, right-click on the MCF in 
question and select UCN. The UCN window appears (figure 2-14). Click on OK to close the 
window. 
 

 
Figure 2-14.  UCN Window 
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2.2.5.5 Printing the GEO Installation Listing 

When configuration is complete and the user is ready to print out the GEO Installation Listing, do 
the following: 
 
1. From the File menu (before the document to be printed is displayed), select Print Setup…. 
 
2. Select the destination printer, select the paper size, source and orientation, and click on OK to 

close the window. 
 
3. Open the document to be printed by right-clicking on the desired installation icon to display 

the pop-up menu, click on GEO Installation Listing, and when the document is displayed, 
click on Print from the File menu. The document will print to the selected printer. 

 
Refer to Appendix A for a sample GEO Installation Listing. 

2.2.5.6 Setting In / Out-of-Service 

In-Service 
When configuration is complete and the user has printed out the GEO Installation Listing, the 
listing is handed over to the Maintainer so that the GWE can be placed in operation. To do this, 
the Maintainer, at the site, uses the information on the GEO Installation Listing to set SIN, 
operating parameters, and the UCN in the GWE, and reboots the unit. The Maintainer then enters 
his name, signature and date in the “Commissioning” box in the GEO Installation Listing. 
 
After the GWE has rebooted and is operational, the Maintainer must review the event log and 
record the In-Service Check Number on the GEO Installation Listing In-Service box and give it to 
the office so that the GEOMCF Manager can be updated to In-Service. The user at the office sets 
the In-Service Check Number into GEOMCF Manager as follows: 
 
1. On the Installations tab, expand the tree for the selected installation to display the MCF in 

question and right-click on it to display the pop-up menu (see detail below). 
 
 
 
 
 
 
 
 
 
2. From the pop-up menu, click on In-Service. The In-Service window is displayed (figure 2-15). 

Select In-Service to 
display the In-Service 
window. 
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Figure 2-15.  In-Service Window 

 
3. In the In-Service window, type in the In-Service Check Number recorded from the GWE, and 

click on OK. 
 
4. The MCF icon in the Installations tab should have changed (indicating an “i” and a downward 

arrow) and should now be displaying green instead of red to indicate the MCF is in service 
(see detail below). 

 
 
 
 
 
 
 
5. Also, now when the user right-clicks on the MCF in the Installations tab to display the pop-up 

menu, the In / Out-of-Service option is “Out-of-Service” (see below). 
 
 
 
 
 
 
 
6. On the GEO Installation Listing, the user enters his name, signature, and date in the In-Service 

box. 
 
Out-of-Service 
To take an operating GWE out of service, the Maintainer at the site sets the unit out of service or 
“unconfigured” and reboots the unit. 
 

 

NOTE
 

One way that a GWE can be set to “unconfigured” is to disable the MCF. 
 

 

Installed MCF (red) 

MCF placed In-Service (green) 

Pop-up menu option is 
“Out-of-Service” when 
the MCF is in service 
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After the GWE has rebooted and is unconfigured, the Maintainer must review the event log and 
record the Out-of-Service Check number on the GEO Installation Listing Out-of-Service box and 
give it to the office so that the GEOMCF Manager can be updated to Out-of-Service. 
 
The user at the office places the MCF “Out-of-Service” in GEOMCF Manager as follows: 
 
1. On the Installations tab, expand the tree for the selected installation to display the MCF in 

question (displaying green with an “i” and a downward arrow) and right-click on it to display 
the pop-up menu (see below). 

 
 
 
 
 
 
 
2. From the pop-up menu, click on Out-of-Service. A confirmation prompt is displayed (see 

figure 2-16). 

 
Figure 2-16.  Out-of-Service Confirmation Promp 

 
3. Click on Yes to take the MCF out of service. 
 
4. The icon for the MCF changes to a gray color and displays an “o” with an upward arrow to 

indicate the MCF is out of service (see detail below). 
 
 
 
 
 
 
 
5. On the GEO Installation Listing, the user enters his name, signature, and date in the Out-of-

Service box. 
 

 

NOTE
 

Now, when the user right-clicks on the MCF in the Installations tab to display 
the pop-up menu, the In / Out-of-Service option is “In-Service”. 

 

Installed MCF (red) 

MCF taken Out-of-Service (gray) 

Select Out-of-Service 
to place an MCF out of 
service in GEOMCF 
Manager 
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APPENDIX A 
SAMPLE GEO INSTALLATION LISTING 

 
Safetran Systems Corporation 

GEO Installation Listing 
testGEO 

MCF: UCCB003.mcf  Created: 14-Sep-2001 14:46  CRC: 9A8E0448 
 

 
1E035170 

 
 
 

Item • Value 
Location Name Safetran 
Milepost 123456789 
DOT Number Cucamonga 
Reviewer Monte D. Shipps 
Approver R. Selznick 
Comments Bidirectional colorlight w/ cab and options for double FY.   

Slot 1 = CPU/CPU2, Slots 2 & 6 = TRK, Slots 3 & 5 = CLS, Slot 4 = RIO 
Test for: Track display status 

 
 

700000000000 
 
 
 
• Slot 2 – Coded Track Module 

 

• Configuration Parameters 
None 

 
• Operating Parameters 
• Name • Value 
VCO Voltage 2000 mV 
Receive True 
Transmit True 
Code 5 Alternating 
EC4 Compatibility EC4 Plus 
Non-vital Change 2 cycles 
Vital Change 2 cycles 
Shunt Drop 2 cycles 
Shunt Pick 5 cycles 
Current Limit 10000 mA 

 
• Slot 3 – Colorlight Module 
Configuration Parameters 
None 

 
• Operating Parameters 
• Name • Value 
Lamp Voltage 9000 mV 
Filament Threshold 0 mA 
Cold Filament Test Yes 
VPI Debounce 20 ms 
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Safetran Systems Corporation 

GEO Installation Listing 
testGEO 

MCF: UCCB003.mcf  Created: 14-Sep-2001 14:46  CRC: 9A8E0448 
 
• Slot 4 – RIO Module 
Configuration Parameters 
None 

 
• Operating Parameters 
• Name • Value 
VPI Debounce 20 ms 

 
• Slot 5 – Colorlight Module 
Configuration Parameters 
None 

 
• Operating Parameters 
• Name • Value 
Lamp Voltage 9000 mV 
Filament Threshold 0 mA 
Cold Filament Test Yes 
VPI Debounce 20 ms 

 
• Slot 6 – Coded Track Module 

 

• Configuration Parameters 
None 

 
• Operating Parameters 
• Name • Value 
VCO Voltage 2000 mV 
Receive True 
Transmit True 
Code 5 Alternating 
EC4 Compatibility EC4 Plus 
Non-vital Change 2 cycles 
Vital Change 2 cycles 
Shunt Drop 2 cycles 
Shunt Pick 5 cycles 
Current Limit 10000 mA 

 
 
 

 Vital User Options 
• Option • Valu

e 
EOPT False 
WOPT False 

 

• Non-vital User Options 
• Option • Valu

e 
ETKC5 Off 
WTKC5 Off 
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Safetran Systems Corporation 

GEO Installation Listing 
testGEO 

MCF: UCCB003.mcf  Created: 14-Sep-2001 14:46  CRC: 9A8E0448 
 
 
 

 None 
 
 
 

 None 
 
 
Installed by:  
Signature:  
Date:  

 
 

In-Service Check Number:  
Authorized by:  
Signature:  
Date:  

 

 
 

Out-of-Service Check Number:  
Authorized by:  
Signature:  
Date:  
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