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1. Introduction 

1.1 Purpose 
Provide information for user operation of the Siecom software. 

1.2 Scope 
This handbook covers both the Pocket PC and PC version of the software. 

1.3 Definitions, Acronyms and Abbreviations 
CDF Command Definition File, this name has been superseded by EDF 

CFE Command File Editor 

EDF Equipment Definition File 

EWD Equipment Wireless Device 

ITD Intelligent Terminal Device 

PI Periodic Inspection 

SDF Script Definition File, this name has been superseded by SPT. 

SFE Script File Editor 

SPT Script file 

1.4 References 

1.4.1 External Documents 
TR2210   Specification for Traffic Signal Controllers 

1.5 Terminology 
 

Tap 

• PDA - tap with the stylus.  

• PC - left click. 

Tap and hold 

• PDA - tap and hold with the stylus.  

• PC - right click. 
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2. Siecom Software 
 

2.1 Introduction 
Siecom is a local vicinity wireless communications device and is designed to allow communications 
between on-street traffic equipment and authorised maintenance personnel without the need to access 
either the cabinet or equipment. The main benefits of fitting a Siecom (EWD) to an outstation are: 

a) It allows communications to on-street equipment to be established from the comfort of your vehicle 
or from a vantage point, as long as it is within the specified range of the device. 
b) It eradicates the exposure of live electrical equipment to the elements i.e. rain, snow, etc., on 
operations that would normally require the cabinet to be opened for communications, via interface 
cables, to take place. 

 
 Siecom is comprised of three main components, these are: 

1. An Equipment Wireless Device (EWD) – This is a Bluetooth device which is fitted to the on-street 
equipment and connected to a TR2210 handset port.  

2. Siecom Handset Software – The product software that provides the front end user interface tool.  

3. A Pocket PC or PC – This is the hardware, with Bluetooth support, that the Siecom Handset 
Software runs on. 

A wired connection rather than the wireless Bluetooth linking can be supported.  
The Siecom software supports: 

• Outstation handset commands support.  

• Across equipment/equipment specific script files.  

• User defined command names. 

• Consistent output logging and formatting. 

 

2.2 Health and safety 

 

 

Warning 

 

Siecom hardware includes an Equipment Wireless Device that only transmits when a wireless 
connection is made from authorised maintenance personnel using Siecom software. 
When connected to Siecom, the wireless transmitter within the plastic case should have a separation of 
at least 20cm between the case and the body of the user or nearby persons, excluding hands, wrists, 
feet and ankles. 
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2.3 Getting Started 
 
The Siecom software is normally supplied preinstalled. However to install the software manually the 
following steps will need to be followed. 
 

• Install the CD into the CD drive. 
• If the Welcome screen does not appear right click on the CD drive icon under My Computer and 

select ‘Autoplay’. 
• Click on the appropriate ‘Install’ button. 
• Follow the onscreen instructions. Accepting default options will perform a default installation. If 

asked whether to replace files, click ’Yes to all’. 
• On the Pocket PC version, click ‘OK’ on any warning messages about screen size. 

 
The software, online help and default data files will now be installed. 
 
If you are using a Bluetooth card insert this now into the appropriate slot in the device. 
 
If this is the first time starting after a Hard reset and reinstall on a Pocket PC, then you first need to refer 
to Reserving a Pocket PC Com Port. 
To start Siecom tap the ‘Windows’ symbol in the top left of the screen, select the ‘Programs’ menu 
option and tap on the ‘Siemens Siecom’ icon. If the 'Siecom Initialising' window remains on the screen, 
see Initialising Siecom for more info. 
The Siecom software requires a licence code to run. When the software is first run a message will be 
displayed with an activation code (only for manual install/reinstall).  
If you do not have a licence code already, obtain the licence code by phoning Siecom Sales at Siemens 
on 01202 782000. The activation code and your name and business name will be required. The licence 
code can be entered or changed on the Help -> About menu option.  

1. Before using the features of the software there are a few options that must be specified prior to 
use. To view these options select View -> Options from the menu. See Setting Siecom Options.  

2. The next step is to create a new site using the Site -> New... menu option. This allows the 
configuration of the site to be setup. See Managing Sites for more info. 

3. Next select Site -> Connect to connect to the site. Upon successful connection commands can 
then be entered and sent to the outstation. See Using When Connected for more info. 

 

2.4 Initialising Siecom 
If there is a problem checking the hardware the 'Siecom Initialising' screen will remain on the screen as 
shown below: 
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If the message ‘Hardware not responding’ is displayed then one of the following conditions exists: 

• Bluetooth CF card hardware not inserted.  
Select the 'Exit' option, insert the hardware and restart Siecom. 

• Windows can not talk to hardware.  
Select the ‘Soft Reset’ option to restart windows on a Pocket PC. 

The other condition that can occur is the initialisation takes longer than normal. Under these 
circumstances a 'Retry' button is displayed. Press this to continue trying, or on a Pocket PC press 'Soft 
Reset' to fully reinitialise the device. 
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2.5 Setting Siecom Options 

• Direct Com Port 
Select an appropriate physical port to be used for wired connection. Pocket PC's only support 
ports 1-9 and on a number of devices these can all be pre-allocated at manufacture. In this 
situation a port will have to be disabled to allow Siecom to use the desired port. Contact Siecom 
Support at Siemens if assistance is required. 

• Wireless Com Port  
Select a free port to be used for wireless connection. This can be the same as the direct com port 
although only one can be used at a time. 

• Command History Limit  
Controls the number of previous commands held for quick re-selection via the command entry 
field. Default is 5. 

• Default Quick Key File 
If a specific quick key file is not selected for a particular site then entries from the default quick 
key file will be displayed. 

• On startup, open 
Allows the startup to be configured to open either a specific site or the last site you were 
connected to. 

• Debug On 
This option turns on a software trace file output. Under normal usage this should remain switched 
off as it will reduce the performance of the application, only enable at the request of Siemens. 
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2.6 Managing Sites 
Prior to attempting communication with the on-site equipment, you need to create and select a 'site' 
definition file, using the software. A site is normally associated with a junction or cabinet or at a physical 
level, a handset port. 
A ‘site’ definition file contains information on the communication method, wireless address (where 
appropriate), equipment type, communication settings, and any additional useful reminder information. 

Site Definition File Creation 
To create a new site definition file, select Site -> New from the menu. A blank site properties window is 
displayed allowing the site information to be entered.  
To learn about site properties see Site Properties. 

Site Definition File Selection 
To select an existing site definition file select Site -> Open from the menu. A file browsing window will be 
displayed to allow the site file to be selected. Once the file has been selected a prompt will be displayed 
asking if you want to connect to the site. If you are opening the site to make configuration changes or just 
to view the settings select the ‘No’ button. If you want to connect to the equipment select the ‘Yes’ button, 
see Site Connection. 

Saving Site Definition File Changes 
To save select the menu Site -> Save. 

Cloning a Site Definition File 
It is possible to clone a site by opening an existing site definition file, changing the address and specific 
information and selecting Site > Save As... 

 
Site Definition File Properties 

Info Tab: 

• Site Id 
This is the unique site reference identifier and will be used as the default file name for the site 
definition file. Can also be used in scripts. 

• Name 
A user friendly name for the site. Can also be used in scripts.  

• Description 
This gives the user information regarding equipment configuration, location, etc. 

Settings Tab: 

• Quick Key File 
Allows a specific quick key file to be used for this site only. See Quick Key Editor for details on 
creating quick key definitions. 

• Primary Equipment File 
Allows an equipment file to be specified. The primary file is configured for the equipment, whose 
handset port, Siecom will be connected to, such as an OMU (Outstation Monitoring Unit). All sites 
must have a correctly configured primary file as this contains the information on how to talk to the 
specific type of equipment. When the equipment file is changed a prompt will ask if you want to 
use the default communication settings for the equipment. Under normal circumstances ‘YES’ 
should be selected, as this will remove the need for manual input of some of the communications 



Siecom   Version:           4.0 
SIECOM HANDBOOK   Date:  07/01/2009 
667/HB/30875/000 
 

 ©Siemens Traffic Controls, 2006 Page 10 of 41 
 

settings referenced below. If an existing equipment file does not exist for the equipment being 
connected to then one will need to be created. See Equipment Editor. 

• Secondary Equipment File 
Allows an alternative equipment file to be specified for a single site. The secondary file is for 
equipment that can be communicated to via the primary equipment, i.e. a controller accessed via 
an OMU. If an existing equipment file does not exist for the equipment being connected to then 
one will need to be created. See Equipment Editor. 

Comms Tab:

• Connection Type 
Defines whether the site connects via direct or wireless connections. This basically defines 
whether an EWD (Equipment Wireless Device) is fitted at the site. 

• Address 
If the connection type is wireless then the address of the EWD must be configured. The EWD 
address is the Bluetooth MAC address and is in the format XX:XX:XX:XX:XX:XX where X is a 
hexadecimal digit in uppercase. 

The following settings are those loaded from a specified equipment file if selected. 

• Baud Rate 
Speed of the connection to the handset port. 

• Data Bits 
Number of databits sent in each byte. 

• Stop Bits 
Number of stop bits for each byte. 

• Parity 
Type of check bit used to validate the byte. 

• Send Time Out 
The number of milliseconds to wait for an echoed command when sending a command to the 
equipment. 

• Read Time Out 
The number of milliseconds to wait for a reply to a previously sent command. 

Click the OK button to close the properties window. At this point any changes are not saved. To save, 
select Site -> Save. 

 

2.7 Site Connection 
Once a site file has been successfully opened it is possible to connect to the equipment by selecting Site 
-> Connect from the menu. For wireless connections this can take a number of seconds especially if the 
Bluetooth is switched off, and also depending on the current environmental conditions. It is recommended 
to start at a close distance for the first connection to ensure range is not an issue. Generally once the 
connection is established the range can be increased to a point beyond that at which an initial connection 
could be achieved. If repeated connections fail, then a SOFT reset of the Pocket PC may be required.  
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2.8 Site Disconnection 
Once the equipment connection is no longer required, select Site -> Disconnect to close down the 
connection to the equipment.  

 

2.9 Using commands when connected 
Once connected, the output window and command entry window will be displayed, as shown below. 

   
Commands are entered by various methods as described below, with the text ending up in the command 
entry field at the bottom of the screen. To action the entered command press the 'GO' button. 
 
Pocket PC input tools.
The standard input panel (SIP) can be used to enter text and is activated from the bottom menu bar. 
Quick Keys
To speed up entry of commonly used commands or key sequences, the software provides the concept of 
Quick Keys. This is a predefined list of items which can be selected from the toolbar button or the 
actions menu. For details on creating quick keys see Quick Key Selection. 
Command History
If recent commands need to be repeated, then this can be accomplished by pressing the  button on the 
command entry field. The last few commands are displayed in a list for quick selection, any amendments 
can be performed and 'Go' pressed to action the command. See Setting Siecom Options to change the 
number of commands remembered. 
Responses or output from the commands are displayed in the output window, unless the output has been 
reconfigured. To learn more about configuring the output see Configuring Logging Output. 
Commands can be one of 3 types, Direct, Indirect and System. To learn more about commands select 
the relevant link. 

 

2.10 Quick Key Selection 
Simply click one of the quick key entries to insert the text displayed into the command entry field at the 
current cursor position. 
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Then on the main window edit as required and click 'Go'. If the entry you require is not in the current 
quick key file, it is possible to temporarily change the current quick key file by selecting the Actions -> 
Select Quick Key File.. menu option. 

 

2.11 Configuring Logging Output 
It is possible to control the content and format of logging output from the connected session.   
Examples of output content that can be included or excluded are: Actions, Commands, Comments, 
Prints, Responses and Tables. 
Examples of format types are: CSV, HTML, Screen and Text. 
By default the content options are different depending on the format; however these can be manually 
changed through the Actions -> Logging -> Settings menu or through System Commands. To learn 
more see System Commands. 
New output files can be created, but are restricted to one active file of each format type at any one time. 

 

2.12 Direct Commands 
Direct Commands are commands that are native to the connected equipment. They are equivalent to 
using the software as a dumb terminal; however the responses will still be processed by the software to 
report errors etc. To learn more about reporting errors see Response Formats.  
Examples of Siemens equipment direct commands are 
MIN A 
TOD 
FLT 
For example the TOD above will only return the Time Of Day once.  
Special instructions are provided that change how a direct command is performed.  
POLL (polling for responses) 
Precede the direct command with the command POLL, i.e. 
POLL TOD 
The software will continually read the time of day from the equipment. To stop the polling of the 
command, press the Stop button in the toolbar. 
MLR (multi line response) 
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This is used when a multi line response is expected. i.e. This is used when a log report is requested from 
a Smartlink outstation. 
MLR LOG 
The software will read line responses until there is no more to read. 

 

2.13 Indirect Commands 
The concept of Indirect Commands is that a single generic command can be created and run on different 
manufactures and models of equipment. This offers the benefit to new users only having to learn one 
general instruction set rather than one for each manufacturer and the associated quirks. The other benefit 
is that if used within script files then a general script can be run on different equipment speeding up the 
task in hand. They are extremely powerful and flexible; however this does make them relatively 
complicated. The indirect command can also be typed in manually into the command entry field as well 
being used in script files. 
Example 
Indirect command - ClearLog 
Manufacturer1 direct command - EFLT 
Manufacturer2 direct command - RSTFLT 
Parameters can be supplied to the indirect command and mapped to the correct position in the underlying 
direct command. If an operation on one piece of equipment takes 2 direct commands then this can be 
configured too. The final response can also be validated to check for correct operation. 
To create/modify or view the configured Indirect commands for the equipment you are talking to use the 
Equipment Editor and view the commands tab. See Equipment Editor and Defining Indirect Commands 
for more info. 

NB: To use an indirect command it must be prefixed with an '!' i.e. 

!RSTFLG 

 

2.14 System Commands 
System Commands are commands that allow software features to be altered and/or functions performed. 
Examples are running a script file, creating an output file or storing response data for later use or even 
alerting the user. The full list of commands have been split into the following sections :- 

2.14.1 Output File Control Commands 
This group of commands allows output files to be opened and closed etc. 
$APPENDOUT <format> <filename> 
Description - Appends to an output file if it exists, otherwise creates it.. 
Parameters 

format 

This determines the type and default content of the file. Valid values are-  
 
txt,  
csv,  
html,  
raw 

filename The filename or full path to the file. 
Example: 
$APPENDOUT txt "\My Documents\Siecom Data\my file.txt" 

 
$ENDOUT <format> 
Description - Ends an output file if currently open. 
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Parameters 

format 

This determines the type of output file to close. Valid values are-  
 
txt,  
csv,  
html,  
raw 

Example: 
$ENDOUT txt 

 
$NEWOUT <format> <filename> 
Description - Creates a new output file, overwriting an existing file if it exists. 
Parameters 

format 

This determines the type of output file to close. Valid values are-  
 
txt,  
csv,  
html,  
raw 

filename The filename or full path to the file. 
Example: 
$NEWOUT txt "\My Documents\Siecom Data\my file.txt" 

 
2.14.2  Output Control Commands 
 
This group of commands control the output content of output formats. 
$DISABLE <format> <item to disable> 
Description - Disables output of the item specified for the specified format. 
Parameters 

format 

This determines the type of output file to disable output for. Valid values are-  
scr, 
txt,  
csv,  
html,  
raw 

item to 
disable 

Item to disable i.e.  
Logging 
Command 
Action 
Print  
Comment 
Response 
Table  

Example: 
$DISABLE txt Command 

 
$ENABLE <format> <item to disable>  
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Description - Enables output of the item specified for the specified format. 
Parameters 

format 

This determines the type of output file to disable output for. Valid values are-  
scr, 
txt,  
csv,  
html,  
raw 

item to 
disable 

Item to disable i.e.  
Logging 
Command 
Action 
Print  
Comment 
Response 
Table  

Example: 
$ENABLE txt Command 

 
$PRINT <info> 
Description - Prints the information to any enabled outputs. 
Parameters 

info 
The information to output, this can be text, variable values etc. If the info contains spaces the info 
must be enclosed in quotes (""). 
  

Example: 
$PRINT "Intergreen timings" 

 
 $PRINTLN <info> 
Description - Prints the information to any enabled outputs, including a carriage return to move the 
position to the next line. 
Parameters 

info 
The information to output, this can be text, variable values etc. If the info contains spaces the info 
must be enclosed in quotes (""). 
  

Example: 
$PRINTLN "Intergreen timings" 

 
$SCRIPTOUT <state> 

Description - Controls whether run scripts are allowed to control the output content using the Enable and 
Disable commands. The default state is on. 

Parameters 

state 
The values are on and off. 
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Example: 

$SCRIPTOUT on 

Will enable any run nested script to control its output content. 

 
2.14.3 Table Output Commands 
This group of commands allow tables of response data to be generated in the output. 
$ADDHEAD <heading>  
Description - Adds a column to the table using the heading specified. 
Parameters 
heading The name of the column. Use "" if name not required. 
Example: 
$ADDHEAD "Phase Number" 

 
$ALIGN <alignment>  
Description - Sets the default text alignment for table columns. Future columns added will use this setting. 
Parameters 

alignment 
Valid values are: 
left 
center 
right 

Example: 
$ALIGN left 

 
$ENDROW 
Description - Ends the current row of the table. 
Parameters 
None. 
Example: 
$ENDROW 

 
$ENDTABLE 
Description - Ends a table output 
Parameters 
None. 
Example: 
$ENDTABLE 

 
$OUTPUTCOL <output>   
Description - Outputs a column value in the current row in the current table. 
Parameters 
output This can be a fixed text string or a variable value or a comination of both. 
Examples: 
$OUTPUTCOL "Phase" 

$OUTPUTCOL "Phase &Value" 
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$PRINTHEADINGS   
Description - Prints the headings of the table. 
Parameters 
None 
Examples: 
$PRINTHEADINGS 

 
$ROW   
Description - Starts a new row in a table. 
Parameters 
None. 

 
$SETWIDTH <width>   
Description - Sets the table columns width. Any future columns added will use this setting. 
Parameters 
width This is the number of characters the column can hold. 
Example: 
$SETWIDTH 20 

 
$TABLE   
Description - Starts a table output. 
Parameters 
None. 

 
Full Table example: 
; 
; Start a table  
$TABLE  
;  
; Output headings  
$ADDHEADING -  
$FOR SiemensPhase ph2 A F  
    $ADDHEADING &ph2  
$ENDLOOP  
$PRINTHEADINGS  
;  
;  
$FOR SiemensPhase ph1 A F  
    $ROW  
    $OUTPUTCOL &ph1  
    $FOR SiemensPhase ph2 A F  
        $OUTPUTCOL (&ph1-&ph2)  
    $ENDLOOP  
    $ENDROW  
$ENDLOOP  
;  
; End the table  
$ENDTABLE 
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2.14.4 Script Control 
This group of commands assist with the progress and control of script files. 
; <comment>  
# <comment>
/ <comment>  
Description - Allows a comment to be entered into the script file without affecting execution. 
Parameters 
comment The message in the comment. There must be a space before the actual comment. 
Examples: 
; About to run a script to reset the fault log 
# About to run a script to reset the fault log 
/ About to run a script to reset the fault log

 
$ASSIGN  <variablename> <group captured value> 
Description – Allows response data from the previous command to be stored in a variable for later use in 
a script file. 
Parameters 

variablename This is the name of the variable to store the value in for later use in a script. To later 
use an assigned variable precede the name with an & (ampersand) 

group 
captured 
value 

- captured value can be index into regular expression () or named item, A value of 0 
stores whole of last response. 

Examples: 
PIC 
$ASSIGN SW_VERSION 0 
$PRINT "Using software version &SW_VERSION"
The above example will store the result of the PIC command into a variable called SW_VERSION. This 
can be used later. 

 
$CONF "message"  
Description - Displays a message to the user for confirmation before allowing a script to proceed. 
Parameters 

message The message to display to the user. The message should be contained within quotation 
marks (""). 

Examples: 
$CONF "Check the controller fault light is lit before continuing." 

 
$DEFINE <alias> <text>  
Description - Replaces alias with text. This is useful when text needs to be repeated many times in a 
script, as if the text needs changing it only has to be changed once. 
Parameters 

alias The name of the alias used. This can be any text, however it is recommended to start 
alias's with a special character for script reading clarity. 

text The text to insert where the alias is used.
Examples: 
$DEFINE *Warning "This is a warning message" 
$PRINTLN "*Warning"
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$DEFINE *W PRINTLN 
*W "A message"

NB: if the above examples were used in the same script file then strange results may occur. This is 
because the *Warning maybe replaced with PRINTLN as the *W was matched first. Ensure the alias 
names are suitably different. 

 
$ENDLOOP  
Description - Ends a for or while loop. 
Parameters 
None 
Examples: 
$FOR SiemensPhase ph1 A D2 
    $PRINTLN &ph1 
$ENDLOOP

flt 
$ASSIGN result 0 
$WHILE result NOT "FLT: NO FAULTS" 
    + 
    $PRINTLN "&result" 
    $ASSIGN result 0  
$ENDLOOP

 
$FOR <type> <variablename> <initialvalue> <endvalue> 
Description - Allow a fixed number of iterations of contained commands to be executed. 
Parameters 

type 

The type of the variable to be incremented in the loop. Valid values are: 
TextParam, 
IntParam, 
SiemensPhase, 
PeekPhase, 
MicroSensePhase 

variablename The name of the variable to increment in the loop.  
Don’t use ‘&’ in front of variable name  

initialvalue The value at the start of the loop. 
endvalue The value at the end of the loop. 
Example: 
$FOR SiemensPhase ph1 A D2 
   $ PRINTLN &ph1 
$ENDLOOP

 
$PRIMARY 
Description - Switches to the primary equipment definition file. Any subsequent indirect commands will be 
checked against this file. 
Parameters 
None. 

 
$RUN <scriptfilename> 
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Description - Runs the specified scriptfile. This is how scripts can be nested within other script files. 
Parameters 
scriptfilename Filename and/or path to script file use "" if spaces  
Examples: 
RUN "\My Documents\Siecom Data\Test.spt". 

 
$SECONDARY 
Description - Switches to the secondary equipment definition file. Any subsequent indirect commands will 
be checked against this file. If there is no secondary equipment file configured then a warning will be 
output. 
Parameters 
None. 

 
  
$SET  <variablename> <value> 
 
Description - Allows a variable to be set to a constant value or other expression. 
 
Parameters 
 

variablename This is the name of the variable to store the value in for later use in a script. To later 
use an assigned variable precede the name with an & (ampersand) 

group 
captured 
value 

- This is the text value to store, can be the the contents of another variable. 

 
Examples: 
 
$SET TMP "No Error" 
$PRINT "Value in TMP is &TMP" 
$SET TMP2 &TMP 
$PRINT "Value in TMP2 is &TMP2" 

 
$WAIT <milliseconds> 
Description - Waits the specified number of milliseconds, before allowing subsequent commands to run. 
Parameters 
milliseconds The period to wait.  
Examples: 
$WAIT 1000 

 
$WHILE <variablename> <condition> <value> 
Description - Loops until the exit variable condition is met. 
Parameters 
variablename The variable to check. No &.  

condition 
The exit condition to check. 
IS 
NOT 

value The value to check against. 
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Examples: 
flt 
$ASSIGN result 0 
$WHILE result NOT "FLT: NO FAULTS" 
    + 
    $PRINTLN "&result" 
    $ASSIGN result 0  
$ENDLOOP

 
2.14.5 Predefined macros 
To aid in the use of system commands there are a number of predefined macros that can be used as 
parameters to system commands, aswell as other types of commands. They are defined as follows. 

• %date – current date.  

• %filetime - current timestamp suitable for use in a filename.  

• %lastresponsetype - the type of the last response from the outstation, possible values are : 
notavailable, unknown, generic, other, expected. 

• %script – script file name.  

• %siteid – id of the site.  

• %sitename – name of the site.  

• %time – current time.  

• %user – logged on user. 
For example to print a line with the current date and time, the following command would be used. 
$println "%date %time"
The quote marks are required to indicate that both macros are a single parameter to the $println function. 
These may also be required when using a single macro. i.e. 
$println "%user"
This is because the %user will be converted into the logged on username which is likely to be 2 names 
separated by a space. So the actual command is really. 
$println "Fred Bloggs" 

 

2.15 Run Script 
The Run Script menu option allows a script file to be selected and run on the connected equipment. The 
software is restricted to allow 5 levels of script nesting. 
To stop a script running once started press the Stop button in the toolbar. 

 

2.16 Equipment Editor 
The equipment editor is accessed from the Edit -> Equipment menu on the main window. This allows the 
equipment information to be defined to allow support for particular equipment models. Follow the on 
screen prompt to create or open a file. Once a file has been selected the editor window is displayed. To 
assist in creating new equipment files a default file is provided called template.edf. This file contains all 
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the indirect command placeholders. To start with this file open it and do a File -> Save As... to copy it to a 
new file. 
Info Tab: 
This contains basic information about the equipment including the manufacturer, model and version. 
 
Responses Tab:  
 

 
• Generic Success Response Format 

A generic success response format can be defined here. Defining an overall generic format will 
speed up the processing of responses. It is most relevant if commands always return a certain 
format for the response, such as the mnemonic followed by a colon. 

• Other possible responses 
Other possible generic responses can also be defined, these are used for interpreting error 
conditions or capturing data. To manage these tap and hold in the list and a pop up menu will 
appear, allowing responses to be created, modified or deleted. 

To learn about response formats see Defining Response Formats. 
Settings Tab: 
The settings tab allows the following options to be set : 

• Timeout Action 
What the software does by default when a timeout occurs when waiting for a command response. 
The options are : 

Abort - Stop the command 
Continue - carries on with any further commands 
Prompt - prompts the user for a decision. 

• Command Terminator 
The characters used to terminate a command being sent (usually ^M the escape code for a 
carriage return).  
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• Wake Up Command 
This is the command sent to wake up the equipment upon connection. 

  

Comms Tab: 

• Baud Rate 
Speed of the connection to the handset port.  

• Data Bits 
Number of databits sent in each byte.  

• Stop Bits 
Number of stop bits for each byte.  

• Parity 
Type of check bit used to validate the byte.  

• Send Time Out 
The number of milliseconds to wait for an echoed reply when sending a command to the 
equipment.  

• Read Time Out 
The number of milliseconds to wait for a reply to previously sent command. 

 
Commands Tab:  
Allows indirect command definitions to be managed. Tap and hold in the list and a pop up menu will 
appear, allowing indirect commands to be created, modified or deleted. See Defining Indirect Commands. 

 

2.17 Quick Keys Editor 
The Quick Key Editor allows the creation and modification of the quick key files, it is 
accessed by the Edit -> Quick Keys... menu option. Follow the on screen prompt to create or open a 
file. Once a file has been selected the editor window is displayed.  
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The order of how the quick keys appear can be changed by selecting an entry in the list and using the 
corresponding ‘Move’ button. 
To add, delete or edit a quick key entry tap and hold the entry in the list. New entries are entered above 
the item selected. Text strings will be transferred to the command entry field exactly as entered when 
using the quick key definitions. Therefore any valid direct, indirect, system or partial commands can be 
defined. 
NB: New quick key entries are not available for use, unless the site is disconnected and reconnected, or 
by reselecting the Quick Key file using the Actions -> Select Quick Key File... menu option. 
 
When saving a quick key file, the location can be specified by selecting the appropriate folder. However 
the preferred locations for quick key files are:- 

• PDA - 'My Documents\Siecom Data'  
• PC - '\Program Files\Siemens Traffic\Siecom PC\Siecom Data'  

 
 

2.18 Script Editor 
The Script Editor allows the creation and modification of the quick key files; it is 
accessed by the Edit -> Script... menu option. Follow the on screen prompt to create or open a file. 
Once a file has been selected the editor window is displayed.  
 



Siecom   Version:           4.0 
SIECOM HANDBOOK   Date:  07/01/2009 
667/HB/30875/000 
 

 ©Siemens Traffic Controls, 2006 Page 25 of 41 
 

  
 
The editor window is a simple text editor, with standard edit features that can be used to copy sections of 
script to then paste into other script files. A basic command syntax checker is run by clicking the Validate 
button; this will prompt for a site file to check the indirect commands against the sites equipment file. 
 
Normally direct commands would not be used so that a single script will be compatible with different 
equipment. Full direct, indirect and system commands can be entered. When the script is run, these will 
be executed as if being manually entered but without the need for operator interaction. This process is 
similar to that of creating and running a batch file in DOS. 
 
When saving a script file, the location can be specified by selecting the appropriate folder. However the 
preferred locations for script files are:- 

• PDA - 'My Documents\Siecom Data'  
• PC - '\Program Files\Siemens Traffic\Siecom PC\Siecom Data'  

 
 
A step by step example of a script is given below. This particular script has been written to display 
firmware information by outputting the text “Firmware ID” in the first row of a table and the actual firmware 
version into the second row: 
 
In the screenshot below, the ‘$PRINTLN’ command sets the line header text that is to be displayed on 
the top line of the output. In this example, the text “Firmware Information” is to be displayed. The other 
variables determine the assigned firmware ID that is to be displayed on the final output. The first 3 lines 
are comments purely for information. 
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In the screenshot below, the ‘$TABLE’ command starts a table output. 
 

 
In the screenshot below, the next set of commands, ‘SETWIDTH 20’ & ‘ALIGN Center’, sets the column 
width and text alignment options within the table. 
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In the screenshot below, the ‘$ADDHEADING “Firmware Id”’ & ‘$PRINTHEADINGS’ commands, set 
the column text heading to be displayed at the top of the table output. 
 

 
In the screenshot below, the next command, ‘$ROW’, starts a 2nd row within the table output. 
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In the screenshot below, the next command, ‘$OUTPUTCOL’ outputs the value “Firmware Id” into the 
current row in the current table. 

 
 
 
In the screenshot below, the next command, ‘$ENDROW’, ends the current row of the table. 
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In the screenshot below, the command, ‘$ENDTABLE’, ends the current table output. 
 

 
 
 
In the screenshot below, the ‘$PRINTLN’ command prints a blank line after the table. 
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In the screenshot below, once the context of the script file has been determined, clicking on ‘Validate’ will 
check the script file and identify any problems or errors in the script compilation. 
 

 
The screenshot below show the final output of the script file based on the ‘Logging Settings’ that were 
selected in the next screenshot. 
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The screenshot below show the final output of the script file based on the ‘Logging Settings’ that were 
selected in the next screenshot. 
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2.19 Defining Response Formats 
Response formats are defined using 'Regular Expressions' which is an international standard formatting 
language. A full description is beyond the scope of this text, but numerous sources of information on 
'Regular Expressions' are available on the internet.  
The following reserved characters and their specification should be noted: 
\ 
[ 
] 
( 
) 
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< 
> 
- 
^ 
$ 
? 
* 
+ 
. 
These have special meanings in the expression, and if any of these characters are expected in the actual 
response then they must be escaped with the '\' character i.e. '\*R' would match a '*R' response. 
 
 
Group Capture Points 
From the response any of the data can be captured for later use by use of group capture points in the 
response format. These are defined by enclosing section within curved brackets (). By default all 
response formats have an invisible set of brackets around the whole response; this is accessed by group 
capture value 0. 
Example: 
If a date was a response in the format 
2005-05-26
To match this date exactly the 'response format' would be 
2005\-05\-26
If we wanted to store parts of this response for later script use such and the year/month and day, we 
could do the following. 
(2005)\-(05)\-(26) - the year would be group capture value 1, month 2 and day 3. or to make it more 
friendly do the following. 
(?<YEAR>2005)\-(?<MONTH>05)\-(?<DAY>26) - this uses named captures of YEAR, MONTH, DAY 
All of the above is not much use when the date is changing, to match any date in the 21 century would be 
(20[0-9]{2})\-(0[0-9]|1[0-2])\-([0-2][0-9]|3[0-1]) NB: This would not reject 31 of Feb though for example. 
That is more complicated!! 

 

2.20 Defining Indirect Commands 
Indirect commands provide a common way of performing different manufacturer 
commands. They are accessed from the Edit -> Equipment...  then File -> Open... and 
Command Tab options. Tap and hold an indirect command definition to access properties, add or delete 
a definition.  
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• Command Name 

The reference name given to the indirect command. NB: this must not include spaces. 

• Parameters 
Multiple parameters can be defined, and the order of these parameters can be swapped when 
performing the equipment commands, by using the relevant %n (n is the parameter number as 
listed in the Parameters list, starting at 1) marker as required. To add, delete and edit the 
parameters tap and hold an entry in the Parameters list and a popup menu will appear, this menu 
can also be used to rearrange the order of the parameters (The final response and equipment 
commands may then need amending to match). See Parameters for further information. 

• Final Response 
The final response allows data to be captured. This must be the last command in the Equipment 
commands list. To learn about response formats see Defining Response Formats. 

• Equipment Commands 
Multiple equipment commands can be defined, and they are run in the order of the list. To add, 
delete and edit the commands tap and hold an entry in the Equipment Commands list and a 
popup menu will appear, this menu can also be used to rearrange the order of the commands. 

 
2.21 Parameters 
Parameters are used within Indirect command definitions to allow correct mapping through to the 
underlying direct commands to perform. To access tap and hold an entry in the Parameters list on the 
Indirect Command Properties window. 



Siecom   Version:           4.0 
SIECOM HANDBOOK   Date:  07/01/2009 
667/HB/30875/000 
 

 ©Siemens Traffic Controls, 2006 Page 35 of 41 
 

 
• Description 

This is purely a useful reminder of what the parameter is. It can include spaces. 

• Type 
This is the type of the parameter, it is required for checking that the supplied value is the correct 
type, if checking is not required then TextParam can be selected. 

The valid options are: 
TextParam Any alphanumeric value can be entered 
IntParam A whole number can be entered 
MicroSensePhase A valid Microsense controller phase can be entered
PeekPhase A valid Peek controller phase can be entered 
SiemensPhase A valid Siemens controller phase can be entered 

• LowerBound 
This is the lowest value allowed within the type. 

• UpperBound 
This is the highest value allowed within the type. 
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2.22 Logging Settings 
 

 
 
During an interactive session it is possible to configure what output goes to the active output files or 
screen. Simply select each output type and check the options required for that type. The Logging Option 
controls all output and is useful for temporarily disabling output while carrying out some manual actions. 
These settings will also override any commands embedded in script files to the selection set. 

 

2.23 External Connection 
Siecom can allow external program to use the secure wireless connection provided by 
Siecom to communicate with the outstation device. To use this feature select the Site -> 
Allow External Connect menu option.   
 
The external program can now be run and the specified com port used to talk to the handset port. After 
use select Site -> Disconnect to release the connection, to allow normal Siecom reconnection.   
 

 

2.24 Exiting Siecom 
To exit the Siecom application, use the Site -> Exit menu option. This will auto disconnect from 
any connected site.  
NB: Tapping the cross in the top right of the screen will simply minimise the Siecom window. The site will 
remain connected while in range. Any executing script file will continue until further operator intervention 
is required. 
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2.25 Reserving a Pocket PC Com Port 
On a Pocket PC, only com 1-9 can be used. Most Pocket Pc's have all of these pre-allocated to built in 
facilities. In order for Siecom to use one of these assigned ports, it must be released from its default use. 
To change this setting, do the following.  
Copy the 'regedit.Mrln_ARM.CAB' file from the PHM regedit folder on the CD onto the Pocket PC. 
Using file explorer find the file and select it. Select 'OK' to any warning messages about screen display. 
From the Programs Folder run the ‘PHM RegEdit’ program. 

Find the folder HKEY_LOCAL_MACHINE\Drivers\BuiltIn in the top half of the screen as show below. 
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Find the built in Bluetooth serial port to override. NB: This will stop the built in Bluetooth from being able 
to use a serial port. 
On the Siemens Loox this is the Serial8 folder. 

 

In the bottom half of the screen select the Prefix entry and change the value ‘COM’ to read ‘SIECOM’, as 
show below. 



Siecom   Version:           4.0 
SIECOM HANDBOOK   Date:  07/01/2009 
667/HB/30875/000 
 

 ©Siemens Traffic Controls, 2006 Page 39 of 41 
 

 

Click 'OK', to close the PHM RegEdit program and select ‘Soft Reset’ for the Pocket PC to accept the 
change. 
 

3. FAQ 
•   What is the difference between a sending and reading timeout error? 

A sending timeout occurs when the echo of the command is not received. This usually indicated 
as basic communications mismatch between Siecom and the outstation. A reading timeout 
occurs when the outstation takes longer than expected to return the response for a command. 
This can occurs when using secondary equipment due to the delays passing through the primary 
equipment. 

• Script validation does not detect problems although when run errors occur. 
Script validation only occurs for system or indirect commands. These must be prefixed with the ‘$’ 
and ‘!’ respectively otherwise the commands will be assumed to be direct outstation commands 
that are not validated. 

• When I run a script file on a Pocket PC the pocket pc switches off and stops the script 
running. How do I stop this? 
Select the Start menu. Select Settings. Select the System tab. Locate and select the Power icon. 
Select the Control tab. Uncheck the On battery power: turn off device is not used for.. tick box. 
Click OK. 

• When a CSV file is created on the Pocket PC version, why won't it open with Pocket Excel? 
Pocket Excel does not support CSV file importing. The file will have to be copied to a desktop pc 
and opened with Excel. If the file needs to be opened in Pocket Excel, using the desktop pc Excel 
save as Windows 95/5.0 format or 97-2000 format. It can then be copied back to the Pocket PC 
and opened with Pocket Excel. 

• How do I commission an EWD? 
Create a new site properties file, using the address specified on the connector. Connect to the 
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site and send a command or run one of the commissioning scripts provided. Check a response is 
received from the outstation. 

• Where are the script or quick key files I created? 
The files will have been saved in the folder selected at the time of saving the file. Use the search 
or find facility of the device to locate the files. The preferred location for script and quick key files 
can be found in the Script Editor or Quick Key Editor sections. 

 

 

4. Trouble Shooting 
 

• Pocket PC Siecom will not accept the licence code although it previously worked. 
This occurs when there is a problem reading the information from the device. To resolve, a soft 
reset of of the Pocket PC is required. See the manufacturers’ instructions on how to perform this. 

• Unable to establish wireless connection. 
Primarily check the range and line of sight to the EWD, if necessary move closer and face the 
EWD. Retry the connection. If problems still exist check the properties of the site, ensuring the 
address is in the format XX:XX:XX:XX:XX:XX where X is a Hexadecimal digit in uppercase. 
Check the communications settings are correct and the primary equipment file is being used. 
Ensure the Bluetooth device is plugged in and the pocket pc has sufficient power to power the 
Bluetooth. Check in the Siecom options that the correct free comport is being used for wireless 
connections. Ensure that the EWD is plugged in correctly to the handset port of the outstation, 
remove and reconnect if necessary. 

• When initially connecting a read timeout occurs before any commands have been sent. 
This is due to the wakeup command that is sent on connection. The outstation uses this 
command to auto detect the baud rate of the terminal. If detection occurs on the first character 
sent, then it comes out of auto detect mode, and is not expecting further wakeup characters. This 
occurrence can be reduced by shortening the wake up command in the equipment editor or can 
be simply ignored by pressing the ignore button. 

• A script file validates ok, but when run a 2nd pass validation error occurs. 
This occurs because a variable has been used as a parameter to a command and the value 
inside the variable is not valid format as a parameter to the command. i.e. the variable value may 
have spaces in it, in which case the variable name must be enclosed in quotation marks "&tmp". 

• Bluetooth connection to a site continues to fail. 
Occasionally if the outstation has had power fluctuations the EWD may not initialise correctly. 
Unplug the EWD from the outstation handset port and re-plug in. Retry the connection. 

 
 

5. Siecom Hardware 
The EWD is the wireless device that is plugged into the outstations TR2210 handset port. These are 
programmed prior to installation to match the communications parameters for the particular equipment 
being connected to. 
 
Some 3rd party outstation equipment does not fully implement hardware flow control. This requires a link 
to be in place on the EWD. 
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We, Siemens plc, trading as Siemens Traffic Controls, declare that the Siecom Product Range is in 
compliance with the essential requirements and other relevant provisions of Directive 1999/5/EC. 
 
 

 
 
The EWD range is limited if the EWD or handheld terminal are too near the ground.  At 60m range, the 
Fresnel zone radius is 1.37m, and the signal strength will start to reduce if the path height is less than 
1.1m (80% of the Fresnel radius) above the ground. 
 
 

 
 
 
 
 
 
 
 

6. Contacts 
Should you require any assistance with Siecom please contact the relevant department at Siemens 
Traffic on 01202 782000.  

• Siecom Sales 
Additional equipment/software licences. 

• Siecom Marketing 
Product literature. Additional feature requests. 

• Siecom Support 
Problems with supplied hardware and/or software. 
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